summaryrefslogtreecommitdiffstats
path: root/network/dwb
diff options
context:
space:
mode:
author Ryan P.C. McQuen <ryan.q@linux.com>2016-01-29 10:27:02 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-02-05 07:02:33 +0700
commita6870d952669a96e5a72d091a4152192680fcce8 (patch)
treecfe0964ef8878099208e7d80406600567f2b430c /network/dwb
parent06e46fd9b1bd5fdc91b31dd86de17407df044005 (diff)
downloadslackbuilds-a6870d952669a96e5a72d091a4152192680fcce8.tar.gz
slackbuilds-a6870d952669a96e5a72d091a4152192680fcce8.tar.xz
network/dwb: Updated for version 20150726_dda5aa7 + new maintainer.
Signed-off-by: Ryan P.C. McQuen <ryan.q@linux.com>
Diffstat (limited to 'network/dwb')
-rw-r--r--network/dwb/dwb.SlackBuild42
-rw-r--r--network/dwb/dwb.info10
2 files changed, 37 insertions, 15 deletions
diff --git a/network/dwb/dwb.SlackBuild b/network/dwb/dwb.SlackBuild
index c60ae28851..fc108f8da9 100644
--- a/network/dwb/dwb.SlackBuild
+++ b/network/dwb/dwb.SlackBuild
@@ -1,9 +1,32 @@
#!/bin/sh
-# Slackware build script for dwb by Marcin Herda <mherda@slackword.net>
+# Slackware build script for dwb
+# Originally by Marcin Herda <mherda@slackword.net>
+
+# Ryan P.C. McQuen | Everett, WA | ryan.q@linux.com
+
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version, with the following exception:
+# the text of the GPL license may be omitted.
+
+# This program is distributed in the hope that it will be useful, but
+# without any warranty; without even the implied warranty of
+# merchantability or fitness for a particular purpose. Compiling,
+# interpreting, executing or merely reading the text of the program
+# may result in lapses of consciousness and/or very being, up to and
+# including the end of all existence and the Universe as we know it.
+# See the GNU General Public License for more details.
+
+# You may have received a copy of the GNU General Public License along
+# with this program (most likely, a file named COPYING). If not, see
+# <https://www.gnu.org/licenses/>.
PRGNAM=dwb
-VERSION=${VERSION:-20150419_8ba11e5}
+VERSION=${VERSION:-20150726_dda5aa7}
+SRCVERSION=${SRCVERSION:-dda5aa74a63a}
+SRCNAM=${SRCNAM:-portix-dwb}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -39,20 +62,19 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$SRCVERSION
+tar xvf $CWD/$SRCVERSION.tar.bz2 || tar xvf $CWD/$SRCNAM-$SRCVERSION.tar.bz2
+cd $SRCNAM-$SRCVERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# fix the location of man pages
sed -i '/^MANDIR/s/DATAROOTDIR/PREFIX/' config.mk
-
CFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
diff --git a/network/dwb/dwb.info b/network/dwb/dwb.info
index 18406326bf..7654b43f77 100644
--- a/network/dwb/dwb.info
+++ b/network/dwb/dwb.info
@@ -1,10 +1,10 @@
PRGNAM="dwb"
-VERSION="20150419_8ba11e5"
+VERSION="20150726_dda5aa7"
HOMEPAGE="http://portix.bitbucket.org/dwb/"
-DOWNLOAD="http://ponce.cc/slackware/sources/repo/dwb-20150419_8ba11e5.tar.gz"
-MD5SUM="65f3dd6352989feedf94e9a07e2c23d0"
+DOWNLOAD="https://bitbucket.org/portix/dwb/get/dda5aa74a63a.tar.bz2"
+MD5SUM="dd3ca8253e017b6d755c6dfaa9543ef6"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="webkitgtk"
-MAINTAINER="Marcin Herda"
-EMAIL="mherda@slackword.net"
+MAINTAINER="Ryan P.C. McQuen"
+EMAIL="ryan.q@linux.com"