summaryrefslogtreecommitdiffstats
path: root/network/ettercap
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2013-11-07 09:58:51 +0100
committer Robby Workman <rworkman@slackbuilds.org>2013-11-07 11:28:18 -0600
commitfcb5edca813643e70bddaba22d825ea28e27f160 (patch)
tree7234f8603749e876241fb28aeb7cecb5d797ef32 /network/ettercap
parent9b9a64eae969ad2f162613dfadaf540e6c98a39f (diff)
downloadslackbuilds-fcb5edca813643e70bddaba22d825ea28e27f160.tar.gz
slackbuilds-fcb5edca813643e70bddaba22d825ea28e27f160.tar.xz
network/ettercap: Updated for version 0.8.0.
Switched to cmake, cleanups, added switches Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'network/ettercap')
-rw-r--r--network/ettercap/README4
-rw-r--r--network/ettercap/doinst.sh5
-rw-r--r--network/ettercap/ettercap.SlackBuild62
-rw-r--r--network/ettercap/ettercap.desktop7
-rw-r--r--network/ettercap/ettercap.info6
-rw-r--r--network/ettercap/slack-desc11
6 files changed, 48 insertions, 47 deletions
diff --git a/network/ettercap/README b/network/ettercap/README
index d5416e6943..5eba7bab2f 100644
--- a/network/ettercap/README
+++ b/network/ettercap/README
@@ -9,3 +9,7 @@ ciphered ones) and includes many feature for network and host analysis.
It is free software, licensed under the terms of the
GNU General Public License.
+
+The build script support the following switches:
+IPV6=ON (default: OFF) to enable ipv6 support
+LUA=ON (default: OFF) to enable lua support (experimental)
diff --git a/network/ettercap/doinst.sh b/network/ettercap/doinst.sh
index 837a7c8f69..6c78ed0113 100644
--- a/network/ettercap/doinst.sh
+++ b/network/ettercap/doinst.sh
@@ -11,7 +11,10 @@ config() {
# Otherwise, we leave the .new copy for the admin to consider...
}
-config etc/etter.conf.new
+config etc/ettercap/etter.conf.new
+config etc/ettercap/etter.dns.new
+config etc/ettercap/etter.mdns.new
+config etc/ettercap/etter.nbns.new
if [ -x usr/bin/update-desktop-database ]; then
usr/bin/update-desktop-database -q usr/share/applications
diff --git a/network/ettercap/ettercap.SlackBuild b/network/ettercap/ettercap.SlackBuild
index 34a8728aa4..5b01e0ada8 100644
--- a/network/ettercap/ettercap.SlackBuild
+++ b/network/ettercap/ettercap.SlackBuild
@@ -1,9 +1,7 @@
#!/bin/sh
# Slackbuild for ettercap
-# forked off ettercap-NG.SlackBuild by Matteo Bernardini <ponce@slackbuilds.org>
-#
-# Copyright 2008 meckafett <tom[DOT]bradish[AT]gmail[DOT]com>
+# Copyright 2013 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +22,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=ettercap
-VERSION=${VERSION:-0.7.4.1}
+VERSION=${VERSION:-0.8.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -55,40 +53,42 @@ else
LIBDIRSUFFIX=""
fi
+IPV6=${IPV6:-OFF}
+LUA=${LUA:-OFF}
+
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM
+rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM
+cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r,a-s .
-
-sed -i "s|-O2 -funroll-loops|$SLKCFLAGS -funroll-loops|" configure.in
-
-sh autogen.sh
-
-CFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib$LIBDIRSUFFIX \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --enable-plugins \
- --enable-gtk \
- --disable-debug \
- --build=$ARCH-slackware-linux \
-
-make
-make install DESTDIR=$PKG
-
-mkdir -p $PKG/usr/share/applications
-cat $CWD/ettercap.desktop > $PKG/usr/share/applications/ettercap.desktop
-
-mv $PKG/etc/etter.conf $PKG/etc/etter.conf.new
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DMAN_INSTALLDIR=/usr/man \
+ -DBUNDLED_LIBS=OFF \
+ -DENABLE_IPV6=$IPV6 \
+ -DENABLE_LUA=$LUA \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+# don't clobber the config files
+( cd $PKG/etc/ettercap
+ for i in conf dns mdns nbns; do mv etter.$i etter.$i.new ; done )
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/network/ettercap/ettercap.desktop b/network/ettercap/ettercap.desktop
deleted file mode 100644
index 5ca2e8b4d1..0000000000
--- a/network/ettercap/ettercap.desktop
+++ /dev/null
@@ -1,7 +0,0 @@
-[Desktop Entry]
-Name=Ettercap GTK
-Icon=/usr/share/ettercap/ettercap.png
-Exec=/usr/bin/ettercap --gtk
-Terminal=false
-Type=Application
-Categories=Network;System;Security;GTK;
diff --git a/network/ettercap/ettercap.info b/network/ettercap/ettercap.info
index e79df77f2e..512b48ccde 100644
--- a/network/ettercap/ettercap.info
+++ b/network/ettercap/ettercap.info
@@ -1,8 +1,8 @@
PRGNAM="ettercap"
-VERSION="0.7.4.1"
+VERSION="0.8.0"
HOMEPAGE="http://ettercap.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/ettercap/ettercap-0.7.4.1.tar.gz"
-MD5SUM="8e13ff5504b5bb4f1fc6a465d57ce7ea"
+DOWNLOAD="http://downloads.sourceforge.net/ettercap/ettercap-0.8.0.tar.gz"
+MD5SUM="067514bb53ff76b81d578676e2048319"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libnet"
diff --git a/network/ettercap/slack-desc b/network/ettercap/slack-desc
index 0ba8403701..bf51a41263 100644
--- a/network/ettercap/slack-desc
+++ b/network/ettercap/slack-desc
@@ -1,9 +1,10 @@
# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|' on
-# the right side marks the last column you can put a character in. You must make
-# exactly 11 lines for the formatting to be correct. It's also customary to
-# leave one space after the ':'.
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
|-----handy-ruler------------------------------------------------------|
ettercap: ettercap (Multipurpose sniffer/interceptor/logger)
ettercap: