summaryrefslogtreecommitdiffstats
path: root/network/exim
diff options
context:
space:
mode:
author Thomas Morper <thomas@beingboiled.info>2018-04-17 12:20:42 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-04-21 07:42:59 +0700
commitf4853d2962b8208e7f64b8a991d437041e8e2e8b (patch)
tree957032da232b298a01dd238b3e6ac27e6ba4574e /network/exim
parent47ab8c44a3257c0cfad11455da0e344cba8cce0f (diff)
downloadslackbuilds-f4853d2962b8208e7f64b8a991d437041e8e2e8b.tar.gz
slackbuilds-f4853d2962b8208e7f64b8a991d437041e8e2e8b.tar.xz
network/exim: Updated for version 4.91.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'network/exim')
-rw-r--r--network/exim/exim.Makefile80
-rw-r--r--network/exim/exim.SlackBuild16
-rw-r--r--network/exim/exim.info6
3 files changed, 54 insertions, 48 deletions
diff --git a/network/exim/exim.Makefile b/network/exim/exim.Makefile
index 1f6fb19c4d..08befe0e5d 100644
--- a/network/exim/exim.Makefile
+++ b/network/exim/exim.Makefile
@@ -317,7 +317,9 @@ LOOKUP_DSEARCH=yes
# LOOKUP_ORACLE=yes
LOOKUP_PASSWD=yes
# LOOKUP_PGSQL=yes
+LOOKUP_PGSQL_PC=libpq
# LOOKUP_REDIS=yes
+LOOKUP_REDIS_PC=hiredis
# LOOKUP_SQLITE=yes
LOOKUP_SQLITE_PC=sqlite3
# LOOKUP_WHOSON=yes
@@ -364,6 +366,12 @@ PCRE_CONFIG=yes
#------------------------------------------------------------------------------
+# Uncomment the following line to add DANE support
+# Note: Enabling this unconditionally overrides DISABLE_DNSSEC
+# For DANE under GnuTLS we need an additional library. See TLS_LIBS below.
+SUPPORT_DANE=yes
+
+#------------------------------------------------------------------------------
# Additional libraries and include directories may be required for some
# lookup styles (e.g. LDAP, MYSQL or PGSQL). LOOKUP_LIBS is included only on
# the command for linking Exim itself, not on any auxiliary programs. You
@@ -385,18 +393,9 @@ endif
ifeq ($(LOOKUP_MYSQL),yes)
LOOKUP_INCLUDE+=-I/usr/include/mysql
-LOOKUP_LIBS+=-L/usr/lib$(LIBDIRSUFFIX)/mysql -lmysqlclient_r
+LOOKUP_LIBS+=-L/usr/lib$(LIBDIRSUFFIX)/mysql -lmysqlclient
endif
-ifeq ($(LOOKUP_REDIS),yes)
-LOOKUP_LIBS+=-lhiredis
-endif
-
-ifeq ($(LOOKUP_PGSQL),yes)
-LOOKUP_LIBS+=-lpq
-endif
-
-
#------------------------------------------------------------------------------
# Compiling the Exim monitor: If you want to compile the Exim monitor, a
# program that requires an X11 display, then EXIM_MONITOR should be set to the
@@ -417,15 +416,24 @@ endif
WITH_CONTENT_SCAN=yes
-#------------------------------------------------------------------------------
-# If you're using ClamAV and are backporting fixes to an old version, instead
-# of staying current (which is the more usual approach) then you may need to
-# use an older API which uses a STREAM command, now deprecated, instead of
-# zINSTREAM. If you need to set this, please let the Exim developers know, as
-# if nobody reports a need for it, we'll remove this option and clean up the
-# code. zINSTREAM was introduced with ClamAV 0.95.
-#
-# WITH_OLD_CLAMAV_STREAM=yes
+# If you have content scanning you may wish to only include some of the scanner
+# interfaces. Uncomment any of these lines to remove that code.
+
+# DISABLE_MAL_FFROTD=yes
+# DISABLE_MAL_FFROT6D=yes
+# DISABLE_MAL_DRWEB=yes
+# DISABLE_MAL_FSECURE=yes
+# DISABLE_MAL_SOPHIE=yes
+# DISABLE_MAL_CLAM=yes
+# DISABLE_MAL_AVAST=yes
+# DISABLE_MAL_SOCK=yes
+# DISABLE_MAL_CMDLINE=yes
+
+# These scanners are claimed to be no longer existent.
+
+DISABLE_MAL_AVE=yes
+DISABLE_MAL_KAV=yes
+DISABLE_MAL_MKS=yes
#------------------------------------------------------------------------------
@@ -453,7 +461,7 @@ WITH_CONTENT_SCAN=yes
# By default, Exim has support for checking the AD bit in a DNS response, to
# determine if DNSSEC validation was successful. If your system libraries
# do not support that bit, then set DISABLE_DNSSEC to "yes"
-# Note: Enabling EXPERIMENTAL_DANE unconditionally overrides this setting.
+# Note: Enabling SUPPORT_DANE unconditionally overrides this setting.
# DISABLE_DNSSEC=yes
@@ -473,14 +481,6 @@ WITH_CONTENT_SCAN=yes
# EXPERIMENTAL_DCC=yes
-# Uncomment the following lines to add SPF support. You need to have libspf2
-# installed on your system (www.libspf2.org). Depending on where it is installed
-# you may have to edit the CFLAGS and LDFLAGS lines.
-
-# EXPERIMENTAL_SPF=yes
-# CFLAGS += -I/usr/local/include
-# LDFLAGS += -lspf2
-
# Uncomment the following lines to add SRS (Sender rewriting scheme) support.
# You need to have libsrs_alt installed on your system (srs.mirtol.com).
# Depending on where it is installed you may have to edit the CFLAGS and
@@ -491,12 +491,16 @@ WITH_CONTENT_SCAN=yes
# LDFLAGS += -lsrs_alt
# Uncomment the following line to add DMARC checking capability, implemented
-# using libopendmarc libraries. You must have SPF support enabled also.
+# using libopendmarc libraries. You must have SPF and DKIM support enabled also.
# EXPERIMENTAL_DMARC=yes
# DMARC_TLD_FILE= /etc/exim/opendmarc.tlds
# CFLAGS += -I/usr/local/include
# LDFLAGS += -lopendmarc
+# Uncomment the following line to add ARC (Authenticated Received Chain)
+# support. You must have SPF and DKIM support enabled also.
+# EXPERIMENTAL_ARC=yes
+
# Uncomment the following lines to add Brightmail AntiSpam support. You need
# to have the Brightmail client SDK installed. Please check the experimental
# documentation for implementation details. You need to edit the CFLAGS and
@@ -506,11 +510,6 @@ WITH_CONTENT_SCAN=yes
# CFLAGS += -I/opt/brightmail/bsdk-6.0/include
# LDFLAGS += -lxml2_single -lbmiclient_single -L/opt/brightmail/bsdk-6.0/lib
-# Uncomment the following line to add DANE support
-# Note: Enabling this unconditionally overrides DISABLE_DNSSEC
-# Note: DANE is only supported when using OpenSSL
-# EXPERIMENTAL_DANE=yes
-
# Uncomment the following to include extra information in fail DSN message (bounces)
# EXPERIMENTAL_DSN_INFO=yes
@@ -817,6 +816,9 @@ USE_OPENSSL_PC=openssl
# or
# TLS_LIBS=-L/opt/gnu/lib -lgnutls -ltasn1 -lgcrypt
+# For DANE under GnuTLS we need an additional library.
+# TLS_LIBS += -lgnutls-dane
+
# TLS_LIBS is included only on the command for linking Exim itself, not on any
# auxiliary programs. If the include files are not in a standard place, you can
# set TLS_INCLUDE to specify where they are, for example:
@@ -988,6 +990,16 @@ LDFLAGS += -lidn
#------------------------------------------------------------------------------
+# Uncomment the following lines to add SPF support. You need to have libspf2
+# installed on your system (www.libspf2.org). Depending on where it is installed
+# you may have to edit the CFLAGS and LDFLAGS lines.
+
+# SUPPORT_SPF=yes
+# CFLAGS += -I/usr/local/include
+# LDFLAGS += -lspf2
+
+
+#------------------------------------------------------------------------------
# Support for authentication via Radius is also available. The Exim support,
# which is intended for use in conjunction with the SMTP AUTH facilities,
# is included only when requested by setting the following parameter to the
diff --git a/network/exim/exim.SlackBuild b/network/exim/exim.SlackBuild
index c859c766b2..f04b3ba9e6 100644
--- a/network/exim/exim.SlackBuild
+++ b/network/exim/exim.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=exim
-VERSION=${VERSION:-4.90.1}
+VERSION=${VERSION:-4.91}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -81,19 +81,13 @@ find -L . \
# See README.SBo for info on how to enable the database lookups.
cat $CWD/exim.Makefile > Local/Makefile
+# Add our SLKCFLAGS to the custom Makefile
+echo "CFLAGS += $SLKCFLAGS" >> Local/Makefile
+
# Use a stock config for the Exim Monitor (not built by default).
cat exim_monitor/EDITME > Local/eximon.conf
-# Use the Exim build system to set the architecture-specific CFLAGS.
-# This requires "make" to run twice, in case you wonder. If you want
-# to use your own CFLAGS in exim.Makefile, you should put a '#' in
-# front of the next 3 lines.
-echo "CFLAGS=$SLKCFLAGS -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE" > Local/Makefile-Linux
-FULLECHO="" LIBDIRSUFFIX=$LIBDIRSUFFIX DESTDIR=$PKG make -e || true
-FULLECHO="" LIBDIRSUFFIX=$LIBDIRSUFFIX DESTDIR=$PKG make -e makefile
-
-# build & install
-FULLECHO="" LIBDIRSUFFIX=$LIBDIRSUFFIX DESTDIR=$PKG make -e
+# Build and install.
FULLECHO="" LIBDIRSUFFIX=$LIBDIRSUFFIX DESTDIR=$PKG make -e install
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/network/exim/exim.info b/network/exim/exim.info
index 3204e9b13a..5b2b571337 100644
--- a/network/exim/exim.info
+++ b/network/exim/exim.info
@@ -1,8 +1,8 @@
PRGNAM="exim"
-VERSION="4.90.1"
+VERSION="4.91"
HOMEPAGE="https://www.exim.org/"
-DOWNLOAD="https://ftp.exim.org/pub/exim/exim4/exim-4.90.1.tar.xz"
-MD5SUM="0095c67c9954a51c67424a11e429ebc7"
+DOWNLOAD="https://ftp.exim.org/pub/exim/exim4/exim-4.91.tar.xz"
+MD5SUM="d10144ed96314eb12a2ab40bc70d1ef2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="%README%"