summaryrefslogtreecommitdiffstats
path: root/network/ganglia
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@slackbuilds.org>2010-05-13 00:08:39 +0200
committer Heinz Wiesinger <pprkut@slackbuilds.org>2010-05-13 00:08:39 +0200
commit30a2ff195b41c70b994f8ba3c45dc30901decc8c (patch)
tree3af0844fb7fef7724235da72d4dec71fdfad0028 /network/ganglia
parent7846e91a8f93edb61bfb9bbc62724aca7d1fc7d8 (diff)
downloadslackbuilds-30a2ff195b41c70b994f8ba3c45dc30901decc8c.tar.gz
slackbuilds-30a2ff195b41c70b994f8ba3c45dc30901decc8c.tar.xz
network/ganglia: Removed from 13.0 repository
Diffstat (limited to 'network/ganglia')
-rw-r--r--network/ganglia/README16
-rw-r--r--network/ganglia/doinst.sh36
-rw-r--r--network/ganglia/ganglia.SlackBuild112
-rw-r--r--network/ganglia/ganglia.info8
-rw-r--r--network/ganglia/slack-desc19
5 files changed, 0 insertions, 191 deletions
diff --git a/network/ganglia/README b/network/ganglia/README
deleted file mode 100644
index 8ddb0efe49..0000000000
--- a/network/ganglia/README
+++ /dev/null
@@ -1,16 +0,0 @@
-Ganglia is a scalable distributed monitoring system for high-performance
-computing systems such as clusters and Grids. It is based on a hierarchical
-design targeted at federations of clusters.
-
-1. This SlackBuild is just going to build Ganglia without 'gmetad', which
- collects information from ganglia monitor clients, and writes them to RRD
- databases. If you want to enable this, you'll have to enable it with the
- OPT variable and 'gmetad' as value, then execute the build script as
- follows: OPT=gmetad ./ganglia.SlackBuild
-
- In order to build gmetad as part of this package, you'll need to have
- RRDTool installed. It is available from SlackBuilds.org.
-
-2. The Ganglia web frontend files will be stored under /var/www/htdocs/gweb
- directory. You can set WWWPATH to the desired place for your web server.
- Example: WWWPATH=/var/www/ganglia ./ganglia.SlackBuild
diff --git a/network/ganglia/doinst.sh b/network/ganglia/doinst.sh
deleted file mode 100644
index 2eadc4a110..0000000000
--- a/network/ganglia/doinst.sh
+++ /dev/null
@@ -1,36 +0,0 @@
-config() {
- NEW="$1"
- OLD="$(dirname $NEW)/$(basename $NEW .new)"
- # If there's no config file by that name, mv it over:
- if [ ! -r $OLD ]; then
- mv $NEW $OLD
- elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
- # toss the redundant copy
- rm $NEW
- fi
- # Otherwise, we leave the .new copy for the admin to consider...
-}
-
-# Keep same perms on rc.gmond.new:
-if [ -e etc/rc.d/rc.gmond ]; then
- cp -a etc/rc.d/rc.gmond etc/rc.d/rc.gmond.new.incoming
- cat etc/rc.d/rc.gmond.new > etc/rc.d/rc.gmond.new.incoming
- mv etc/rc.d/rc.gmond.new.incoming etc/rc.d/rc.gmond.new
-fi
-config etc/rc.d/rc.gmond.new
-config etc/gmond.conf.new
-
-if [ -e etc/gmetad.conf.new ]; then
- config etc/gmetad.conf.new
-fi
-
-if [ -e etc/rc.d/rc.gmetad.new ]; then
- # Keep same perms on rc.gmetad.new:
- if [ -e etc/rc.d/rc.gmetad ]; then
- cp -a etc/rc.d/rc.gmetad etc/rc.d/rc.gmetad.new.incoming
- cat etc/rc.d/rc.gmetad.new > etc/rc.d/rc.gmetad.new.incoming
- mv etc/rc.d/rc.gmetad.new.incoming etc/rc.d/rc.gmetad.new
- fi
- config etc/rc.d/rc.gmetad.new
-fi
-
diff --git a/network/ganglia/ganglia.SlackBuild b/network/ganglia/ganglia.SlackBuild
deleted file mode 100644
index f953957ead..0000000000
--- a/network/ganglia/ganglia.SlackBuild
+++ /dev/null
@@ -1,112 +0,0 @@
-#!/bin/sh
-#
-# Slackware build script for ganglia
-#
-# Copyright 2008 Cherife Li <cherife-#-dotimes.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=ganglia
-VERSION=3.1.1
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-WWWPATH=${WWWPATH:-/var/www/htdocs/gweb}
-DOCUMENTATION="AUTHORS COPYING ChangeLog INSTALL NEWS README*"
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
-
-if [ -n "$OPT" ]; then
- if [ "$OPT" = 'gmetad' ]; then
- OPT='--with-gmetad'
- else
- unset -v OPT
- fi
-fi
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --enable-static=no \
- --enable-gexeca \
- --enable-status \
- $OPT
-
-make
-make install DESTDIR=$PKG
-
-mkdir -p $PKG/etc/rc.d
-cat gmond/gmond.init > $PKG/etc/rc.d/rc.gmond.new
-./gmond/gmond -t > $PKG/etc/gmond.conf.new
-
-if [ -n "$OPT" ]; then
- cat gmetad/gmetad.init > $PKG/etc/rc.d/rc.gmetad.new
- cat gmetad/gmetad.conf > $PKG/etc/gmetad.conf.new
-fi
-
-mkdir -p $PKG/$WWWPATH
-mv web/* $PKG/$WWWPATH
-( cd $PKG/$WWWPATH ; rm -f AUTHORS COPYING Makefile.am conf.php.in version.php.in )
-
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-)
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCUMENTATION $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/usr/man/man1
-cp -a mans/*.1 $PKG/usr/man/man1
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/network/ganglia/ganglia.info b/network/ganglia/ganglia.info
deleted file mode 100644
index be9e856d9a..0000000000
--- a/network/ganglia/ganglia.info
+++ /dev/null
@@ -1,8 +0,0 @@
-PRGNAM="ganglia"
-VERSION="3.1.1"
-HOMEPAGE="http://ganglia.info/"
-DOWNLOAD="http://downloads.sourceforge.net/ganglia/ganglia-3.1.1.tar.gz"
-MD5SUM="e6f4de42afecb4731a5de4606e3f1045"
-MAINTAINER="Cherife Li"
-EMAIL="cherife-#-dotimes.com"
-APPROVED="dsomero"
diff --git a/network/ganglia/slack-desc b/network/ganglia/slack-desc
deleted file mode 100644
index dc254333a7..0000000000
--- a/network/ganglia/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-ganglia: Ganglia (distributed monitoring system)
-ganglia:
-ganglia: Ganglia is a scalable distributed monitoring system
-ganglia: for high-performance computing systems such as
-ganglia: clusters and Grids. It is based on a hierarchical
-ganglia: design targeted at federations of clusters.
-ganglia:
-ganglia: Homepage: http://ganglia.info/
-ganglia:
-ganglia:
-ganglia: