summaryrefslogtreecommitdiffstats
path: root/network/mz
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2013-11-17 10:18:54 +0700
committer Robby Workman <rworkman@slackbuilds.org>2013-11-16 22:56:56 -0600
commit2e97d43d71bba67eaa67ff5fefe42ea18e709eee (patch)
treeba9fd9f1e00b34454768b78154a6a913edea194c /network/mz
parent411d3a4556469126dd471aa7fda6e23edb3fe51e (diff)
downloadslackbuilds-2e97d43d71bba67eaa67ff5fefe42ea18e709eee.tar.gz
slackbuilds-2e97d43d71bba67eaa67ff5fefe42ea18e709eee.tar.xz
network/mz: Removed (No longer maintained upstream)
Please use netsniff-ng which has this package included as well Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org> Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'network/mz')
-rw-r--r--network/mz/README16
-rw-r--r--network/mz/mz.SlackBuild103
-rw-r--r--network/mz/mz.info10
-rw-r--r--network/mz/slack-desc19
4 files changed, 0 insertions, 148 deletions
diff --git a/network/mz/README b/network/mz/README
deleted file mode 100644
index d509403afd..0000000000
--- a/network/mz/README
+++ /dev/null
@@ -1,16 +0,0 @@
-Mausezahn is a **fast traffic generator** written in C which allows you
-to send nearly every possible and impossible packet.
-Mausezahn can be used:
-
- - As traffic generator (e. g. to stress multicast networks)
- - For penetration testing of firewalls and IDS
- - For DoS attacks on networks (for audit purposes of course)
- - To find bugs in network software or appliances
- - For reconnaissance attacks using ping sweeps and port scans
- - To test network behaviour under strange circumstances (stress test,
- malformed packets, ...)
- - As didactical tool during lab exercises
-
-Mausezahn is basically a versatile packet creation tool on the command line
-with a simple syntax and online help. It could also be used within (bash-)
-scripts to perform combination of tests.
diff --git a/network/mz/mz.SlackBuild b/network/mz/mz.SlackBuild
deleted file mode 100644
index d80c4e05d9..0000000000
--- a/network/mz/mz.SlackBuild
+++ /dev/null
@@ -1,103 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for mz
-
-# Copyright 2008-2010 Heinz Wiesinger, Amsterdam, The Netherlands
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=mz
-VERSION=0.40
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# we need to link to libssp to not fail because of -fstack-protector
-sed -i "s/pcap rt/pcap rt ssp/" src/CMakeLists.txt
-
-cmake \
- -DCMAKE_C_FLAGS="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DLIB_SUFFIX="$LIBDIRSUFFIX" \
- .
-
-make
-make install DESTDIR=$PKG
-
-mv $PKG/usr/share/man $PKG/usr/
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-mv $PKG/usr/share/doc/mz/* $PKG/usr/doc/$PRGNAM-$VERSION/
-rm -rf $PKG/usr/share
-cp -a AUTHORS ChangeLog COPYING INSTALL NEWS README \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/mz/mz.info b/network/mz/mz.info
deleted file mode 100644
index 35f5604d0b..0000000000
--- a/network/mz/mz.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="mz"
-VERSION="0.40"
-HOMEPAGE="http://www.perihel.at/sec/mz"
-DOWNLOAD="http://www.perihel.at/sec/mz/mz-0.40.tar.gz"
-MD5SUM="d3d959c92cbf3d81224f5b2f8409e9d8"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="libcli libnet"
-MAINTAINER="Heinz Wiesinger"
-EMAIL="pprkut@liwjatan.at"
diff --git a/network/mz/slack-desc b/network/mz/slack-desc
deleted file mode 100644
index dee2925a32..0000000000
--- a/network/mz/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-mz: mz (fast network-traffic generator)
-mz:
-mz: Mausezahn is a **fast traffic generator** written in C which allows you
-mz: to send nearly every possible and impossible packet. Mausezahn can be
-mz: used for example:
-mz: - As traffic generator (e. g. to stress multicast networks)
-mz: - For penetration testing of firewalls and IDS
-mz: - For DoS attacks on networks (for audit purposes of course)
-mz: - and many more...
-mz:
-mz: Homepage: http://www.perihel.at/sec/mz