summaryrefslogtreecommitdiffstats
path: root/network/netsurf
diff options
context:
space:
mode:
author Ruben Schuller <ruben@orgizm.net>2012-12-30 14:38:36 -0500
committer dsomero <xgizzmo@slackbuilds.org>2012-12-30 14:38:36 -0500
commite456a7f9bc1a7ccbaa63f6c994f58884fcf536f9 (patch)
tree6afe89ffa10d6f0363ba12e9d137354677b2b9cb /network/netsurf
parent05325d7fb14c0b6db99154173827b561b5864de6 (diff)
downloadslackbuilds-e456a7f9bc1a7ccbaa63f6c994f58884fcf536f9.tar.gz
slackbuilds-e456a7f9bc1a7ccbaa63f6c994f58884fcf536f9.tar.xz
network/netsurf: Added (NetSurf web browser)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'network/netsurf')
-rw-r--r--network/netsurf/README8
-rw-r--r--network/netsurf/doinst.sh7
-rw-r--r--network/netsurf/netsurf.SlackBuild95
-rw-r--r--network/netsurf/netsurf.desktop12
-rw-r--r--network/netsurf/netsurf.info10
-rw-r--r--network/netsurf/ns-config21
-rw-r--r--network/netsurf/slack-desc19
7 files changed, 172 insertions, 0 deletions
diff --git a/network/netsurf/README b/network/netsurf/README
new file mode 100644
index 0000000000..9efed74637
--- /dev/null
+++ b/network/netsurf/README
@@ -0,0 +1,8 @@
+NetSurf is a free, open source web browser. It is written in C and released
+under the GNU Public Licence version 2. NetSurf has its own layout and
+rendering engine entirely written from scratch. It is small and capable of
+handling many of the web standards in use today.
+
+Building and additional dependencys:
+If you want to change the build options you can do this in the ns-config
+file. For webp support libwebp must be installed.
diff --git a/network/netsurf/doinst.sh b/network/netsurf/doinst.sh
new file mode 100644
index 0000000000..9a8ded3c60
--- /dev/null
+++ b/network/netsurf/doinst.sh
@@ -0,0 +1,7 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
diff --git a/network/netsurf/netsurf.SlackBuild b/network/netsurf/netsurf.SlackBuild
new file mode 100644
index 0000000000..4123d4df24
--- /dev/null
+++ b/network/netsurf/netsurf.SlackBuild
@@ -0,0 +1,95 @@
+#!/bin/sh
+
+# Slackware build script for netsurf
+
+# Copyright 2012 Ruben Schuller
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=netsurf
+VERSION=${VERSION:-2.9}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION-full-src.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Apply the configuration
+cat $CWD/ns-config > $PRGNAM-$VERSION/Makefile.config
+
+make TARGET=gtk
+make install DESTDIR=$PKG PREFIX=/usr TARGET=gtk
+
+cp -v -R -L $PRGNAM-$VERSION/gtk/res/* $PKG/usr/share/netsurf
+
+mkdir $PKG/usr/share/pixmaps
+cp $PRGNAM-$VERSION/gtk/res/netsurf.xpm $PKG/usr/share/pixmaps
+
+mkdir $PKG/usr/share/applications
+cp $CWD/netsurf.desktop $PKG/usr/share/applications
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/ns-config > $PKG/usr/doc/$PRGNAM-$VERSION/ns-config
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/netsurf/netsurf.desktop b/network/netsurf/netsurf.desktop
new file mode 100644
index 0000000000..5764a8eb0e
--- /dev/null
+++ b/network/netsurf/netsurf.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=Netsurf
+GenericName=Web Browser
+Comment=Lightweight web browser
+Exec=netsurf %U
+Icon=netsurf
+Terminal=false
+StartupNotify=false
+Categories=Application;Network;
+MimeType=text/html;application/xhtml+xml;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/geo;
diff --git a/network/netsurf/netsurf.info b/network/netsurf/netsurf.info
new file mode 100644
index 0000000000..33db7871ff
--- /dev/null
+++ b/network/netsurf/netsurf.info
@@ -0,0 +1,10 @@
+PRGNAM="netsurf"
+VERSION="2.9"
+HOMEPAGE="http://www.netsurf-browser.org"
+DOWNLOAD="http://download.netsurf-browser.org/netsurf/releases/source-full/netsurf-2.9-full-src.tar.gz"
+MD5SUM="cfc2789997b356f2ea9d9f7694c4c909"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Ruben Schuller"
+EMAIL="ruben@orgizm.net"
diff --git a/network/netsurf/ns-config b/network/netsurf/ns-config
new file mode 100644
index 0000000000..632e9ba40e
--- /dev/null
+++ b/network/netsurf/ns-config
@@ -0,0 +1,21 @@
+# sane defaults
+NETSURF_USE_BMP := YES
+NETSURF_USE_GIF := YES
+NETSURF_USE_JPEG := YES
+NETSURF_USE_PNG := YES
+NETSURF_USE_MNG := NO
+
+# webp images, libwebp needed
+NETSURF_USE_WEBP := NO
+
+# video playback with gstreamer
+NETSURF_USE_VIDEO := NO
+
+# experimental javascript support, spidermonkey needed
+NETSURF_USE_JS := NO
+
+# pdf export and printing with haru
+# http://libharu.org (unfortunately there is no SlackBuild for haru)
+NETSURF_USE_HARU_PDF := NO
+
+NETSURF_GTK_RESOURCES := /usr/share/netsurf/
diff --git a/network/netsurf/slack-desc b/network/netsurf/slack-desc
new file mode 100644
index 0000000000..0084ddc7ba
--- /dev/null
+++ b/network/netsurf/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+netsurf: netsurf (NetSurf web browser)
+netsurf:
+netsurf: NetSurf is a free, open source web browser. It is written in C and
+netsurf: released under the GNU Public Licence version 2.
+netsurf: NetSurf has its own layout and rendering engine entirely written from
+netsurf: scratch.
+netsurf:
+netsurf:
+netsurf:
+netsurf:
+netsurf: