summaryrefslogtreecommitdiffstats
path: root/network/nginx
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2010-05-18 01:03:08 -0500
committer Robby Workman <rworkman@slackbuilds.org>2010-05-19 09:06:59 -0500
commitce5d8576cceb6afdae47341eb2298b91a11f3944 (patch)
treec0eb217ac34301048f76f934443696254545ec03 /network/nginx
parentfa9971b7cf6920b765c65d76c355ed14d37bf6e0 (diff)
downloadslackbuilds-ce5d8576cceb6afdae47341eb2298b91a11f3944.tar.gz
slackbuilds-ce5d8576cceb6afdae47341eb2298b91a11f3944.tar.xz
network/nginx: Removed (no maintainer)
Diffstat (limited to 'network/nginx')
-rw-r--r--network/nginx/README10
-rw-r--r--network/nginx/doinst.sh22
-rw-r--r--network/nginx/nginx.SlackBuild138
-rw-r--r--network/nginx/nginx.info10
-rw-r--r--network/nginx/rc.nginx88
-rw-r--r--network/nginx/slack-desc19
6 files changed, 0 insertions, 287 deletions
diff --git a/network/nginx/README b/network/nginx/README
deleted file mode 100644
index e148206644..0000000000
--- a/network/nginx/README
+++ /dev/null
@@ -1,10 +0,0 @@
-nginx [engine x] is a high-performance HTTP server and reverse proxy
-as well as an IMAP/POP3 proxy server.
-
-By default, nginx will use the "nobody" user and group accounts. You may
-specify alternate values on the command line if desired; for example:
-
- NGINXUSER=backup NGINXGROUP=backup ./nginx.SlackBuild
-
-Regardless of which user and group you decide to use, you will need to make
-sure they exist on both the build system and the target system.
diff --git a/network/nginx/doinst.sh b/network/nginx/doinst.sh
deleted file mode 100644
index 9641df3888..0000000000
--- a/network/nginx/doinst.sh
+++ /dev/null
@@ -1,22 +0,0 @@
-config() {
- NEW="$1"
- OLD="$(dirname $NEW)/$(basename $NEW .new)"
- # If there's no config file by that name, mv it over:
- if [ ! -r $OLD ]; then
- mv $NEW $OLD
- elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
- # toss the redundant copy
- rm $NEW
- fi
- # Otherwise, we leave the .new copy for the admin to consider...
-}
-
-# Keep same perms on rc.nginx.new:
-if [ -e etc/rc.d/rc.nginx ]; then
- cp -a etc/rc.d/rc.nginx etc/rc.d/rc.nginx.new.incoming
- cat etc/rc.d/rc.nginx.new > etc/rc.d/rc.nginx.new.incoming
- mv etc/rc.d/rc.nginx.new.incoming etc/rc.d/rc.nginx.new
-fi
-
-config etc/rc.d/rc.nginx.new
-
diff --git a/network/nginx/nginx.SlackBuild b/network/nginx/nginx.SlackBuild
deleted file mode 100644
index 8dc2e4f9ca..0000000000
--- a/network/nginx/nginx.SlackBuild
+++ /dev/null
@@ -1,138 +0,0 @@
-#!/bin/sh
-#
-# Slackware build script for nginx
-#
-# Copyright 2008 Cherife Li <cherife-#-dotimes.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=nginx
-VERSION=${VERSION:-0.7.62}
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --sbin-path=/usr/sbin/nginx \
- --conf-path=/etc/nginx/nginx.conf \
- --error-log-path=/var/log/nginx_error.log \
- --pid-path=/var/run/nginx.pid \
- --lock-path=/var/lock/nginx \
- --user=${NGINXUSER:-nobody} \
- --group=${NGINXGROUP:-nogroup} \
- --with-rtsig_module \
- --with-select_module \
- --with-poll_module \
- --with-http_ssl_module \
- --with-http_realip_module \
- --with-http_addition_module \
- --with-http_xslt_module \
- --with-http_sub_module \
- --with-http_dav_module \
- --with-http_flv_module \
- --with-http_gzip_static_module \
- --with-http_random_index_module \
- --with-http_secure_link_module \
- --with-http_stub_status_module \
- --with-http_perl_module \
- --http-log-path=/var/log/nginx_access.log \
- --http-client-body-temp-path=/var/tmp/nginx_client_body_temp \
- --http-proxy-temp-path=/var/tmp/nginx_proxy_temp \
- --http-fastcgi-temp-path=/dev/shm \
- --without-mail_pop3_module \
- --without-mail_imap_module \
- --without-mail_smtp_module \
- --with-debug
-
-make
-sed -r -i 's|/usr/share/man|/usr/man|g' objs/src/http/modules/perl/Makefile
-make install DESTDIR=$PKG
-
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null || true
- find . -name perllocal.pod -o -name ".packlist" -o -name "*.bs" | \
- xargs rm -f 2> /dev/null
- find . -perm 444 -exec chmod 0644 {} \;
- find . -perm 555 -exec chmod 0755 {} \;
-)
-
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
-
-# Remove some other empty and/or unnecessary directories from the package
-eval $(perl '-V:archlib')
-rm -rf $PKG/$archlib $PKG/usr/html $PKG/var
-
-# Add an init script
-mkdir -p $PKG/etc/rc.d
-cat $CWD/rc.nginx > $PKG/etc/rc.d/rc.nginx.new
-
-mkdir -p $PKG/usr/doc/nginx-$VERSION
-cp -a CHANGES CHANGES.ru LICENSE README $PKG/usr/doc/nginx-$VERSION
-cat $CWD/nginx.SlackBuild > $PKG/usr/doc/nginx-$VERSION/nginx.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-# Let's not clobber config files on upgrade
-( cd $PKG/etc/nginx
- for i in fastcgi_params mime.types nginx.conf koi-utf koi-win win-utf; do
- mv $i $i.new;
- echo "config etc/nginx/$i.new" >> $PKG/install/doinst.sh;
- done
-)
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/nginx/nginx.info b/network/nginx/nginx.info
deleted file mode 100644
index 75cdf07768..0000000000
--- a/network/nginx/nginx.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="nginx"
-VERSION="0.7.62"
-HOMEPAGE="http://nginx.net/"
-DOWNLOAD="http://sysoev.ru/nginx/nginx-0.7.62.tar.gz"
-MD5SUM="ab22f1b7f098a90d803a3abb94d23f7e"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Nobody"
-EMAIL="nobody@nowhere"
-APPROVED="rworkman"
diff --git a/network/nginx/rc.nginx b/network/nginx/rc.nginx
deleted file mode 100644
index 0c82902992..0000000000
--- a/network/nginx/rc.nginx
+++ /dev/null
@@ -1,88 +0,0 @@
-#!/bin/sh
-#
-# Nginx daemon control script.
-# Written for Slackware Linux by Cherife Li <cherife-#-dotimes.com>.
-
-BIN=/usr/sbin/nginx
-CONF=/etc/nginx/nginx.conf
-PID=/var/run/nginx.pid
-
-nginx_start() {
- # Sanity checks.
- if [ ! -r $CONF ]; then # no config file, exit:
- echo "$CONF does not appear to exist. Abort."
- exit 1
- fi
-
- if [ -s $PID ]; then
- echo "Nginx appears to already be running?"
- exit 1
- fi
-
- echo "Starting Nginx server daemon..."
- if [ -x $BIN ]; then
- $BIN -c $CONF
- fi
-}
-
-nginx_test_conf() {
- echo "Checking configuration for correct syntax and"
- echo "then trying to open files referenced in configuration..."
- $BIN -t -c $CONF
-}
-
-nginx_term() {
- echo "Shutdown Nginx quickly..."
- kill -TERM $(cat $PID)
-}
-
-nginx_stop() {
- echo "Shutdown Nginx gracefully..."
- kill -QUIT $(cat $PID)
-}
-
-nginx_reload() {
- echo "Reloading Nginx configuration..."
- kill -HUP $(cat $PID)
-}
-
-nginx_upgrade() {
- echo "Upgrading to the new Nginx binary."
- echo "Make sure the Nginx binary has been replaced with new one"
- echo "or Nginx server modules were added/removed."
- kill -USR2 $(cat $PID)
- sleep 3
- kill -QUIT $(cat $PID.oldbin)
-}
-
-nginx_restart() {
- nginx_quit
- sleep 3
- nginx_start
-}
-
-case "$1" in
- check)
- nginx_test_conf
- ;;
- start)
- nginx_start
- ;;
- term)
- nginx_term
- ;;
- stop)
- nginx_stop
- ;;
- reload)
- nginx_reload
- ;;
- restart)
- nginx_restart
- ;;
- upgrade)
- nginx_upgrade
- ;;
- *)
- echo "usage: `basename $0` {check|start|term|stop|reload|restart|upgrade}"
-esac
diff --git a/network/nginx/slack-desc b/network/nginx/slack-desc
deleted file mode 100644
index b7b1a62e39..0000000000
--- a/network/nginx/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-nginx: nginx (http/imap/pop3 proxy)
-nginx:
-nginx: Nginx [engine x] is a high-performance HTTP server and reverse proxy,
-nginx: as well as an IMAP/POP3 proxy server.
-nginx:
-nginx: Nginx was written by Igor Sysoev.
-nginx:
-nginx: Homepage: http://nginx.net/
-nginx:
-nginx:
-nginx: