summaryrefslogtreecommitdiffstats
path: root/network/nginx
diff options
context:
space:
mode:
author Cherife Li <cherife-#-dotimes.com>2010-05-12 17:43:58 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-12 17:43:58 +0200
commitba227da84ad1fc6ff7acf46df072649bd54086f1 (patch)
tree59a60e3723d8b2d8d5a845fe18ca9f3e1d5e9f5a /network/nginx
parentf7aaa9cc9279b5b759fc7ef72681d477f61b61e7 (diff)
downloadslackbuilds-ba227da84ad1fc6ff7acf46df072649bd54086f1.tar.gz
slackbuilds-ba227da84ad1fc6ff7acf46df072649bd54086f1.tar.xz
network/nginx: Updated for version 0.7.27
Diffstat (limited to 'network/nginx')
-rw-r--r--network/nginx/nginx.SlackBuild41
-rw-r--r--network/nginx/nginx.info10
-rw-r--r--network/nginx/rc.nginx24
-rw-r--r--network/nginx/slack-desc2
4 files changed, 43 insertions, 34 deletions
diff --git a/network/nginx/nginx.SlackBuild b/network/nginx/nginx.SlackBuild
index 086458fd17..57f6868ba7 100644
--- a/network/nginx/nginx.SlackBuild
+++ b/network/nginx/nginx.SlackBuild
@@ -2,7 +2,7 @@
#
# Slackware build script for nginx
#
-# Copyright 2008 Cherife Li <cherife@dotimes.com>
+# Copyright 2008 Cherife Li <cherife-#-dotimes.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,10 +24,9 @@
#
# Notes:
# + This SlackBuild is for v0.7.0 and newer.
-# + You may want to customize the configure options.
PRGNAM=nginx
-VERSION=0.7.5
+VERSION=${VERSION:-0.7.27}
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -39,6 +38,7 @@ OUTPUT=${OUTPUT:-/tmp}
NGINXUSER=${NGINXUSER:-nobody}
NGINXGROUP=${NGINXGROUP:-nobody}
+PERL=$( eval "`perl -V:version`"; echo $version )
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
@@ -53,15 +53,12 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
+
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
+chown -R root:root $PRGNAM-$VERSION
+chmod -R u+w,go+r-w,a-s $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -74,35 +71,51 @@ CXXFLAGS="$SLKCFLAGS" \
--lock-path=/var/lock/nginx \
--user=${NGINXUSER} \
--group=${NGINXGROUP} \
+ --with-rtsig_module \
+ --with-select_module \
+ --with-poll_module \
--with-http_ssl_module \
--with-http_realip_module \
--with-http_addition_module \
+ --with-http_xslt_module \
--with-http_sub_module \
--with-http_dav_module \
--with-http_flv_module \
--with-http_gzip_static_module \
+ --with-http_random_index_module \
+ --with-http_secure_link_module \
--with-http_stub_status_module \
+ --with-http_perl_module \
--http-log-path=/var/log/nginx_access.log \
- --http-client-body-temp-path=/var/spool/nginx_client_body_temp \
- --http-proxy-temp-path=/var/spool/nginx_proxy_temp \
+ --http-client-body-temp-path=/var/tmp/nginx_client_body_temp \
+ --http-proxy-temp-path=/var/tmp/nginx_proxy_temp \
--http-fastcgi-temp-path=/dev/shm \
--without-mail_pop3_module \
--without-mail_imap_module \
--without-mail_smtp_module \
--with-debug
-make || exit 1
+make
+sed -r -i 's|/usr/share/man|/usr/man|g' objs/src/http/modules/perl/Makefile
make install DESTDIR=$PKG || exit 1
mkdir -p $PKG/{etc/rc.d,usr/doc/nginx-$VERSION}
cp -a CHANGES CHANGES.ru LICENSE README $PKG/usr/doc/nginx-$VERSION
cat $CWD/nginx.SlackBuild > $PKG/usr/doc/nginx-$VERSION/nginx.SlackBuild
cat $CWD/rc.nginx > $PKG/etc/rc.d/rc.nginx.new
-mv $PKG/usr/html $PKG/usr/doc/nginx-$VERSION
+rm -rf $PKG/{var,usr/{html,lib/perl5/${PERL}}}
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+ find . -name perllocal.pod -o -name ".packlist" -o -name "*.bs" | xargs rm -f 2> /dev/null
+ find . -perm 444 -exec chmod 0644 {} \;
+ find . -perm 555 -exec chmod 0755 {} \;
+)
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
)
mkdir -p $PKG/install
diff --git a/network/nginx/nginx.info b/network/nginx/nginx.info
index c704848e4f..2aea47b137 100644
--- a/network/nginx/nginx.info
+++ b/network/nginx/nginx.info
@@ -1,8 +1,8 @@
PRGNAM="nginx"
-VERSION="0.7.5"
+VERSION="0.7.27"
HOMEPAGE="http://nginx.net/"
-DOWNLOAD="http://sysoev.ru/nginx/nginx-0.7.5.tar.gz"
-MD5SUM="881e2069181adecdfae9b58ab811a17b"
+DOWNLOAD="http://sysoev.ru/nginx/nginx-0.7.27.tar.gz"
+MD5SUM="70d90a9e7c92ad88e7bc40e0488d281e"
MAINTAINER="Cherife Li"
-EMAIL="cherife@dotimes.com"
-APPROVED="David Somero"
+EMAIL="cherife-#-dotimes.com"
+APPROVED="dsomero"
diff --git a/network/nginx/rc.nginx b/network/nginx/rc.nginx
index 88b917d360..0c82902992 100644
--- a/network/nginx/rc.nginx
+++ b/network/nginx/rc.nginx
@@ -1,38 +1,34 @@
#!/bin/sh
#
# Nginx daemon control script.
-#
-# This is an init script for the nginx daemon.
-# To use nginx, you must first set up the config file(s).
-#
-# Written for Slackware Linux by Cherife Li <cherife@dotimes.com>.
+# Written for Slackware Linux by Cherife Li <cherife-#-dotimes.com>.
-DAEMON=/usr/sbin/nginx
+BIN=/usr/sbin/nginx
CONF=/etc/nginx/nginx.conf
PID=/var/run/nginx.pid
nginx_start() {
# Sanity checks.
if [ ! -r $CONF ]; then # no config file, exit:
- echo "$CONF does not appear to exist; exiting..."
+ echo "$CONF does not appear to exist. Abort."
exit 1
fi
if [ -s $PID ]; then
- echo "Nginx appears to already be running..."
+ echo "Nginx appears to already be running?"
exit 1
fi
- echo "Starting Nginx server daemon:"
- if [ -x $DAEMON ]; then
- $DAEMON -c $CONF
+ echo "Starting Nginx server daemon..."
+ if [ -x $BIN ]; then
+ $BIN -c $CONF
fi
}
nginx_test_conf() {
echo "Checking configuration for correct syntax and"
echo "then trying to open files referenced in configuration..."
- $DAEMON -t -c $CONF
+ $BIN -t -c $CONF
}
nginx_term() {
@@ -61,7 +57,7 @@ nginx_upgrade() {
nginx_restart() {
nginx_quit
- sleep 5
+ sleep 3
nginx_start
}
@@ -88,5 +84,5 @@ case "$1" in
nginx_upgrade
;;
*)
- echo "usage: $0 {check|start|term|stop|reload|restart|upgrade}"
+ echo "usage: `basename $0` {check|start|term|stop|reload|restart|upgrade}"
esac
diff --git a/network/nginx/slack-desc b/network/nginx/slack-desc
index de2d8a147d..8c81a4b5f1 100644
--- a/network/nginx/slack-desc
+++ b/network/nginx/slack-desc
@@ -14,6 +14,6 @@ nginx:
nginx: Nginx was written by Igor Sysoev.
nginx:
nginx:
-nginx:
+nginx: Homepage: http://nginx.net/
nginx:
nginx: