summaryrefslogtreecommitdiffstats
path: root/network/spice-gtk/spice-gtk.SlackBuild
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2021-04-18 12:07:24 +0200
committer Matteo Bernardini <ponce@slackbuilds.org>2021-04-18 12:22:55 +0200
commit16054fb1b90e843b171732f7fb3eac5f4efe3773 (patch)
tree1184b9e1cdb2baa63e2a6a4adfe03235107b3796 /network/spice-gtk/spice-gtk.SlackBuild
parent104f3fb5dc0acee9d1c01dfa3357aa8b9a31b751 (diff)
downloadslackbuilds-16054fb1b90e843b171732f7fb3eac5f4efe3773.tar.gz
slackbuilds-16054fb1b90e843b171732f7fb3eac5f4efe3773.tar.xz
network/spice-gtk: Updated for version 0.39.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'network/spice-gtk/spice-gtk.SlackBuild')
-rw-r--r--network/spice-gtk/spice-gtk.SlackBuild57
1 files changed, 25 insertions, 32 deletions
diff --git a/network/spice-gtk/spice-gtk.SlackBuild b/network/spice-gtk/spice-gtk.SlackBuild
index bc3554fe27..06791ccc7f 100644
--- a/network/spice-gtk/spice-gtk.SlackBuild
+++ b/network/spice-gtk/spice-gtk.SlackBuild
@@ -1,7 +1,8 @@
#!/bin/sh
# Slackware build script for spice-gtk
-# Copyright 2013-2018 Matteo Bernardini <ponce@slackbuilds.org> Pisa, Italy
+
+# Copyright 2013-2021 Matteo Bernardini <ponce@slackbuilds.org> Pisa, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=spice-gtk
-VERSION=${VERSION:-0.35}
+VERSION=${VERSION:-0.39}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -58,7 +59,7 @@ if pkg-config --exists libusbredirhost; then usbredir="en"; else usbredir="dis";
if pkg-config --exists libcacard; then cacard="en"; else cacard="dis"; fi
if pkg-config --exists libphodav-2.0; then phodav="en"; else phodav="dis"; fi
-DOCS="AUTHORS COPYING NEWS README THANKS TODO"
+DOCS="AUTHORS CHANGELOG.md COPYING README.md"
set -e
@@ -67,7 +68,7 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -76,37 +77,29 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Disable broken tests
-sed -i 's/ tests//' Makefile.am Makefile.in
-
-export VALAC=$(which valac)
-export VAPIGEN=$(which vapigen)
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
+# Configure, build, and install:
+export CFLAGS="$SLKCFLAGS"
+export CXXFLAGS="$SLKCFLAGS"
+mkdir meson-build
+cd meson-build
+meson setup \
--prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
+ --libdir=lib${LIBDIRSUFFIX} \
+ --libexecdir=/usr/libexec \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --includedir=/usr/include \
+ --datadir=/usr/share \
--mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --sysconfdir=/etc \
--localstatedir=/var \
- --disable-static \
- --enable-shared \
- --with-gtk=3.0 \
- --enable-gstaudio=yes \
- --enable-gstvideo=yes \
- --disable-maintainer-mode \
- --enable-vala \
- --disable-celt051 \
- --enable-dbus=yes \
- --${usbredir}able-usbredir \
- --${cacard}able-smartcard \
- --${phodav}able-webdav \
- --build=$ARCH-slackware-linux
-
-make
-make install DESTDIR=$PKG
+ --buildtype=release \
+ -D gtk_doc=enabled \
+ -D usb-ids-path=/usr/share/hwdata/usb.ids \
+ .. || exit 1
+ "${NINJA:=ninja}" $NUMJOBS || exit 1
+ DESTDIR=$PKG $NINJA install || exit 1
+cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true