summaryrefslogtreecommitdiffstats
path: root/network/transmission/transmission.SlackBuild
diff options
context:
space:
mode:
author Iskar Enev <iskar.enev[@]gmail.com>2010-08-10 01:35:29 +0100
committer Michiel van Wessem <michiel@slackbuilds.org>2010-08-10 01:35:29 +0100
commitf15ce42eac2efdb9b7f60060215314f1220a2892 (patch)
treee6fd2848e447a70b00159b9ca0f9a6bc7312f903 /network/transmission/transmission.SlackBuild
parentebd1d1551aae67862e9453784a3dff37f427d208 (diff)
downloadslackbuilds-f15ce42eac2efdb9b7f60060215314f1220a2892.tar.gz
slackbuilds-f15ce42eac2efdb9b7f60060215314f1220a2892.tar.xz
network/transmission: Updaetd for version 2.0.3.
Signed-off-by: Michiel van Wessem <michiel@slackbuilds.org>
Diffstat (limited to 'network/transmission/transmission.SlackBuild')
-rw-r--r--network/transmission/transmission.SlackBuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/network/transmission/transmission.SlackBuild b/network/transmission/transmission.SlackBuild
index 6a41187245..b1bae6b467 100644
--- a/network/transmission/transmission.SlackBuild
+++ b/network/transmission/transmission.SlackBuild
@@ -3,16 +3,15 @@
# Written by Iskar Enev <iskar.enev[@]gmail.com>
PRGNAM=transmission
-VERSION=1.92
+VERSION=2.03
+ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -48,12 +47,8 @@ mkdir -p $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
+chmod -R a-s,u+w,go+r-w .
+
sed -i -e 's%-g -O3 -funroll-loops %%g' configure.ac
sed -i -e 's%-ggdb3 %%g' configure.ac
@@ -81,8 +76,12 @@ make install DESTDIR=$PKG
INSTALL_ROOT=$PKG/usr make install
)
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+)
( cd $PKG/usr/man
find . -type f -exec gzip -9 {} \;