summaryrefslogtreecommitdiffstats
path: root/network/uget-chrome-wrapper
diff options
context:
space:
mode:
author Macius Kuzmin <szczecinska.duma@gmail.com>2017-06-30 14:05:49 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-06-30 14:05:49 +0700
commitc8d1ca49e344ec5f1bd26540106eccf532db18b6 (patch)
treec460709575c2c220425043a3ed07054d0b48f789 /network/uget-chrome-wrapper
parent4fecab3cf3a445d4c96f1cea049f17079b143d33 (diff)
downloadslackbuilds-c8d1ca49e344ec5f1bd26540106eccf532db18b6.tar.gz
slackbuilds-c8d1ca49e344ec5f1bd26540106eccf532db18b6.tar.xz
network/uget-chrome-wrapper: Added (download manager).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network/uget-chrome-wrapper')
-rw-r--r--network/uget-chrome-wrapper/README2
-rw-r--r--network/uget-chrome-wrapper/slack-desc19
-rw-r--r--network/uget-chrome-wrapper/uget-chrome-wrapper.SlackBuild72
-rw-r--r--network/uget-chrome-wrapper/uget-chrome-wrapper.info14
4 files changed, 107 insertions, 0 deletions
diff --git a/network/uget-chrome-wrapper/README b/network/uget-chrome-wrapper/README
new file mode 100644
index 0000000000..a1cabbad2a
--- /dev/null
+++ b/network/uget-chrome-wrapper/README
@@ -0,0 +1,2 @@
+Integrate the famous FOSS uGet Download Manager with Google Chrome in Linux systems.
+With this tool, uGet can interrupt and catch your downloads from Google Chrome.
diff --git a/network/uget-chrome-wrapper/slack-desc b/network/uget-chrome-wrapper/slack-desc
new file mode 100644
index 0000000000..375cdaeb98
--- /dev/null
+++ b/network/uget-chrome-wrapper/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+uget-chrome-wrapper: uget-chrome-wrapper (download manager)
+uget-chrome-wrapper:
+uget-chrome-wrapper: Integrate uGet Download Manager with Google Chrome, Chromium,
+uget-chrome-wrapper: Vivaldi, Opera and Firefox
+uget-chrome-wrapper:
+uget-chrome-wrapper:
+uget-chrome-wrapper:
+uget-chrome-wrapper: Homepage: https://github.com/slgobinath/uget-chrome-wrapper
+uget-chrome-wrapper:
+uget-chrome-wrapper:
+uget-chrome-wrapper:
diff --git a/network/uget-chrome-wrapper/uget-chrome-wrapper.SlackBuild b/network/uget-chrome-wrapper/uget-chrome-wrapper.SlackBuild
new file mode 100644
index 0000000000..99cfaf422c
--- /dev/null
+++ b/network/uget-chrome-wrapper/uget-chrome-wrapper.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# Slackware build script for uget-chrome-wrapper
+
+# Copyright 2017 Matthew Kuzminski Toronto, ON
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=uget-chrome-wrapper
+VERSION=${VERSION:-2.0.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+ARCH=noarch
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $PKG
+mkdir -p "$PKG/usr/bin"
+install -Dm755 "$CWD"/uget-chrome-wrapper "$PKG"/usr/bin
+
+# Experimental (As I don't use these browsers I will not support this, nevertheless these are based on the Arch Linux AUR
+# PKGBUILD script and I have no reason to believe they wouldn't
+# work with Slackware. If you would like to try any of these out, uncommenting the respected sections should be enough)
+# Google Chrome Integration
+#mkdir -p "$PKG/etc/opt/chrome/native-messaging-hosts"
+#install -Dm644 "$CWD"/com.javahelps.ugetchromewrapper.json "$PKG"/etc/opt/chrome/native-messaging-hosts
+# Chromium and Vivaldi Integration
+#mkdir -p "$PKG/etc/chromium/native-messaging-hosts"
+#install -Dm644 "$CWD"/com.javahelps.ugetchromewrapper.json "$PKG"/etc/chromium/native-messaging-hosts
+# Opera Integration
+#mkdir -p "$PKG/etc/opera/native-messaging-hosts"
+#install -Dm644 "$CWD"/com.javahelps.ugetchromewrapper.json "$PKG"/etc/opera/native-messaging-hosts
+# End Experimental
+
+# Firefox Integration
+mkdir -p "$PKG/usr/lib${LIBDIRSUFFIX}/mozilla/native-messaging-hosts"
+install -Dm644 "$CWD"/com.javahelps.ugetfirefoxwrapper.json "$PKG"/usr/lib${LIBDIRSUFFIX}/mozilla/native-messaging-hosts
+
+chown -R root:root .
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/uget-chrome-wrapper/uget-chrome-wrapper.info b/network/uget-chrome-wrapper/uget-chrome-wrapper.info
new file mode 100644
index 0000000000..eefd9cad37
--- /dev/null
+++ b/network/uget-chrome-wrapper/uget-chrome-wrapper.info
@@ -0,0 +1,14 @@
+PRGNAM="uget-chrome-wrapper"
+VERSION="2.0.4"
+HOMEPAGE="https://github.com/slgobinath/uget-chrome-wrapper"
+DOWNLOAD="https://raw.githubusercontent.com/slgobinath/uget-chrome-wrapper/v2.0.4/uget-chrome-wrapper/bin/uget-chrome-wrapper \
+ https://raw.githubusercontent.com/slgobinath/uget-chrome-wrapper/v2.0.4/uget-chrome-wrapper/conf/com.javahelps.ugetchromewrapper.json \
+ https://raw.githubusercontent.com/slgobinath/uget-chrome-wrapper/v2.0.4/uget-chrome-wrapper/conf/com.javahelps.ugetfirefoxwrapper.json"
+MD5SUM="d824ef742a548a5613caadbad78475f2 \
+ 7c185094db349599f8375866796db33a \
+ 4806bc4553389cc0610e642b12510246"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="uget python3"
+MAINTAINER="Macius Kuzmin"
+EMAIL="szczecinska.duma@gmail.com"