summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@slackbuilds.org>2010-05-12 11:47:56 +0200
committer Heinz Wiesinger <pprkut@slackbuilds.org>2010-05-12 11:47:56 +0200
commit8f808a8b505610071d3120ed4b470c397935392c (patch)
treee1f61a4805810f92e14439374eeadb38c2a96ecb /network
parent231d9b0c7adfe06c5355591d4ef88f7c859e42cd (diff)
downloadslackbuilds-8f808a8b505610071d3120ed4b470c397935392c.tar.gz
slackbuilds-8f808a8b505610071d3120ed4b470c397935392c.tar.xz
network/museek-plus: Removed from 12.2 repository
Diffstat (limited to 'network')
-rw-r--r--network/museek-plus/README28
-rw-r--r--network/museek-plus/doinst.sh28
-rw-r--r--network/museek-plus/museek-plus.SlackBuild77
-rw-r--r--network/museek-plus/museek-plus.info8
-rw-r--r--network/museek-plus/museek-qsa.patch16
-rw-r--r--network/museek-plus/rc.museekd105
-rw-r--r--network/museek-plus/slack-desc19
7 files changed, 0 insertions, 281 deletions
diff --git a/network/museek-plus/README b/network/museek-plus/README
deleted file mode 100644
index 9ea53b8be9..0000000000
--- a/network/museek-plus/README
+++ /dev/null
@@ -1,28 +0,0 @@
-Museek+ is a file-sharing application for the Soulseek peer-to-peer network,
-written in C++. It's an enhanced version of Hyriand's original Museek
-(see http://museek.thegraveyard.org). It supports chat, transferring files,
-searching, user-management, shares browsing and more. The new features are:
-room searching, interests, buddy-only shares, banlists, icon themes, and
-font/color selecting.
-
-Museek+ consists of museekd (daemon), muscan (shares scanning tool), muscand
-(automated shares scanning tool), musetup (command-line configuration script),
-musetup-gtk (PyGTK configuration app), museeq (QT GUI client), mucous (curses
-python client), murmur (PyGTK client) and museekcontrol (command-line python
-client).
-
-After installing museek+ follow these steps:
- 1) Configure your settings with musetup: server, username, password,
- interface password, download directory, shared directories.
- 2) Run museekd.
- 3) Run museeq, mucous, or museekcontrol.
- 4) Login into museekd via the interface socket or host:port and the
- interface password.
-
-Requires: scons, libsig++, libxml++ and Swig. PyGTK (for musetup-gtk)
-and QSA are optional dependencies.
-Slackbuilds for all the requirements (except QSA, which is optional)
-are available at SlackBuilds.org.
-
-An example init script (rc.museekd) for the museekd daemon is provided.
-Feel free to modify it for your needs. Use it at your own risk.
diff --git a/network/museek-plus/doinst.sh b/network/museek-plus/doinst.sh
deleted file mode 100644
index 7d8815d8fc..0000000000
--- a/network/museek-plus/doinst.sh
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/bin/sh
-
-config() {
- NEW="$1"
- OLD="$(dirname $NEW)/$(basename $NEW .new)"
- # If there's no config file by that name, mv it over:
- if [ ! -r $OLD ]; then
- mv $NEW $OLD
- elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
- # toss the redundant copy
- rm $NEW
- fi
- # Otherwise, we leave the .new copy for the admin to consider...
-}
-
-# Keep same perms on rc.museekd.new:
-#if [ -e etc/rc.d/rc.museekd ]; then
-# cp -a etc/rc.d/rc.museekd etc/rc.d/rc.museekd.new.incoming
-# cat etc/rc.d/rc.museekd.new > etc/rc.d/rc.museekd.new.incoming
-# mv etc/rc.d/rc.museekd.new.incoming etc/rc.d/rc.museekd.new
-#fi
-#
-#config etc/rc.d/rc.museekd.new
-
-if [ -x usr/bin/update-desktop-database ]; then
- usr/bin/update-desktop-database usr/share/applications >/dev/null 2>&1
-fi
-
diff --git a/network/museek-plus/museek-plus.SlackBuild b/network/museek-plus/museek-plus.SlackBuild
deleted file mode 100644
index 3daf7e058c..0000000000
--- a/network/museek-plus/museek-plus.SlackBuild
+++ /dev/null
@@ -1,77 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for museek+
-# Written by Iskar Enev <iskar.enev[@]gmail.com>
-
-set -e
-
-PRGNAM=museek-plus
-PKGNAME=museek+
-VERSION=0.1.13
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PKGNAME
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-fi
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PKGNAME-$VERSION
-tar xvf $CWD/$PKGNAME-$VERSION.tar.bz2
-cd $PKGNAME-$VERSION
-chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
-
-# Allow museeq to compile without QSA (which is optional)
-cat $CWD/museek-qsa.patch | patch -p0
-
-cmake -DPREFIX=/usr \
- -DMANDIR=man \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DSWIG_DIR:PATH=`swig -swiglib` \
- -DEVERYTHING=1 \
- -DTRAYICON=1 \
- -DBINRELOC=0
-
-make VERBOSE=1
-make install VERBOSE=1 DESTDIR=$PKG
-
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-)
-
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
-)
-
-rm -rf $PKG/usr/share/config.xml.tmpl
-
-mkdir -p $PKG/usr/share/museek/museeq/icons
-mv $PKG/usr/share/museek/museeq/{bluebox,default,mikelabo-silk,mikelabo-tri} \
- $PKG/usr/share/museek/museeq/icons
-
-mkdir -p $PKG/usr/doc/$PKGNAME-$VERSION
-cp -a CHANGELOG COPYING CREDITS FILES INSTALL* INSTRUCTIONS LICENSE \
- README TODO doc/protocol.tmpl $PKG/usr/doc/$PKGNAME-$VERSION
-chmod 644 $PKG/usr/doc/$PKGNAME-$VERSION/*
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PKGNAME-$VERSION/$PRGNAM.SlackBuild
-cat $CWD/rc.museekd > $PKG/usr/doc/$PKGNAME-$VERSION/rc.museekd.new
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PKGNAME-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/network/museek-plus/museek-plus.info b/network/museek-plus/museek-plus.info
deleted file mode 100644
index f4658024b7..0000000000
--- a/network/museek-plus/museek-plus.info
+++ /dev/null
@@ -1,8 +0,0 @@
-PRGNAM="museek-plus"
-VERSION="0.1.13"
-HOMEPAGE="http://museek-plus.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/museek-plus/museek+-0.1.13.tar.bz2"
-MD5SUM="7aada627839578ebe525c54a1cef7dc4"
-MAINTAINER="Iskar Enev"
-EMAIL="iskar.enev@gmail.com"
-APPROVED="rworkman"
diff --git a/network/museek-plus/museek-qsa.patch b/network/museek-plus/museek-qsa.patch
deleted file mode 100644
index a0d29c5df5..0000000000
--- a/network/museek-plus/museek-qsa.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- museeq/CMakeLists.txt
-+++ museeq/CMakeLists.txt
-@@ -305,7 +305,12 @@
-
- add_executable(museeq ${MUSEEQ_SOURCES} ${MUSEEQ_MOC_HEADERS})
-
--target_link_libraries(museeq Mucipher ${QT_LIBRARIES} ${QSA_LIBRARY})
-+set(LINK_LIBRARIES Mucipher ${QT_LIBRARIES})
-+if (QSA)
-+ set(LINK_LIBRARIES ${LINK_LIBRARIES} ${QSA_LIBRARY})
-+endif (QSA)
-+
-+target_link_libraries(museeq ${LINK_LIBRARIES})
-
- install(
- TARGETS museeq
diff --git a/network/museek-plus/rc.museekd b/network/museek-plus/rc.museekd
deleted file mode 100644
index 8c74eb95ab..0000000000
--- a/network/museek-plus/rc.museekd
+++ /dev/null
@@ -1,105 +0,0 @@
-#!/bin/sh
-#
-# This shell script takes care of starting and stopping museekd.
-
-MUSEEKD=/usr/bin/museekd
-MUSETUP=/usr/bin/musetup
-MUSCAN=/usr/bin/muscan
-MUSOCKET=/tmp/museekd.root
-PIDFILE=/var/run/museekd.pid
-DBDIR=/var/museek
-CONFIG=$DBDIR/museekd.xml
-CHOWNSOCKET=YES
-
-case "$1" in
- start)
- if [ ! -d $DBDIR ]; then
- mkdir $DBDIR
- fi
- if [ ! -f $CONFIG ]; then
- echo -n "Starting Museek Setup"
- echo
- if [ ! -d $DBDIR ]; then
- mkdir $DBDIR
- fi
- $MUSETUP $CONFIG
- echo
- fi
- if [ -f $PIDFILE ]; then
- echo -n "Museek Daemon already running (or zombie pid file in /var/run/)"
- echo
- exit
- fi
- echo -n "Starting Museek Daemon"
- $MUSEEKD -c $CONFIG &>/dev/null &
- PID="$!"
- sleep 2
- if kill -0 $PID # pid check
- then
- if [ $CHOWNSOCKET = YES ];
- then
- if [ -e $MUSOCKET ]; then chmod 666 $MUSOCKET
- # access the museekd socket from other users, may be a security risk on multiuser systems
- fi
- fi
- echo $PID > $PIDFILE
- echo
- else
- echo -n "Museekd isn't starting up properly. Check your Config file, \nor run 'museekd -c /var/museek/museekd.xml' for verbose messages."
- echo
- fi
- ;;
- stop)
- echo -n "Stopping Museek Daemon"
- echo
- if [ -f $PIDFILE ]; then
- kill -15 $(cat $PIDFILE) &>/dev/null
- rm $PIDFILE
- else
- echo -n "Museek Daemon not running"
- echo
- exit
- fi
- ;;
- reconnect)
- if [ -f $PIDFILE ]; then
- echo -n "Attempting to reconnect Museekd to the Server"
- kill -ALRM $(cat $PIDFILE) &>/dev/null
- echo
- fi
- ;;
- restart)
- $0 stop
- sleep 3
- $0 start
- ;;
- rescan)
- echo -n "Starting Muscan, rescanning shared files"
- echo
- $MUSCAN -c $CONFIG -r -v
- echo
- $0 reload
- ;;
- setup)
- echo -n "Starting Museek Setup"
- echo
- if [ ! -d $DBDIR ]; then
- mkdir $DBDIR
- fi
- $MUSETUP $CONFIG
- echo
- ;;
- reload)
- if [ -f $PIDFILE ]; then
- echo -n "Reloading Museek Daemon to update Shares"
- kill -HUP $(cat $PIDFILE)
- echo
- else
- echo -n "Museek Daemon not running, can't reload shares"
- echo
- fi
- ;;
- *)
- echo "usage: $0 {start|stop|restart|rescan|reconnect|setup|reload}"
- echo -n
-esac
diff --git a/network/museek-plus/slack-desc b/network/museek-plus/slack-desc
deleted file mode 100644
index 7203e36f4e..0000000000
--- a/network/museek-plus/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|' on
-# the right side marks the last column you can put a character in. You must make
-# exactly 11 lines for the formatting to be correct. It's also customary to
-# leave one space after the ':'.
-
- |-----handy-ruler---------------------------------------------------------|
-museek+: museek+ (file-sharing application)
-museek+:
-museek+: Museek+ is a file-sharing application for the Soulseek p2p network,
-museek+: written in C++. It's an enhanced version of Hyriand's original Museek
-museek+: (http://museek.thegraveyard.org). It supports chat, transferring files,
-museek+: searching, user-management, sharing, banlists, interests and more.
-museek+: Museek+ consists of museekd (daemon), muscan (shares scanning tool),
-museek+: muscand (automated shares scanning tool), musetup (command-line
-museek+: configuration script), musetup-gtk (PyGTK configuration app), museeq
-museek+: (QT GUI client), mucous (curses python client), museekcontrol
-museek+: (command-line python client) and murmur (PyGTK client).