summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author David Woodfall <dave@dawoodfall.net>2018-07-27 15:26:04 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-07-28 08:51:48 +0700
commit40680d1d4f8c8738e1b81b91b178ca7112f0ffa2 (patch)
tree2e6217a512e17fbacafe557ac592417adf769241 /network
parentf6eaad2bb2d889f2326a4691d2bab14ea31106fa (diff)
downloadslackbuilds-40680d1d4f8c8738e1b81b91b178ca7112f0ffa2.tar.gz
slackbuilds-40680d1d4f8c8738e1b81b91b178ca7112f0ffa2.tar.xz
network/persepolis: Added (Download Manager for aria2).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/persepolis/README15
-rw-r--r--network/persepolis/doinst.sh3
-rw-r--r--network/persepolis/persepolis.SlackBuild91
-rw-r--r--network/persepolis/persepolis.info10
-rw-r--r--network/persepolis/slack-desc19
5 files changed, 138 insertions, 0 deletions
diff --git a/network/persepolis/README b/network/persepolis/README
new file mode 100644
index 0000000000..c4e5d5c42f
--- /dev/null
+++ b/network/persepolis/README
@@ -0,0 +1,15 @@
+Persepolis Download Manager is a GUI for aria2
+
+Persepolis is a Download Manager & a GUI For aria2. It's written in
+Python. Persepolis is a sample of free and open source software.
+It's developed For GNU/Linux Distributions, BSDs, MacOS and Microsoft
+Windows.
+
+Features:
+
+* Multi segment downloading
+* Scheduling downloads
+* Download queuing
+* Finding and downloading video from Youtube, Vimeo, DailyMotion, etc.
+
+Important: you will need to build all the dependencies with python3 support.
diff --git a/network/persepolis/doinst.sh b/network/persepolis/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/network/persepolis/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/network/persepolis/persepolis.SlackBuild b/network/persepolis/persepolis.SlackBuild
new file mode 100644
index 0000000000..d499b1c620
--- /dev/null
+++ b/network/persepolis/persepolis.SlackBuild
@@ -0,0 +1,91 @@
+#!/bin/sh
+
+# Slackware build script for persepolis
+# Copyright 2018 David Woodfall <dave@dawoodfall.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=persepolis
+VERSION=${VERSION:-3.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mv $PKG/usr/share/man $PKG/usr
+mv $PKG/usr/share/applications/com.github.persepolisdm.persepolis.desktop \
+ $PKG/usr/share/applications/persepolis.desktop
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.md requirements.md LICENSE \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/persepolis/persepolis.info b/network/persepolis/persepolis.info
new file mode 100644
index 0000000000..073716b65b
--- /dev/null
+++ b/network/persepolis/persepolis.info
@@ -0,0 +1,10 @@
+PRGNAM="persepolis"
+VERSION="3.1.0"
+HOMEPAGE="https://persepolisdm.github.io"
+DOWNLOAD="https://github.com/persepolisdm/persepolis/archive/3.1.0/persepolis-3.1.0.tar.gz"
+MD5SUM="ade1aca47186df8a3521ac3d356c328d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-PyQt5 python-requests setproctitle psutil aria2 python-notify2 youtube-dl"
+MAINTAINER="David Woodfall"
+EMAIL="dave@dawoodfall.net"
diff --git a/network/persepolis/slack-desc b/network/persepolis/slack-desc
new file mode 100644
index 0000000000..0ffe325f53
--- /dev/null
+++ b/network/persepolis/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+persepolis: persepolis (Persepolis Download Manager is a GUI for aria2)
+persepolis:
+persepolis: Persepolis is a Download Manager & a GUI For aria2. It's written in
+persepolis: Python. Persepolis is a sample of free and open source software.
+persepolis: It's developed For GNU/Linux Distributions, BSDs, MacOS and Microsoft
+persepolis: Windows.
+persepolis:
+persepolis: Multi segment downloading, Scheduling downloads, Download queuing,
+persepolis: Finding and downloading video from Youtube, Vimeo, DailyMotion, etc.
+persepolis:
+persepolis: https://persepolisdm.github.io