summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2010-05-12 23:31:57 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-12 23:31:57 +0200
commit4f593e6145ffc72d2387e25075915535d5401a70 (patch)
treed0591ca9b0cdcad5c61b5a44225a48d2acc51b3d /network
parent1d6a191cc4e22d1b6464a5c1cac4701c7fca1757 (diff)
downloadslackbuilds-4f593e6145ffc72d2387e25075915535d5401a70.tar.gz
slackbuilds-4f593e6145ffc72d2387e25075915535d5401a70.tar.xz
network/authbind: Added to 12.2 repository
Diffstat (limited to 'network')
-rw-r--r--network/authbind/README1
-rw-r--r--network/authbind/authbind.SlackBuild64
-rw-r--r--network/authbind/authbind.info8
-rw-r--r--network/authbind/slack-desc19
4 files changed, 92 insertions, 0 deletions
diff --git a/network/authbind/README b/network/authbind/README
new file mode 100644
index 0000000000..03a5013a77
--- /dev/null
+++ b/network/authbind/README
@@ -0,0 +1 @@
+authbind allows non-root processes to bind to ports 1 to 511.
diff --git a/network/authbind/authbind.SlackBuild b/network/authbind/authbind.SlackBuild
new file mode 100644
index 0000000000..f69d0d628c
--- /dev/null
+++ b/network/authbind/authbind.SlackBuild
@@ -0,0 +1,64 @@
+#!/bin/sh
+
+# Slackware build script for authbind
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+PRGNAM=authbind
+VERSION=${VERSION:-1.2.0}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/${PRGNAM}_$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R a-s,u+w,go+r-w .
+
+make \
+ OPTIMISE="$SLKCFLAGS" \
+ prefix=/usr \
+ lib_dir=/usr/lib${LIBDIRSUFFIX}/authbind \
+ mandir=/usr/man
+
+mkdir -p $PKG/usr/bin
+make install \
+ prefix=$PKG/usr \
+ lib_dir=$PKG/usr/lib${LIBDIRSUFFIX}/authbind \
+ man_dir=$PKG/usr/man \
+ etc_dir=$PKG/etc/$PRGNAM
+make install_man man_dir=$PKG/usr/man
+
+gzip $PKG/usr/man/man?/*.?
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp debian/changelog debian/copyright $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/network/authbind/authbind.info b/network/authbind/authbind.info
new file mode 100644
index 0000000000..5a81ba61d0
--- /dev/null
+++ b/network/authbind/authbind.info
@@ -0,0 +1,8 @@
+PRGNAM="authbind"
+VERSION="1.2.0"
+HOMEPAGE="http://www.chiark.greenend.org.uk/ucgi/~ijackson/cvsweb/authbind/"
+DOWNLOAD="http://ftp.debian.org/debian/pool/main/a/authbind/authbind_1.2.0.tar.gz"
+MD5SUM="6c3a105f4d366a8ebaa3224300a8c4db"
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
+APPROVED="rworkman"
diff --git a/network/authbind/slack-desc b/network/authbind/slack-desc
new file mode 100644
index 0000000000..a65cf670c3
--- /dev/null
+++ b/network/authbind/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+authbind: authbind (allow non-root processes to bind to ports 1 to 511)
+authbind:
+authbind: authbind allows non-root processes to bind to ports 1 to 511.
+authbind:
+authbind:
+authbind:
+authbind:
+authbind:
+authbind:
+authbind:
+authbind: