summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author LukenShiro <lukenshiro@ngi.it>2010-05-13 01:00:21 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-13 01:00:21 +0200
commit7d2aa13af582cfc1a1be46835f0890521a318f63 (patch)
tree23ec98f21e266f439d82eb95b35d82071b5b9231 /network
parent57ca8b4f852a9847e48b52c77bce5f66ae306e7c (diff)
downloadslackbuilds-7d2aa13af582cfc1a1be46835f0890521a318f63.tar.gz
slackbuilds-7d2aa13af582cfc1a1be46835f0890521a318f63.tar.xz
network/pyzor: Added to 13.0 repository
Diffstat (limited to 'network')
-rw-r--r--network/pyzor/README2
-rw-r--r--network/pyzor/pyzor.SlackBuild66
-rw-r--r--network/pyzor/pyzor.info10
-rw-r--r--network/pyzor/slack-desc19
4 files changed, 97 insertions, 0 deletions
diff --git a/network/pyzor/README b/network/pyzor/README
new file mode 100644
index 0000000000..e103e33d9a
--- /dev/null
+++ b/network/pyzor/README
@@ -0,0 +1,2 @@
+Pyzor is a collaborative, networked system to detect and block spam
+using digests of messages.
diff --git a/network/pyzor/pyzor.SlackBuild b/network/pyzor/pyzor.SlackBuild
new file mode 100644
index 0000000000..ba13e202c4
--- /dev/null
+++ b/network/pyzor/pyzor.SlackBuild
@@ -0,0 +1,66 @@
+#!/bin/sh
+
+# Slackware build script for pyzor
+
+# Copyright 2009 LukenShiro <lukenshiro@ngi.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pyzor
+VERSION=${VERSION:-0.5.0}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+# docs/usage.html directly installed
+DOCFILES="COPYING INSTALL NEWS PKG-INFO README THANKS UPGRADING"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# Avoid /usr/share/doc html file's installation
+sed -r -i "s|share/doc/pyzor|doc/pyzor-$VERSION|g" setup.py
+python setup.py install --prefix=/usr --root=$PKG
+
+mkdir -p $PKG/usr/man/man1
+cp -a docs/pyzor*.1 $PKG/usr/man/man1
+find $PKG/usr/man -type f -exec gzip -9 {} \; 2>/dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/pyzor/pyzor.info b/network/pyzor/pyzor.info
new file mode 100644
index 0000000000..6349abf10e
--- /dev/null
+++ b/network/pyzor/pyzor.info
@@ -0,0 +1,10 @@
+PRGNAM="pyzor"
+VERSION="0.5.0"
+HOMEPAGE="http://pyzor.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/pyzor/pyzor-0.5.0.tar.gz"
+MD5SUM="d752c1d34132a15bda7767306553911e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="LukenShiro"
+EMAIL="lukenshiro@ngi.it"
+APPROVED="rworkman"
diff --git a/network/pyzor/slack-desc b/network/pyzor/slack-desc
new file mode 100644
index 0000000000..43ba3ca778
--- /dev/null
+++ b/network/pyzor/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler--------------------------------------------------------|
+pyzor: pyzor (Spam detection and filtering network)
+pyzor:
+pyzor: Pyzor is a collaborative, networked system to detect and block spam
+pyzor: using digests of messages.
+pyzor:
+pyzor: Homepage: http://pyzor.sourceforge.net/
+pyzor:
+pyzor:
+pyzor:
+pyzor:
+pyzor: