summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Nishant Limbachia <nishant@mnspace.net>2011-12-17 10:38:15 -0600
committer Niels Horn <niels.horn@slackbuilds.org>2011-12-18 00:05:10 -0200
commita60ade573538c1b09098283ce1055f2fa72034f7 (patch)
treeb83b830605234d243560466ba3c993f235659b83 /network
parent534b7b8c7197c432f8f49a2739f4a523ab11f908 (diff)
downloadslackbuilds-a60ade573538c1b09098283ce1055f2fa72034f7.tar.gz
slackbuilds-a60ade573538c1b09098283ce1055f2fa72034f7.tar.xz
network/offlineimap: Updated for version 6.4.0
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/offlineimap/doinst.sh1
-rw-r--r--network/offlineimap/offlineimap.SlackBuild17
-rw-r--r--network/offlineimap/offlineimap.info6
-rw-r--r--network/offlineimap/patches/Makefile.doc.patch (renamed from network/offlineimap/patches/doc_generation_fix.patch)4
-rw-r--r--network/offlineimap/patches/manual.rst.patch20
-rw-r--r--network/offlineimap/slack-desc4
6 files changed, 16 insertions, 36 deletions
diff --git a/network/offlineimap/doinst.sh b/network/offlineimap/doinst.sh
index 26d94b2302..7697c74085 100644
--- a/network/offlineimap/doinst.sh
+++ b/network/offlineimap/doinst.sh
@@ -11,5 +11,4 @@ config() {
fi
# Otherwise, we leave the .new copy for the admin to consider...
}
-
config etc/offlineimap.conf.new
diff --git a/network/offlineimap/offlineimap.SlackBuild b/network/offlineimap/offlineimap.SlackBuild
index e018b31e64..7acacb47f9 100644
--- a/network/offlineimap/offlineimap.SlackBuild
+++ b/network/offlineimap/offlineimap.SlackBuild
@@ -3,7 +3,8 @@
# Slackware build script for OfflineIMAP
# Home Page https://github.com/nicolas33/offlineimap
-# Copyright (c) 2008-2011, Nishant Limbachia, Hoffman Estates, IL, USA <nishant _AT_ mnspace _DOT_ net>
+# Copyright (c) 2008-2011, Nishant Limbachia, Hoffman Estates, IL, USA
+# <nishant _AT_ mnspace _DOT_ net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,9 +25,9 @@
# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-SRCNAM="nicolas33-offlineimap-v6.3.4-0-g61e50b3"
+SRCNAM="nicolas33-offlineimap-v6.4.0-0-gc1120c9"
PRGNAM="offlineimap"
-VERSION=${VERSION:-6.3.4}
+VERSION=${VERSION:-6.4.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -45,11 +46,14 @@ OUTPUT=${OUTPUT:-/tmp}
set -e # Exit on most errors
+# In case the source was fetched with wget or some other downloader:
+[ -e v${VERSION} ] && mv v${VERSION} $SRCNAM.tar.gz
+
rm -fr $TMP/$PRGNAM-$VERSION $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
tar xvf $CWD/$SRCNAM.tar.gz
-mv nicolas33-offlineimap-94450e9 $PRGNAM-$VERSION
+mv nicolas33-offlineimap-b1bff15 $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
chown -R root.root .
@@ -59,11 +63,8 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-### fix the manual file to build correctly
-patch -p0 < $CWD/patches/manual.rst.patch
-
### Patch makefile to disable building dev docs
-patch -p0 < $CWD/patches/doc_generation_fix.patch
+patch -p0 < $CWD/patches/Makefile.doc.patch
### build and install
python setup.py install --root=$PKG
diff --git a/network/offlineimap/offlineimap.info b/network/offlineimap/offlineimap.info
index 4678f5b54e..e2718a544c 100644
--- a/network/offlineimap/offlineimap.info
+++ b/network/offlineimap/offlineimap.info
@@ -1,8 +1,8 @@
PRGNAM="offlineimap"
-VERSION="6.3.4"
+VERSION="6.4.0"
HOMEPAGE="https://github.com/nicolas33/offlineimap"
-DOWNLOAD="https://github.com/nicolas33/offlineimap/tarball/v6.3.4"
-MD5SUM="84c42088ffcc7092473fef76e17c082b"
+DOWNLOAD="https://github.com/nicolas33/offlineimap/tarball/v6.4.0"
+MD5SUM="b7596598ca61347b8c96f8412cfd7dc0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Nishant Limbachia"
diff --git a/network/offlineimap/patches/doc_generation_fix.patch b/network/offlineimap/patches/Makefile.doc.patch
index 1b69ffdca3..3540a7aed1 100644
--- a/network/offlineimap/patches/doc_generation_fix.patch
+++ b/network/offlineimap/patches/Makefile.doc.patch
@@ -1,5 +1,5 @@
---- Makefile.orig 2011-09-09 16:00:42.784605863 -0500
-+++ Makefile 2011-09-09 16:00:50.423804120 -0500
+--- Makefile.orig 2011-12-03 12:09:16.547477510 -0600
++++ Makefile 2011-12-03 12:09:45.284443743 -0600
@@ -44,7 +44,6 @@
@$(MAKE) -C docs man
diff --git a/network/offlineimap/patches/manual.rst.patch b/network/offlineimap/patches/manual.rst.patch
deleted file mode 100644
index 9b40e4bd38..0000000000
--- a/network/offlineimap/patches/manual.rst.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- docs/MANUAL.rst.orig 2011-08-10 14:44:58.000000000 -0500
-+++ docs/MANUAL.rst 2011-09-09 15:43:23.813649765 -0500
-@@ -380,7 +380,7 @@
- default.
-
- Certificate checking
--^^^^^^^^^^^^^^^^^^^^
-+====================
-
- Unfortunately, by default we will not verify the certificate of an IMAP
- TLS/SSL server we connect to, so connecting by SSL is no guarantee
-@@ -397,7 +397,7 @@
- certificate and CA certificate.
-
- StartTLS
--^^^^^^^^
-+========
-
- If you have not configured your account to connect via SSL anyway,
- OfflineImap will still attempt to set up an SSL connection via the
diff --git a/network/offlineimap/slack-desc b/network/offlineimap/slack-desc
index 0ebedae2db..81b7ffb77b 100644
--- a/network/offlineimap/slack-desc
+++ b/network/offlineimap/slack-desc
@@ -5,15 +5,15 @@
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
- |-----handy-ruler------------------------------------------------------|
+ |-----handy-ruler-----------------------------------------------|
offlineimap: offlineimap (IMAP sync tool)
offlineimap:
offlineimap: OfflineIMAP allows you to sync imap mailboxes between remote
offlineimap: and local machines. It is most useful in syncing user
offlineimap: mailboxes between imap servers.
offlineimap:
-offlineimap: Homepage: https://github.com/nicolas33/offlineimap
offlineimap:
offlineimap:
+offlineimap: Homepage: https://github.com/nicolas33/offlineimap
offlineimap:
offlineimap: