summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Ilya Etingof <ilya@glas.net>2011-12-18 00:04:04 -0600
committer Robby Workman <rworkman@slackbuilds.org>2011-12-18 00:04:04 -0600
commitad4ad1471a706b8393709a66ccd505744f69f0d4 (patch)
tree348626410ca864e17371e6e96a549fd2fbd7fca7 /network
parent0a64d3902cf566ec509bca669b9bf90f0125cd16 (diff)
downloadslackbuilds-ad4ad1471a706b8393709a66ccd505744f69f0d4.tar.gz
slackbuilds-ad4ad1471a706b8393709a66ccd505744f69f0d4.tar.xz
network/snmpsim: Added (SNMP Agent simulator)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/snmpsim/README3
-rw-r--r--network/snmpsim/slack-desc19
-rw-r--r--network/snmpsim/snmpsim.SlackBuild66
-rw-r--r--network/snmpsim/snmpsim.info10
4 files changed, 98 insertions, 0 deletions
diff --git a/network/snmpsim/README b/network/snmpsim/README
new file mode 100644
index 0000000000..ad7fd59fc8
--- /dev/null
+++ b/network/snmpsim/README
@@ -0,0 +1,3 @@
+snmpsim is an SNMP Agent simulator.
+
+This requires pysnmp.
diff --git a/network/snmpsim/slack-desc b/network/snmpsim/slack-desc
new file mode 100644
index 0000000000..e2864a39d9
--- /dev/null
+++ b/network/snmpsim/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler----------------------------------------------------|
+snmpsim: snmpsim (SNMP Agent simulator)
+snmpsim:
+snmpsim: snmpsim is an SNMP Agent simulator. Its features include:
+snmpsim:
+snmpsim: - Pure-Python, easy to deploy and highly portable
+snmpsim: - SNMPv1/v2c/v3 support
+snmpsim: - SNMP Agent snapshotting tool included
+snmpsim:
+snmpsim: Homepage: http://sourceforge.net/projects/snmpsim/
+snmpsim:
+snmpsim:
diff --git a/network/snmpsim/snmpsim.SlackBuild b/network/snmpsim/snmpsim.SlackBuild
new file mode 100644
index 0000000000..03e828da4c
--- /dev/null
+++ b/network/snmpsim/snmpsim.SlackBuild
@@ -0,0 +1,66 @@
+#!/bin/sh
+
+# Slackware build script for snmpsim.
+
+# Copyright 2011 Ilya Etingof <ilya@glas.net>, Moscow, RU
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+
+PRGNAM=snmpsim
+VERSION=${VERSION:-0.0.10}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+ARCH=noarch
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+# Nothing but an egg file here, so we'll wipe it and make this a noarch pack
+rm -r $PKG/usr/lib*
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.txt CHANGES.txt LICENSE.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/snmpsim/snmpsim.info b/network/snmpsim/snmpsim.info
new file mode 100644
index 0000000000..ce6748a42d
--- /dev/null
+++ b/network/snmpsim/snmpsim.info
@@ -0,0 +1,10 @@
+PRGNAM="snmpsim"
+VERSION="0.0.10"
+HOMEPAGE="http://sourceforge.net/projects/snmpsim/"
+DOWNLOAD="http://downloads.sourceforge.net/snmpsim/snmpsim-0.0.10.tar.gz"
+MD5SUM="9cf35ba624f09a2d723fa9dea83f243f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Ilya Etingof"
+EMAIL="ilya@glas.net"
+APPROVED="rworkman"