summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2014-03-02 23:09:02 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-03-03 01:13:10 +0700
commitb02b2c225aa545e174ae4c4de6df905e98c6f214 (patch)
treee977b07c9f2dd98406703a6513b0c492d8322805 /network
parent82bcb9ba48d1b2e62f2d97aa130c86ce1f6036ff (diff)
downloadslackbuilds-b02b2c225aa545e174ae4c4de6df905e98c6f214.tar.gz
slackbuilds-b02b2c225aa545e174ae4c4de6df905e98c6f214.tar.xz
network/flexget: Updated for version 1.2.102 + New Maintainer.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/flexget/flexget.SlackBuild51
-rw-r--r--network/flexget/flexget.info12
2 files changed, 40 insertions, 23 deletions
diff --git a/network/flexget/flexget.SlackBuild b/network/flexget/flexget.SlackBuild
index ad3e9ddfca..dbe7952090 100644
--- a/network/flexget/flexget.SlackBuild
+++ b/network/flexget/flexget.SlackBuild
@@ -1,17 +1,37 @@
#!/bin/sh
+
+# Slackware build script for flexget
+
# Generated by Alien's SlackBuild Toolkit: http://slackware.com/~alien/AST
# Copyright 2009-2010 Eric Hameleers, Eindhoven, Netherlands
-# Slackware build script for flexget
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
# Written by Lionel Young <redtricycle@gmail.com>
-# Based on http://slackbuilds.org/template.SlackBuild
+#
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=flexget
-VERSION=${VERSION:-1.0r1656}
+SRCNAM=FlexGet
+VERSION=${VERSION:-1.2.102}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-TARNAM=FlexGet # their tarball is capitalized
-
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
@@ -30,23 +50,20 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$TARNAM-$VERSION.tar.gz
-cd $TARNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py build || exit 1
-python setup.py install --root=$PKG || exit 1
+python setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- README LICENSE PKG-INFO \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.rst PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/network/flexget/flexget.info b/network/flexget/flexget.info
index 2b21649ceb..d57a0351d5 100644
--- a/network/flexget/flexget.info
+++ b/network/flexget/flexget.info
@@ -1,10 +1,10 @@
PRGNAM="flexget"
-VERSION="1.0r1656"
+VERSION="1.2.102"
HOMEPAGE="http://flexget.com/"
-DOWNLOAD="http://ponce.cc/slackware/sources/repo/FlexGet-1.0r1656.tar.gz"
-MD5SUM="f2ae7eb7f457fb44c1eb752c61caa6ad"
+DOWNLOAD="https://pypi.python.org/packages/source/F/FlexGet/FlexGet-1.2.102.tar.gz"
+MD5SUM="813f747f52d5c8ddf82556548e82c325"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="BeautifulSoup PyRSS2Gen PyYAML SQLAlchemy feedparser html5lib nose progressbar pynzb"
-MAINTAINER="Lionel Young"
-EMAIL="redtricycle@gmail.com"
+REQUIRES="Paver feedparser SQLAlchemy PyYAML BeautifulSoup4 html5lib PyRSS2Gen pynzb progressbar Flask CherryPy python-requests python-dateutil jsonschema python-tvrage tmdb3"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"