summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Andrew Conway <nalumc[at]gmail[dot]com>2011-08-11 14:10:01 -0300
committer Niels Horn <niels.horn@slackbuilds.org>2011-08-11 14:10:01 -0300
commitc90bb38f284acac2c483d53947b596df57b452bb (patch)
treee82a66f9f515b3e40ba0cd5a4186720957d344a7 /network
parent3f7169ae65a3e66ae445bf568b0116316c345159 (diff)
downloadslackbuilds-c90bb38f284acac2c483d53947b596df57b452bb.tar.gz
slackbuilds-c90bb38f284acac2c483d53947b596df57b452bb.tar.xz
network/identicurse: Added (status.net microblogging client)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/identicurse/README4
-rw-r--r--network/identicurse/identicurse.SlackBuild74
-rw-r--r--network/identicurse/identicurse.info10
-rw-r--r--network/identicurse/slack-desc19
4 files changed, 107 insertions, 0 deletions
diff --git a/network/identicurse/README b/network/identicurse/README
new file mode 100644
index 0000000000..cf6655aed3
--- /dev/null
+++ b/network/identicurse/README
@@ -0,0 +1,4 @@
+IdentiCurse is a simple but powerful Identi.ca client with a curses-based
+UI, currently developed by @reality and @psquid (see http://identi.ca).
+
+This requires pysetuptools.
diff --git a/network/identicurse/identicurse.SlackBuild b/network/identicurse/identicurse.SlackBuild
new file mode 100644
index 0000000000..045f8c49bc
--- /dev/null
+++ b/network/identicurse/identicurse.SlackBuild
@@ -0,0 +1,74 @@
+#!/bin/sh
+
+# Slackware build script for identicurse
+
+# Written by Andrew Conway <nalumc[at]gmail[dot]com>
+# Based on dateutil slackbuild by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+PRGNAM=identicurse
+VERSION=0.7.3
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+#VERSIONMIN=3a
+SRCVERSION=$(echo $VERSION | cut -f1-2 -d.)
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ LIBDIRSUFFIX="64"
+else
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$SRCVERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$SRCVERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE CHANGELOG INSTALL README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+#move config.json and README to where identicurse expects them and remove /usr/identicurse dir
+mv $PKG/usr/identicurse/config.json $PKG/usr/lib${LIBDIRSUFFIX}/python2.6/site-packages/identicurse/
+mv $PKG/usr/identicurse/README $PKG/usr/lib${LIBDIRSUFFIX}/python2.6/site-packages/identicurse/
+rmdir $PKG/usr/identicurse
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/identicurse/identicurse.info b/network/identicurse/identicurse.info
new file mode 100644
index 0000000000..ad5c8c94aa
--- /dev/null
+++ b/network/identicurse/identicurse.info
@@ -0,0 +1,10 @@
+PRGNAM="identicurse"
+VERSION="0.7.3"
+HOMEPAGE="http://identicurse.net"
+DOWNLOAD="http://identicurse.net/release/0.7/identicurse-0.7.3.tar.bz2"
+MD5SUM="3a9e54ddc32c4e93195d84a7b4041186"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Andrew Conway"
+EMAIL="nalumc[at]gmail[dot]com"
+APPROVED="Niels Horn"
diff --git a/network/identicurse/slack-desc b/network/identicurse/slack-desc
new file mode 100644
index 0000000000..932a5ba89a
--- /dev/null
+++ b/network/identicurse/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+identicurse: identicurse (status.net microblogging client)
+identicurse:
+identicurse: IdentiCurse is a simple but powerful Identi.ca client with a curses-
+identicurse: based UI, currently developed by @reality and @psquid
+identicurse: (see http://identi.ca).
+identicurse:
+identicurse: Homepage: http://identicurse.net
+identicurse:
+identicurse:
+identicurse:
+identicurse: