summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2017-03-09 17:15:32 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-03-18 06:58:55 +0700
commita53689f7d70574a68f035c8fc942ec8482ecd2c5 (patch)
treed8733bccba8844938862026c61d86875b555fe72 /network
parentf5a69cb50a502c210e08652b57622953ae1ce397 (diff)
downloadslackbuilds-a53689f7d70574a68f035c8fc942ec8482ecd2c5.tar.gz
slackbuilds-a53689f7d70574a68f035c8fc942ec8482ecd2c5.tar.xz
network/dwb: New maintainer, updated for version 20161213_4f6c404.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'network')
-rw-r--r--network/dwb/dwb.SlackBuild44
-rw-r--r--network/dwb/dwb.info12
2 files changed, 27 insertions, 29 deletions
diff --git a/network/dwb/dwb.SlackBuild b/network/dwb/dwb.SlackBuild
index 20cda9c5a3..35b930c488 100644
--- a/network/dwb/dwb.SlackBuild
+++ b/network/dwb/dwb.SlackBuild
@@ -3,8 +3,11 @@
# Slackware build script for dwb
# Originally by Marcin Herda <mherda@slackword.net>
+# Formerly maintained by:
# Ryan P.C. McQuen | Everett, WA | ryanpcmcquen@member.fsf.org
+# Now maintained by B. Watson (yalhcru@gmail.com)
+
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
@@ -23,16 +26,23 @@
# with this program (most likely, a file named COPYING). If not, see
# <https://www.gnu.org/licenses/>.
+# 20170309 bkw:
+# - take over maintenance
+# - update for v20161213_4f6c404 (latest commit)
+# - i486 => i586
+# - minor tweaks
+# - TODO: look into ad-blocking (patch whatever's needed)
+
PRGNAM=dwb
-VERSION=${VERSION:-20150726_dda5aa7}
-SRCVERSION=${SRCVERSION:-dda5aa74a63a}
+VERSION=${VERSION:-20161213_4f6c404}
+SRCVER=${SRCVER:-4f6c404f2761}
SRCNAM=${SRCNAM:-portix-dwb}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -43,8 +53,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -62,9 +72,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $SRCNAM-$SRCVERSION
-tar xvf $CWD/$SRCVERSION.tar.bz2 || tar xvf $CWD/$SRCNAM-$SRCVERSION.tar.bz2
-cd $SRCNAM-$SRCVERSION
+rm -rf $SRCNAM-$SRCVER
+tar xvf $CWD/$SRCVER.tar.bz2 || tar xvf $CWD/$SRCNAM-$SRCVER.tar.bz2
+cd $SRCNAM-$SRCVER
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -72,29 +82,17 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Fixup for glibc-2.23 and/or gcc-5.3.0
-# https://bitbucket.org/portix/dwb/pull-requests/26/fix-building-on-newer-gcc-where-isnan-type/diff
-sed -i \
- -e 's/int id = JSValueToNumber/double id = JSValueToNumber/' \
- src/scripts/cl_gobject.c
-
# fix the location of man pages
sed -i '/^MANDIR/s/DATAROOTDIR/PREFIX/' config.mk
CFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+strip $PKG/usr/bin/*
+gzip $PKG/usr/man/man?/*.?
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- README AUTHORS \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README AUTHORS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/network/dwb/dwb.info b/network/dwb/dwb.info
index 4cd7281483..f2ca1c84e3 100644
--- a/network/dwb/dwb.info
+++ b/network/dwb/dwb.info
@@ -1,10 +1,10 @@
PRGNAM="dwb"
-VERSION="20150726_dda5aa7"
-HOMEPAGE="http://portix.bitbucket.org/dwb/"
-DOWNLOAD="https://bitbucket.org/portix/dwb/get/dda5aa74a63a.tar.bz2"
-MD5SUM="dd3ca8253e017b6d755c6dfaa9543ef6"
+VERSION="20161213_4f6c404"
+HOMEPAGE="https://portix.bitbucket.io/dwb/"
+DOWNLOAD="https://bitbucket.org/portix/dwb/get/4f6c404f2761.tar.bz2"
+MD5SUM="08df9c127009284bc201e2301e41f3e1"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="webkitgtk"
-MAINTAINER="Ryan P.C. McQuen"
-EMAIL="ryanpcmcquen@member.fsf.org"
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"