summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Mario Preksavec <mario at slackware dot hr>2017-08-09 00:46:34 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-08-12 06:57:37 +0700
commite3e950bdb4636b9060c3a22913d97f6807a91540 (patch)
tree2f63867a70189dba0a0a4c32483f89c9d2c55b47 /network
parentdd51444fe8f2b813d7bd6435b59185e43363205b (diff)
downloadslackbuilds-e3e950bdb4636b9060c3a22913d97f6807a91540.tar.gz
slackbuilds-e3e950bdb4636b9060c3a22913d97f6807a91540.tar.xz
network/libnatpmp: Added (implementation of the NAT-PMP protocol).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/libnatpmp/Makefile.diff11
-rw-r--r--network/libnatpmp/README5
-rw-r--r--network/libnatpmp/libnatpmp.SlackBuild93
-rw-r--r--network/libnatpmp/libnatpmp.info10
-rw-r--r--network/libnatpmp/slack-desc19
5 files changed, 138 insertions, 0 deletions
diff --git a/network/libnatpmp/Makefile.diff b/network/libnatpmp/Makefile.diff
new file mode 100644
index 0000000000..01f8ea23d4
--- /dev/null
+++ b/network/libnatpmp/Makefile.diff
@@ -0,0 +1,11 @@
+--- libnatpmp-20150609/Makefile.orig 2013-12-09 21:52:28.000000000 +0100
++++ libnatpmp-20150609/Makefile 2017-08-01 15:10:21.711231906 +0200
+@@ -62,7 +62,7 @@
+
+ INSTALLPREFIX ?= $(PREFIX)/usr
+ INSTALLDIRINC = $(INSTALLPREFIX)/include
+-INSTALLDIRLIB = $(INSTALLPREFIX)/lib
++INSTALLDIRLIB = $(INSTALLPREFIX)/lib@@LIBDIRSUFFIX@@
+ INSTALLDIRBIN = $(INSTALLPREFIX)/bin
+
+ JAVA ?= java
diff --git a/network/libnatpmp/README b/network/libnatpmp/README
new file mode 100644
index 0000000000..ff8458a220
--- /dev/null
+++ b/network/libnatpmp/README
@@ -0,0 +1,5 @@
+NAT-PMP is the direct concurrent to the UPnP IGD specification. It is providing
+a way to do NAT traversal. libnatpmp is an attempt to make a portable and
+fully compliant implementation of the protocol for the client side. It is
+based on non blocking sockets and all calls of the API are asynchronous. It
+is therefore very easy to integrate the NAT-PMP code to any event driven code.
diff --git a/network/libnatpmp/libnatpmp.SlackBuild b/network/libnatpmp/libnatpmp.SlackBuild
new file mode 100644
index 0000000000..8fcf8435d9
--- /dev/null
+++ b/network/libnatpmp/libnatpmp.SlackBuild
@@ -0,0 +1,93 @@
+#!/bin/sh
+
+# Slackware build script for libnatpmp
+
+# Copyright 2017 Mario Preksavec, Zagreb, Croatia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=libnatpmp
+VERSION=${VERSION:-20150609}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -e "s|@@LIBDIRSUFFIX@@|$LIBDIRSUFFIX|" $CWD/Makefile.diff | patch -p1
+
+make
+make install PREFIX=$PKG
+
+install -Dm644 natpmpc.1 $PKG/usr/man/man1/natpmpc.1
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a Changelog.txt LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/libnatpmp/libnatpmp.info b/network/libnatpmp/libnatpmp.info
new file mode 100644
index 0000000000..6ee01fa094
--- /dev/null
+++ b/network/libnatpmp/libnatpmp.info
@@ -0,0 +1,10 @@
+PRGNAM="libnatpmp"
+VERSION="20150609"
+HOMEPAGE="http://miniupnp.free.fr/libnatpmp.html"
+DOWNLOAD="http://miniupnp.free.fr/files/libnatpmp-20150609.tar.gz"
+MD5SUM="7bd1af6710271e1743df5422be350bd8"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Mario Preksavec"
+EMAIL="mario at slackware dot hr"
diff --git a/network/libnatpmp/slack-desc b/network/libnatpmp/slack-desc
new file mode 100644
index 0000000000..9426a95bf7
--- /dev/null
+++ b/network/libnatpmp/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+libnatpmp: libnatpmp (implementation of the NAT-PMP protocol)
+libnatpmp:
+libnatpmp: NAT-PMP is the direct concurrent to the UPnP IGD specification. It
+libnatpmp: is providing a way to do NAT traversal. libnatpmp is an attempt to
+libnatpmp: make a portable and fully compliant implementation of the protocol
+libnatpmp: for the client side. It is based on non blocking sockets and all
+libnatpmp: calls of the API are asynchronous. It is therefore very easy to
+libnatpmp: integrate the NAT-PMP code to any event driven code.
+libnatpmp:
+libnatpmp: Homepage: http://miniupnp.free.fr/libnatpmp.html
+libnatpmp: