summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-11-07 06:18:15 +0200
committer David Spencer <idlemoor@slackbuilds.org>2016-11-11 20:36:30 +0000
commitbe2a44a4bee30c369f60d01d23200af434de1d79 (patch)
tree0170c8bb4946cadda603f6b1f124674e658d5cb2 /network
parent2eb7b740683405323a0a329e8520c52b9bb90764 (diff)
downloadslackbuilds-be2a44a4bee30c369f60d01d23200af434de1d79.tar.gz
slackbuilds-be2a44a4bee30c369f60d01d23200af434de1d79.tar.xz
network/pubnub-curses: Switch to i586.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'network')
-rw-r--r--network/pubnub-curses/pubnub-curses.SlackBuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/network/pubnub-curses/pubnub-curses.SlackBuild b/network/pubnub-curses/pubnub-curses.SlackBuild
index 0695aa9b5e..fe6b307c0a 100644
--- a/network/pubnub-curses/pubnub-curses.SlackBuild
+++ b/network/pubnub-curses/pubnub-curses.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pubnub-curses
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -30,7 +30,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -41,8 +41,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -68,7 +68,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG