summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@slackbuilds.org>2010-05-13 00:08:53 +0200
committer Heinz Wiesinger <pprkut@slackbuilds.org>2010-05-13 00:08:53 +0200
commitd622efe86f84080c8cf4783a1d35e6f994adf110 (patch)
tree36c25d04957d2f5e651edac57eff74682385a403 /network
parent85bbce4c0615ff2e65950011dbd9e8d6ad0982cd (diff)
downloadslackbuilds-d622efe86f84080c8cf4783a1d35e6f994adf110.tar.gz
slackbuilds-d622efe86f84080c8cf4783a1d35e6f994adf110.tar.xz
network/nicotine-plus: Removed from 13.0 repository
Diffstat (limited to 'network')
-rw-r--r--network/nicotine-plus/README11
-rw-r--r--network/nicotine-plus/doinst.sh4
-rw-r--r--network/nicotine-plus/nicotine-plus.SlackBuild80
-rw-r--r--network/nicotine-plus/nicotine-plus.info8
-rw-r--r--network/nicotine-plus/slack-desc19
5 files changed, 0 insertions, 122 deletions
diff --git a/network/nicotine-plus/README b/network/nicotine-plus/README
deleted file mode 100644
index 1ad0d4c7fc..0000000000
--- a/network/nicotine-plus/README
+++ /dev/null
@@ -1,11 +0,0 @@
-Nicotine+ is a client for the SoulSeek filesharing network. It was "forked"
-from Nicotine, Hyriand's Soulseek client, which in turn was forked from the
-PySoulSeek project by Alexander Kanavin.
-
-Optional (available at SlackBuilds.org):
-* GeoIP python bindings (Country lookup)
-
-Optional (not available at SlackBuilds.org, but submissions are welcome):
-* PyOGG and PyVorbis (OGG metadata support for your shares)
- http://ekyo.nerim.net/software/pyogg/
-* Psyco (speeds up Python code) http://psyco.sourceforge.net/
diff --git a/network/nicotine-plus/doinst.sh b/network/nicotine-plus/doinst.sh
deleted file mode 100644
index 392c12adb9..0000000000
--- a/network/nicotine-plus/doinst.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications
-fi
-
diff --git a/network/nicotine-plus/nicotine-plus.SlackBuild b/network/nicotine-plus/nicotine-plus.SlackBuild
deleted file mode 100644
index 582311ddd9..0000000000
--- a/network/nicotine-plus/nicotine-plus.SlackBuild
+++ /dev/null
@@ -1,80 +0,0 @@
-#!/bin/sh
-# Slackware build script for nicotine+
-# Written by Iskar Enev <iskar.enev[@]gmail.com>
-# Modified by the SlackBuilds.org project
-
-PRGNAM=nicotine+
-NAME=nicotine
-VERSION=1.2.10
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-# Change to NO if you don't want the trayicon shared object to be built
-# - or call the build script with TRAYICON=NO ./nicotine-plus.SlackBuild
-TRAYICON=${TRAYICON:-YES}
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP || exit 1
-rm -rf $PRGNAM-$VERSION
-tar -xjvf $CWD/$PRGNAM-$VERSION.tar.bz2 || exit 1
-cd $PRGNAM-$VERSION || exit 1
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Tray icon has to be compiled first
-if [ "$TRAYICON" = "YES" ]; then
- ( cd trayicon
- ./autogen.py || exit 1
- make || exit 1
- make install DESTDIR=$PKG || exit 1
- ) || exit 1
-fi
-
-python setup.py bdist || exit 1
-
-tar xzvf dist/$NAME-$VERSION.linux-i686.tar.gz -C $PKG || exit 1
-
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-)
-
-mv $PKG/usr/share/man $PKG/usr
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
-)
-
-# Let's use the larger icon to ensure proper scaling
-sed -i 's%Icon=nicotine-plus-32px.png%Icon=nicotine-plus-96px.png%' \
- $PKG/usr/share/applications/nicotine.desktop || exit 1
-
-# Let's put these icons and such in a subdirectory of their own instead of
-# spamming /usr/share/pixmaps with all sorts of stuff
-rm $PKG/usr/share/pixmaps/*
-mkdir -p $PKG/usr/share/pixmaps/nicotine
-cp -a files/*.png img/*.png img/*.ico img/*.xcf img/README \
- $PKG/usr/share/pixmaps/nicotine
-
-mkdir -p $PKG/usr/doc
-cp -a COPYING MANIFEST PKG-INFO $PKG/usr/share/$NAME/documentation
-mv $PKG/usr/share/$NAME/documentation $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/nicotine-plus.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/nicotine-plus.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/network/nicotine-plus/nicotine-plus.info b/network/nicotine-plus/nicotine-plus.info
deleted file mode 100644
index 2d425b1591..0000000000
--- a/network/nicotine-plus/nicotine-plus.info
+++ /dev/null
@@ -1,8 +0,0 @@
-PRGNAM="nicotine-plus"
-VERSION="1.2.10"
-HOMEPAGE="http://nicotine-plus.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/nicotine-plus/nicotine+-1.2.10.tar.bz2"
-MD5SUM="80f17b222b9bd33acc1ac64f77bef640"
-MAINTAINER="Iskar Enev"
-EMAIL="iskar.enev@gmail.com"
-APPROVED="dsomero"
diff --git a/network/nicotine-plus/slack-desc b/network/nicotine-plus/slack-desc
deleted file mode 100644
index 3a797f5f2b..0000000000
--- a/network/nicotine-plus/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|' on
-# the right side marks the last column you can put a character in. You must make
-# exactly 11 lines for the formatting to be correct. It's also customary to
-# leave one space after the ':'.
-
- |-----handy-ruler---------------------------------------------------------|
-nicotine+: Nicotine+ (SoulSeek client written in Python)
-nicotine+:
-nicotine+: Nicotine+ is a SoulSeek client written in Python, based on the
-nicotine+: PySoulSeek project by Alexander Kanavin. It features, among other
-nicotine+: things, a completely rewritten graphical user interface which
-nicotine+: uses the PyGTK-2 toolkit and a less strict user request policy.
-nicotine+: Nicotine-Plus is a fork of Hyriand's original Nicotine Soulseek client.
-nicotine+:
-nicotine+: NOTE: these code changes are NOT sanctioned by Hyriand, so if this
-nicotine+: messes you up, don't bug him.
-nicotine+: