summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-04-20 23:11:20 +0000
committer Robby Workman <rworkman@slackbuilds.org>2021-04-21 21:19:51 -0500
commitf03a9d4f3e2f4128ce802dcce0099e45a372c20a (patch)
tree3851af29cae4a9117ff114b06a0dcd6d0ab3d654 /network
parent2dbadf5943b8f7f0f5ee0e7dc8392ec042a86a7a (diff)
downloadslackbuilds-f03a9d4f3e2f4128ce802dcce0099e45a372c20a.tar.gz
slackbuilds-f03a9d4f3e2f4128ce802dcce0099e45a372c20a.tar.xz
network/smstools3: Add L(D)FLAGS, DESTDIR patch.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/smstools3/destdir.patch (renamed from network/smstools3/fixups2.diff)59
-rw-r--r--network/smstools3/doinst.sh3
-rw-r--r--network/smstools3/smstools3.SlackBuild8
3 files changed, 18 insertions, 52 deletions
diff --git a/network/smstools3/fixups2.diff b/network/smstools3/destdir.patch
index d99ee9deee..0cdf272b1f 100644
--- a/network/smstools3/fixups2.diff
+++ b/network/smstools3/destdir.patch
@@ -1,6 +1,6 @@
diff -Naur a/Makefile b/Makefile
--- a/Makefile 2007-04-22 11:42:22.000000000 +0000
-+++ b/Makefile 2017-08-10 22:14:15.011099622 +0000
++++ b/Makefile 2021-04-20 22:48:57.084918445 +0000
@@ -2,7 +2,7 @@
# If you change destination of executables, remember to change
@@ -12,34 +12,8 @@ diff -Naur a/Makefile b/Makefile
diff -Naur a/install.sh b/install.sh
--- a/install.sh 2007-04-22 11:43:17.000000000 +0000
-+++ b/install.sh 2017-08-10 22:18:11.561100240 +0000
-@@ -3,9 +3,11 @@
-
- BINDIR=$1
- if [ -z "$BINDIR" ]; then
-- BINDIR=/usr/local/bin
-+ BINDIR=/usr/bin
- fi
-
-+SBINDIR=/usr/sbin
-+
- makepath()
- {
- p="$1"
-@@ -33,10 +35,10 @@
- {
- if [ -f $2 ]; then
- echo " Skipped $2, file already exists"
-- else
-+ else
- echo " $2"
- cp $1 $2
-- fi
-+ fi
- }
-
- forcecopy()
-@@ -64,58 +66,39 @@
++++ b/install.sh 2021-04-20 23:01:28.251300300 +0000
+@@ -64,7 +64,7 @@
echo " Skipped $1, directory already exists"
else
echo " Creating directory $1"
@@ -48,25 +22,16 @@ diff -Naur a/install.sh b/install.sh
fi
}
- echo ""
--if [ ! -f src/smsd ] && [ ! -f src/smsd.exe ]; then
-+if [ ! -f src/smsd ] && [ ! -f src/smsd.exe ]; then
- echo 'Please run "make -s install" instead.'
- exit 1
- fi
-
- echo "Installing binary program files"
--makepath $BINDIR
--if [ -f src/smsd.exe ]; then
-- forcecopy src/smsd.exe $BINDIR/smsd.exe
--else
+@@ -79,43 +79,28 @@
+ if [ -f src/smsd.exe ]; then
+ forcecopy src/smsd.exe $BINDIR/smsd.exe
+ else
- forcecopy src/smsd $BINDIR/smsd
--fi
++ makedir $DESTDIR/$BINDIR
++ forcecopy src/smsd $DESTDIR/$BINDIR/smsd
+ fi
-delete $BINDIR/getsms
-delete $BINDIR/putsms
-+mkdir -p $DESTDIR/$BINDIR
-+mkdir -p $DESTDIR/$SBINDIR
-+forcecopy src/smsd $DESTDIR/$SBINDIR/smsd
echo "Installing some scripts"
-copy scripts/sendsms $BINDIR/sendsms
@@ -117,13 +82,13 @@ diff -Naur a/install.sh b/install.sh
-fi
diff -Naur a/scripts/sms3 b/scripts/sms3
--- a/scripts/sms3 2010-05-04 09:21:44.000000000 +0000
-+++ b/scripts/sms3 2017-08-10 21:58:41.968097184 +0000
++++ b/scripts/sms3 2021-04-20 22:48:57.084918445 +0000
@@ -24,9 +24,9 @@
# Logfile can also be defined in here:
LOGFILE="/var/log/smsd.log"
-DAEMON=/usr/local/bin/smsd
-+DAEMON=/usr/sbin/smsd
++DAEMON=/usr/bin/smsd
# A program which turns power off for couple of seconds:
-RESETMODEMS=/usr/local/bin/smsd_resetmodems
+RESETMODEMS=/usr/bin/smsd_resetmodems
diff --git a/network/smstools3/doinst.sh b/network/smstools3/doinst.sh
index 859238d1ce..003aac27e2 100644
--- a/network/smstools3/doinst.sh
+++ b/network/smstools3/doinst.sh
@@ -23,6 +23,3 @@ preserve_perms() {
}
preserve_perms etc/rc.d/rc.sms3.new
-#chgrp -R dialout /var/spool/sms
-#chmod -R g+rw /var/spool/sms
-
diff --git a/network/smstools3/smstools3.SlackBuild b/network/smstools3/smstools3.SlackBuild
index 2564390f94..6743447103 100644
--- a/network/smstools3/smstools3.SlackBuild
+++ b/network/smstools3/smstools3.SlackBuild
@@ -68,9 +68,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-patch --verbose -p1 < $CWD/fixups2.diff
+patch --verbose -p1 <$CWD/destdir.patch
-DESTDIR=$PKG make install
+LFLAGS="-z muldefs" \
+CFLAGS="$SLKCFLAGS" \
+DESTDIR=$PKG \
+BINDIR=$PKG/usr/bin \
+ make install
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true