summaryrefslogtreecommitdiffstats
path: root/office/calibre/patches
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2010-06-15 04:26:34 -0500
committer Robby Workman <rworkman@slackbuilds.org>2010-06-15 04:26:34 -0500
commit4bdda09a8054e97a1535288cf41919f3b2575207 (patch)
tree133349a3c7a0a7d5a8ed66b334dc25d4a1f2b4d6 /office/calibre/patches
parent45e8294d0e6bf58b1777f07e427973bdc29ac412 (diff)
downloadslackbuilds-4bdda09a8054e97a1535288cf41919f3b2575207.tar.gz
slackbuilds-4bdda09a8054e97a1535288cf41919f3b2575207.tar.xz
office/calibre: Updated for version 0.7.2.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'office/calibre/patches')
-rw-r--r--office/calibre/patches/calibre-module-fix.patch14
-rw-r--r--office/calibre/patches/fix-manpages.diff21
-rw-r--r--office/calibre/patches/fix-manpages.patch21
-rw-r--r--office/calibre/patches/post-install-removal.patch44
-rw-r--r--office/calibre/patches/remove-desktop-integration.patch13
-rw-r--r--office/calibre/patches/tagging-form.patch12
6 files changed, 48 insertions, 77 deletions
diff --git a/office/calibre/patches/calibre-module-fix.patch b/office/calibre/patches/calibre-module-fix.patch
new file mode 100644
index 0000000000..d2288d288e
--- /dev/null
+++ b/office/calibre/patches/calibre-module-fix.patch
@@ -0,0 +1,14 @@
+diff -Naur calibre.orig/setup/install.py calibre/setup/install.py
+--- calibre.orig/setup/install.py 2010-03-05 21:13:33.000000000 +0000
++++ calibre/setup/install.py 2010-03-07 00:07:41.000000000 +0000
+@@ -142,7 +142,9 @@
+
+ def install_env_module(self):
+ import distutils.sysconfig as s
+- libdir = s.get_python_lib(prefix=self.opts.staging_root)
++ libdir = s.get_python_lib(prefix=(self.opts.staging_root + sys.prefix))
++ if not os.path.exists(libdir):
++ os.makedirs(libdir)
+ if os.path.exists(libdir):
+ path = os.path.join(libdir, 'init_calibre.py')
+ self.info('Installing calibre environment module: '+path)
diff --git a/office/calibre/patches/fix-manpages.diff b/office/calibre/patches/fix-manpages.diff
deleted file mode 100644
index 50129c6c92..0000000000
--- a/office/calibre/patches/fix-manpages.diff
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Naur calibre-0.5.12.orig/src/calibre/linux.py calibre-0.5.12/src/calibre/linux.py
---- calibre-0.5.12.orig/src/calibre/linux.py 2009-05-15 21:05:52.000000000 +0000
-+++ calibre-0.5.12/src/calibre/linux.py 2009-05-16 04:09:44.000000000 +0000
-@@ -417,7 +417,7 @@
- def install_man_pages(fatal_errors, use_destdir=False):
- from calibre.utils.help2man import create_man_page
- prefix = os.environ.get('DESTDIR', '/') if use_destdir else '/'
-- manpath = os.path.join(prefix, 'usr/share/man/man1')
-+ manpath = os.path.join(prefix, 'usr/man/man1')
- if not os.path.exists(manpath):
- os.makedirs(manpath)
- print 'Installing MAN pages...'
-@@ -431,7 +431,7 @@
- continue
- parser = parser()
- raw = create_man_page(prog, parser)
-- manfile = os.path.join(manpath, prog+'.1'+__appname__+'.bz2')
-+ manfile = os.path.join(manpath, prog+'.1'+'.bz2')
- print '\tInstalling MAN page for', prog
- open(manfile, 'wb').write(raw)
- manifest.append(manfile)
diff --git a/office/calibre/patches/fix-manpages.patch b/office/calibre/patches/fix-manpages.patch
new file mode 100644
index 0000000000..b9ea10be00
--- /dev/null
+++ b/office/calibre/patches/fix-manpages.patch
@@ -0,0 +1,21 @@
+diff -Naur calibre.orig/src/calibre/linux.py calibre/src/calibre/linux.py
+--- calibre.orig/src/calibre/linux.py 2010-03-05 21:13:33.000000000 +0000
++++ calibre/src/calibre/linux.py 2010-03-07 00:02:26.000000000 +0000
+@@ -325,7 +325,7 @@
+ if isfreebsd:
+ manpath = os.path.join(self.opts.staging_root, 'man/man1')
+ else:
+- manpath = os.path.join(self.opts.staging_sharedir, 'man/man1')
++ manpath = os.path.join(self.opts.staging_root, 'usr/man/man1')
+ if not os.path.exists(manpath):
+ os.makedirs(manpath)
+ self.info('Installing MAN pages...')
+@@ -341,7 +341,7 @@
+ if isfreebsd:
+ manfile = os.path.join(manpath, prog+'.1')
+ else:
+- manfile = os.path.join(manpath, prog+'.1'+__appname__+'.bz2')
++ manfile = os.path.join(manpath, prog+'.1'+'.bz2')
+ self.info('\tInstalling MAN page for', prog)
+ open(manfile, 'wb').write(raw)
+ self.manifest.append(manfile)
diff --git a/office/calibre/patches/post-install-removal.patch b/office/calibre/patches/post-install-removal.patch
deleted file mode 100644
index 6a47e957a0..0000000000
--- a/office/calibre/patches/post-install-removal.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -Naur calibre-0.5.14.orig/setup.py calibre-0.5.14/setup.py
---- calibre-0.5.14.orig/setup.py 2009-05-29 17:25:45.000000000 +0000
-+++ calibre-0.5.14/setup.py 2009-06-27 03:26:58.000000000 +0000
-@@ -55,8 +55,6 @@
- upload_to_pypi, stage3, stage2, stage1, upload, \
- upload_rss
-
-- entry_points['console_scripts'].append(
-- 'calibre_postinstall = calibre.linux:post_install')
- optional = []
-
-
-@@ -198,6 +196,4 @@
-
- if 'develop' in ' '.join(sys.argv) and islinux:
- subprocess.check_call('calibre_postinstall --do-not-reload-udev-hal', shell=True)
-- if 'install' in sys.argv and islinux:
-- subprocess.check_call('calibre_postinstall', shell=True)
-
-diff -Naur calibre-0.5.14.orig/src/calibre/linux.py calibre-0.5.14/src/calibre/linux.py
---- calibre-0.5.14.orig/src/calibre/linux.py 2009-05-29 17:25:45.000000000 +0000
-+++ calibre-0.5.14/src/calibre/linux.py 2009-06-27 03:26:23.000000000 +0000
-@@ -444,7 +444,6 @@
- global use_destdir
- use_destdir = opts.destdir
- manifest = []
-- setup_desktop_integration(opts.fatal_errors)
- if opts.no_root or os.geteuid() == 0:
- manifest += install_man_pages(opts.fatal_errors, use_destdir)
- manifest += setup_udev_rules(opts.group_file, not opts.dont_reload, opts.fatal_errors)
-@@ -462,13 +461,6 @@
- if opts.save_manifest_to:
- open(opts.save_manifest_to, 'wb').write('\n'.join(manifest)+'\n')
-
-- from calibre.utils.config import config_dir
-- if os.path.exists(config_dir):
-- os.chdir(config_dir)
-- for f in os.listdir('.'):
-- if os.stat(f).st_uid == 0:
-- os.unlink(f)
--
- def binary_install():
- manifest = os.path.join(getattr(sys, 'frozen_path'), 'manifest')
- exes = [x.strip() for x in open(manifest).readlines()]
diff --git a/office/calibre/patches/remove-desktop-integration.patch b/office/calibre/patches/remove-desktop-integration.patch
new file mode 100644
index 0000000000..c1fe516f36
--- /dev/null
+++ b/office/calibre/patches/remove-desktop-integration.patch
@@ -0,0 +1,13 @@
+diff -Naur calibre.orig/src/calibre/linux.py calibre/src/calibre/linux.py
+--- calibre.orig/src/calibre/linux.py 2010-06-11 22:28:24.000000000 +0000
++++ calibre/src/calibre/linux.py 2010-06-13 23:07:49.000000000 +0000
+@@ -133,9 +133,6 @@
+ if islinux:
+ self.setup_completion()
+ self.install_man_pages()
+- if islinux:
+- self.setup_desktop_integration()
+- self.create_uninstaller()
+
+ from calibre.utils.config import config_dir
+ if os.path.exists(config_dir):
diff --git a/office/calibre/patches/tagging-form.patch b/office/calibre/patches/tagging-form.patch
deleted file mode 100644
index d1d76e2ff0..0000000000
--- a/office/calibre/patches/tagging-form.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur calibre-0.5.14.orig/src/tagging/forms.py calibre-0.5.14/src/tagging/forms.py
---- calibre-0.5.14.orig/src/tagging/forms.py 2009-05-29 17:25:45.000000000 +0000
-+++ calibre-0.5.14/src/tagging/forms.py 2009-07-01 22:58:17.000000000 +0000
-@@ -16,7 +16,7 @@
- value = self.cleaned_data['name']
- tag_names = parse_tag_input(value)
- if len(tag_names) > 1:
-- raise ValidationError(_('Multiple tags were given.'))
-+ raise forms.ValidationError(_('Multiple tags were given.'))
- elif len(tag_names[0]) > settings.MAX_TAG_LENGTH:
- raise forms.ValidationError(
- _('A tag may be no more than %s characters long.') %