summaryrefslogtreecommitdiffstats
path: root/office/elyxer
diff options
context:
space:
mode:
author Bending Unit 647 <bender647[at]gmail[dot]com>2010-10-24 22:24:42 -0400
committer Erik Hanson <erik@slackbuilds.org>2010-10-25 07:55:11 -0500
commita480d7c0685ef630804dddd61dde88c11bdeb447 (patch)
tree6ca030cf178c703d6dbcd53d5a8264d4a9aef855 /office/elyxer
parent8dabd065295cf4a710be07ae56e99336fe9a57f8 (diff)
downloadslackbuilds-a480d7c0685ef630804dddd61dde88c11bdeb447.tar.gz
slackbuilds-a480d7c0685ef630804dddd61dde88c11bdeb447.tar.xz
office/elyxer: Added (Lyx to HTML converter)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'office/elyxer')
-rw-r--r--office/elyxer/README4
-rw-r--r--office/elyxer/elyxer.SlackBuild72
-rw-r--r--office/elyxer/elyxer.info10
-rw-r--r--office/elyxer/elyxer.sh2
-rw-r--r--office/elyxer/slack-desc19
5 files changed, 107 insertions, 0 deletions
diff --git a/office/elyxer/README b/office/elyxer/README
new file mode 100644
index 0000000000..39d3b9804f
--- /dev/null
+++ b/office/elyxer/README
@@ -0,0 +1,4 @@
+eLyXer (pronounced elixir) is a LyX to HTML converter. Using eLyXer,
+you can build a web representation of your documentation written with LyX.
+
+eLyXer is a python module, but a wrapper script is provided.
diff --git a/office/elyxer/elyxer.SlackBuild b/office/elyxer/elyxer.SlackBuild
new file mode 100644
index 0000000000..2b792092f8
--- /dev/null
+++ b/office/elyxer/elyxer.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# Slackware build script for eLyXer
+
+# Written by Bending Unit 647 <bender647[at]gmail[dot]com>
+
+PRGNAM=elyxer
+VERSION=${VERSION:-1.0.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README gpl-3.0-standalone.html docs $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/usr/bin
+cat $CWD/elyxer.sh > $PKG/usr/bin/elyxer && chmod 0755 $PKG/usr/bin/elyxer
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/office/elyxer/elyxer.info b/office/elyxer/elyxer.info
new file mode 100644
index 0000000000..7eeda9d090
--- /dev/null
+++ b/office/elyxer/elyxer.info
@@ -0,0 +1,10 @@
+PRGNAM="elyxer"
+VERSION="1.0.2"
+HOMEPAGE="http://elyxer.nongnu.org/"
+DOWNLOAD="http://download.savannah.gnu.org/releases/elyxer/elyxer-1.0.3.tar.gz"
+DOWNLOAD_x86_64=""
+MD5SUM="06be63a5efbd1be566f2fb26f02259a8"
+MD5SUM_x86_64=""
+MAINTAINER="Bending Unit 647"
+EMAIL="bender647[at]gmail[dot]com"
+APPROVED="dsomero"
diff --git a/office/elyxer/elyxer.sh b/office/elyxer/elyxer.sh
new file mode 100644
index 0000000000..e55d65534d
--- /dev/null
+++ b/office/elyxer/elyxer.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+python -m elyxer $@
diff --git a/office/elyxer/slack-desc b/office/elyxer/slack-desc
new file mode 100644
index 0000000000..9da731abab
--- /dev/null
+++ b/office/elyxer/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+elyxer: elyxer (Lyx to HTML converter)
+elyxer:
+elyxer: eLyXer is a LyX to HTML converter, implemented as a python module.
+elyxer: While there are a ton of such projects all over the web, eLyXer has a
+elyxer: clear focus on flexibility and elegant output. Installing eLyXer adds
+elyxer: HTML export capability to LyX.
+elyxer:
+elyxer: Project website: http://elyxer.nongnu.org/
+elyxer:
+elyxer: User guide: http://elyxer.nongnu.org/userguide.html
+elyxer: