summaryrefslogtreecommitdiffstats
path: root/office/hyphen-id
diff options
context:
space:
mode:
author Ali Ahmadi <idnux09@gmail.com>2017-05-02 08:41:34 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-05-02 08:41:34 +0700
commit1d9a6c989cab403d8be35a3980606581c80e3803 (patch)
tree0cade73642911dc291db55d02813d81dc97af701 /office/hyphen-id
parenta97be3d2eac084807e7189fde09a5e7172404874 (diff)
downloadslackbuilds-1d9a6c989cab403d8be35a3980606581c80e3803.tar.gz
slackbuilds-1d9a6c989cab403d8be35a3980606581c80e3803.tar.xz
office/hyphen-id: Added (Indonesian hyphenation library function).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'office/hyphen-id')
-rw-r--r--office/hyphen-id/README1
-rw-r--r--office/hyphen-id/hyphen-id.SlackBuild70
-rw-r--r--office/hyphen-id/hyphen-id.info10
-rw-r--r--office/hyphen-id/slack-desc19
4 files changed, 100 insertions, 0 deletions
diff --git a/office/hyphen-id/README b/office/hyphen-id/README
new file mode 100644
index 0000000000..f93257649f
--- /dev/null
+++ b/office/hyphen-id/README
@@ -0,0 +1 @@
+Indonesian hyphenation library function.
diff --git a/office/hyphen-id/hyphen-id.SlackBuild b/office/hyphen-id/hyphen-id.SlackBuild
new file mode 100644
index 0000000000..42a27e31fd
--- /dev/null
+++ b/office/hyphen-id/hyphen-id.SlackBuild
@@ -0,0 +1,70 @@
+#!/bin/sh
+
+# Slackware build script for hyphen-id
+
+# Copyright 2017 Ali Ahmadi <idnux09@gmail.com>
+# # All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Based on the Arch PKGBUILD
+
+PRGNAM=hyphen-id
+VERSION=${VERSION:-2.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+ARCH="noarch"
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+mkdir -p $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+
+bsdtar -xf $CWD/id_id.oxt
+
+# Putting everything in proper place
+install -dm755 $PKG/usr/share/hyphen
+install -m644 hyph_id_ID.dic $PKG/usr/share/hyphen
+
+# myspell symlinks
+install -dm755 $PKG/usr/share/myspell/dicts
+pushd $PKG/usr/share/myspell/dicts
+ for file in $PKG/usr/share/hyphen/*; do
+ ln -sv ../../hyphen/$(basename $file) .
+ done
+popd
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+install -m644 info/long-description.txt $PKG/usr/doc/$PRGNAM-$VERSION/README.txt
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/office/hyphen-id/hyphen-id.info b/office/hyphen-id/hyphen-id.info
new file mode 100644
index 0000000000..b48f951070
--- /dev/null
+++ b/office/hyphen-id/hyphen-id.info
@@ -0,0 +1,10 @@
+PRGNAM="hyphen-id"
+VERSION="2.0"
+HOMEPAGE="https://extensions.libreoffice.org/extension-center/indonesian-dictionary-kamus-indonesia-by-benitius"
+DOWNLOAD="https://extensions.libreoffice.org/extensions/indonesian-dictionary-kamus-indonesia-by-benitius/2.0/@@download/file/id_id.oxt"
+MD5SUM="e5c97ae82ba6c191f432f45ec7a5783e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Ali Ahmadi"
+EMAIL="idnux09@gmail.com"
diff --git a/office/hyphen-id/slack-desc b/office/hyphen-id/slack-desc
new file mode 100644
index 0000000000..fe16ad8986
--- /dev/null
+++ b/office/hyphen-id/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+hyphen-id: hyphen-id (Indonesian hyphenation library function)
+hyphen-id:
+hyphen-id: Indonesian hyphenation library function.
+hyphen-id:
+hyphen-id:
+hyphen-id:
+hyphen-id:
+hyphen-id:
+hyphen-id:
+hyphen-id:
+hyphen-id: