summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@slackbuilds.org>2010-05-11 17:59:16 +0200
committer Heinz Wiesinger <pprkut@slackbuilds.org>2010-05-11 17:59:16 +0200
commit82a5389f660eda5d4d6184995f4833f02a564938 (patch)
treee69465e7c2a4f925430a63c3c2b373c8c623d8e8 /office
parent7fc005419c753bd2023ea3cadec684689b103adb (diff)
downloadslackbuilds-82a5389f660eda5d4d6184995f4833f02a564938.tar.gz
slackbuilds-82a5389f660eda5d4d6184995f4833f02a564938.tar.xz
office/magicpoint: Removed from 12.0 repository
Diffstat (limited to 'office')
-rw-r--r--office/magicpoint/README9
-rw-r--r--office/magicpoint/doinst.sh14
-rw-r--r--office/magicpoint/magicpoint.SlackBuild107
-rw-r--r--office/magicpoint/magicpoint.info8
-rw-r--r--office/magicpoint/slack-desc11
5 files changed, 0 insertions, 149 deletions
diff --git a/office/magicpoint/README b/office/magicpoint/README
deleted file mode 100644
index 0d16b82c5f..0000000000
--- a/office/magicpoint/README
+++ /dev/null
@@ -1,9 +0,0 @@
-Magic Point is an X11-based presentation tool. It allows you to
-quickly create nice-looking presentations. The presentation file
-format is plain text so you can use a text editor of your own
-preference.
-
-NOTE: /usr/X11R6/bin/xmkmf must be in your $PATH when you run this
- script. The easiest way to ensure this is to either use "su -"
- instead of "su" or "source /etc/profile" after "su"
-
diff --git a/office/magicpoint/doinst.sh b/office/magicpoint/doinst.sh
deleted file mode 100644
index eedb5b6f28..0000000000
--- a/office/magicpoint/doinst.sh
+++ /dev/null
@@ -1,14 +0,0 @@
-config() {
- NEW="$1"
- OLD="`dirname $NEW`/`basename $NEW .new`"
- # If there's no config file by that name, mv it over:
- if [ ! -r $OLD ]; then
- mv $NEW $OLD
- elif [ "`cat $OLD | md5sum`" = "`cat $NEW | md5sum`" ]; then # toss the redundant copy
- rm $NEW
- fi
- # Otherwise, we leave the .new copy for the admin to consider...
-}
-
-config etc/mgp/default.mgp.new
-
diff --git a/office/magicpoint/magicpoint.SlackBuild b/office/magicpoint/magicpoint.SlackBuild
deleted file mode 100644
index 192092e208..0000000000
--- a/office/magicpoint/magicpoint.SlackBuild
+++ /dev/null
@@ -1,107 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for grap
-
-# Copyright (c) 2007 Daniel de Kok <moc.mikciat@leinad>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# Modified by the SlackBuilds.org project
-
-set -e
-
-PRGNAM=magicpoint
-VERSION=1.12a
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-CWD=`pwd`
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-fi
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
-
-# Add --enable-freetype-charset16 if you are using a wide character
-# set, e.g. for Japanese users.
-CFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --enable-locale \
- --enable-gif \
- --enable-imlib
-
-xmkmf
-make Makefiles
-make
-make install DESTDIR=$PKG LIBDIR=/etc BINDIR=/usr/bin
-make install.man DESTDIR=$PKG DOCHTMLDIR=/usr/doc/$PRGNAM-$VERSION \
- MANPATH=/usr/man MANSUFFIX=1
-
-install -m 0755 contrib/mgp2html.pl $PKG/usr/bin/mgp2html
-install -m 0755 contrib/mgp2latex.pl $PKG/usr/bin/mgp2latex
-
-# Don't overwrite the configuration file after an upgrade
-mv $PKG/etc/mgp/default.mgp $PKG/etc/mgp/default.mgp.new
-
-find $PKG | xargs file | grep "executable" | grep ELF | cut -f 1 -d : \
- | xargs strip --strip-unneeded 2> /dev/null
-
-# Fix permissions
-chmod 644 $PKG/etc/mgp/*
-chmod 644 $PKG/usr/man/man1/*
-chmod 644 $PKG/usr/doc/$PRGNAM-$VERSION/*
-
-
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in `find . -type l` ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a FAQ README README.fonts README.fonts.jp README.lang README.m17n \
- README.xft RELNOTES SYNTAX TODO.jp USAGE USAGE.jp sample \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-# Remove cruft
-rm -rf $PKG/usr/doc/$PRGNAM-$VERSION/sample/CVS \
- $PKG/usr/doc/$PRGNAM-$VERSION/sample/.cvsignore \
- $PKG/usr/doc/$PRGNAM-$VERSION/sample/Imakefile* \
- $PKG/usr/doc/$PRGNAM-$VERSION/sample/Makefile
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/office/magicpoint/magicpoint.info b/office/magicpoint/magicpoint.info
deleted file mode 100644
index 8fc1af0c42..0000000000
--- a/office/magicpoint/magicpoint.info
+++ /dev/null
@@ -1,8 +0,0 @@
-PRGNAM="magicpoint"
-VERSION="1.12a"
-HOMEPAGE="http://member.wide.ad.jp/wg/mgp/"
-DOWNLOAD="ftp://sh.wide.ad.jp/WIDE/free-ware/mgp/magicpoint-1.12a.tar.gz"
-MD5SUM="fc2cb825098c70e7ad649eb0572e7732"
-MAINTAINER="Daniel de Kok"
-EMAIL="danieldk@pobox.com"
-APPROVED="robw810"
diff --git a/office/magicpoint/slack-desc b/office/magicpoint/slack-desc
deleted file mode 100644
index 1b38c17140..0000000000
--- a/office/magicpoint/slack-desc
+++ /dev/null
@@ -1,11 +0,0 @@
-magicpoint: Magic Point (X11-based presentation tool)
-magicpoint:
-magicpoint: Magic Point is an X11-based presentation tool. It allows you to
-magicpoint: quickly create nice-looking presentations. The presentation file
-magicpoint: format is plain text so you can use a text editor of your own
-magicpoint: preference.
-magicpoint:
-magicpoint: The Magic Point website can be found at:
-magicpoint: http://member.wide.ad.jp/wg/mgp/
-magicpoint:
-magicpoint: