summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2010-09-12 01:14:26 -0500
committer Robby Workman <rworkman@slackbuilds.org>2010-09-12 23:08:53 -0500
commit076d539a097d737ff2641722b3560fbe0e791472 (patch)
tree70be20abd0931d0ff448aaae8b0e29a216da0e0e /office
parente7175392ca69a33ef2dc178c0a0318e39a7783be (diff)
downloadslackbuilds-076d539a097d737ff2641722b3560fbe0e791472.tar.gz
slackbuilds-076d539a097d737ff2641722b3560fbe0e791472.tar.xz
office/calibre: Updated for version 0.7.18.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'office')
-rw-r--r--office/calibre/calibre.SlackBuild17
-rw-r--r--office/calibre/calibre.info6
-rw-r--r--office/calibre/desktop/calibre-gui.pngbin9261 -> 0 bytes
-rw-r--r--office/calibre/desktop/calibre-viewer.pngbin5626 -> 0 bytes
-rw-r--r--office/calibre/doinst.sh5
5 files changed, 19 insertions, 9 deletions
diff --git a/office/calibre/calibre.SlackBuild b/office/calibre/calibre.SlackBuild
index 18a1bcdbcf..1fa053c811 100644
--- a/office/calibre/calibre.SlackBuild
+++ b/office/calibre/calibre.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=calibre
-VERSION=0.7.4
+VERSION=0.7.18
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -35,6 +35,7 @@ if [ -z "$ARCH" ]; then
esac
fi
+
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
@@ -96,7 +97,6 @@ python setup.py install \
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-# Fix the man pages.
find $PKG/usr/man -type f -exec gzip -9 {} \;
# Fix permissions on calibre's bash completion.
@@ -107,14 +107,19 @@ install -D -m 644 $CWD/desktop/$PRGNAM-gui.desktop \
$PKG/usr/share/applications/$PRGNAM-gui.desktop
install -D -m 644 $CWD/desktop/$PRGNAM-lrfviewer.desktop \
$PKG/usr/share/applications/$PRGNAM-lrfviewer.desktop
-install -D -m 644 $CWD/desktop/$PRGNAM-gui.png \
- $PKG/usr/share/pixmaps/$PRGNAM-gui.png
-install -D -m 644 $CWD/desktop/$PRGNAM-viewer.png \
- $PKG/usr/share/pixmaps/$PRGNAM-viewer.png
install -D -m 644 $CWD/desktop/$PRGNAM-ebook-viewer.desktop \
$PKG/usr/share/applications/$PRGNAM-ebook-viewer.desktop
install -D -m 644 $CWD/desktop/$PRGNAM-mimetypes \
$PKG/usr/share/mime/packages/$PRGNAM-mimetypes
+for i in 16 24 32 64 96 128; do
+ convert resources/images/lt.png -resize ${i}x${i}! $PRGNAM-gui-${i}.png
+ convert -background none resources/images/viewer.png \
+ -resize ${i}x${i}! $PRGNAM-viewer-${i}.png
+ install -D -m 0644 $PRGNAM-gui-${i}.png \
+ $PKG/usr/share/icons/hicolor/${i}x${i}/apps/$PRGNAM-gui.png
+ install -D -m 0644 $PRGNAM-viewer-${i}.png \
+ $PKG/usr/share/icons/hicolor/${i}x${i}/apps/$PRGNAM-viewer.png
+done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
diff --git a/office/calibre/calibre.info b/office/calibre/calibre.info
index a4e1b538ca..269fb1f13f 100644
--- a/office/calibre/calibre.info
+++ b/office/calibre/calibre.info
@@ -1,8 +1,8 @@
PRGNAM="calibre"
-VERSION="0.7.4"
+VERSION="0.7.18"
HOMEPAGE="http://calibre-ebook.com/"
-DOWNLOAD="http://downloads.sourceforge.net/calibre/calibre-0.7.4.tar.gz"
-MD5SUM="9c2e3bddec53370c1a9f01d02b0ea244"
+DOWNLOAD="http://downloads.sourceforge.net/calibre/calibre-0.7.18.tar.gz"
+MD5SUM="7de4a0b4afa64bb22c3fbd119f9e20f4"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Larry Hajali"
diff --git a/office/calibre/desktop/calibre-gui.png b/office/calibre/desktop/calibre-gui.png
deleted file mode 100644
index 83eae25b12..0000000000
--- a/office/calibre/desktop/calibre-gui.png
+++ /dev/null
Binary files differ
diff --git a/office/calibre/desktop/calibre-viewer.png b/office/calibre/desktop/calibre-viewer.png
deleted file mode 100644
index e519f06305..0000000000
--- a/office/calibre/desktop/calibre-viewer.png
+++ /dev/null
Binary files differ
diff --git a/office/calibre/doinst.sh b/office/calibre/doinst.sh
index e4e6459838..9424ce43ff 100644
--- a/office/calibre/doinst.sh
+++ b/office/calibre/doinst.sh
@@ -6,3 +6,8 @@ if [ -x /usr/bin/update-mime-database ]; then
/usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
fi
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi