summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author titopoquito <titopoquito@cooltoad.com>2010-05-11 15:03:01 +0200
committer Eric Hameleers <alien@slackbuilds.org>2010-05-11 15:03:01 +0200
commitab1505c2ae587937ca43ee84109e4de512666f5b (patch)
treeed6ce54a66dc8f96da9bb58cb4dbe8e4cecc457e /office
parent4593409b5b1f788f5fdfd6e335181f09cb10b906 (diff)
downloadslackbuilds-ab1505c2ae587937ca43ee84109e4de512666f5b.tar.gz
slackbuilds-ab1505c2ae587937ca43ee84109e4de512666f5b.tar.xz
office/antiword: Initial import
Diffstat (limited to 'office')
-rw-r--r--office/antiword/README9
-rw-r--r--office/antiword/antiword.SlackBuild83
-rw-r--r--office/antiword/antiword.info8
-rw-r--r--office/antiword/patch.Makefile11
-rw-r--r--office/antiword/slack-desc18
5 files changed, 129 insertions, 0 deletions
diff --git a/office/antiword/README b/office/antiword/README
new file mode 100644
index 0000000000..e9c4992040
--- /dev/null
+++ b/office/antiword/README
@@ -0,0 +1,9 @@
+antiword is a free MS Word reader for Linux and RISC OS.
+antiword converts the binary files from Word 2, 6, 7, 97, 2000,
+2002 and 2003 to plain text and to PostScript TM .
+
+The homepage of antiword is found at http://www.winfield.demon.nl/
+
+antiword does not seem to depend on other packages.
+No incompatibilites are known so far. No special configuration
+is needed after installing the package.
diff --git a/office/antiword/antiword.SlackBuild b/office/antiword/antiword.SlackBuild
new file mode 100644
index 0000000000..f947012c1f
--- /dev/null
+++ b/office/antiword/antiword.SlackBuild
@@ -0,0 +1,83 @@
+#!/bin/sh
+# Slackware build script for antiword
+# Copyright 2007 by titopoquito (titopoquito@cooltoad.com)
+# Permission to use, copy, modify, and distribute this software for
+# any purpose with or without fee is hereby granted, provided that
+# the above copyright notice and this permission notice appear in all
+# copies.
+#
+# THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+# IN NO EVENT SHALL THE AUTHORS AND COPYRIGHT HOLDERS AND THEIR
+# CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
+# USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+# OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
+# OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+# SUCH DAMAGE.
+# ---------------------------------------------------------------------------
+# Modified by the SlackBuilds.org Project
+
+# Exit on most errors
+set -e
+
+PRGNAM=antiword
+VERSION=0.37
+ARCH=${ARCH:-i486} # this should not change
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo} # the "_SBo" is required
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo} # For consistency's sake, use this
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp} # Drop the package in /tmp
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# let antiword be installed to /usr instead of /usr/local
+# since there is no configre utility here, we'll patch the Makefile
+patch -p0 < $CWD/patch.Makefile
+
+# Compile the application and install it into the $PKG directory
+# call "make all" instead the usual "make" and "make global_install"
+# instead of "make install" to make the binary accessable by all users
+make all
+make global_install DESTDIR=$PKG
+
+# Strip binaries and libraries
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+# The man page is NOT installed correctly. Copy it manually ...
+mkdir -p $PKG/usr/man/man1
+gzip -9cf Docs/antiword.1 > $PKG/usr/man/man1/antiword.1.gz
+
+# Copy program documentation into the package
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a Docs/* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+# Copy the slack-desc into ./install
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+# Make the package; be sure to leave it in $OUTPUT
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/office/antiword/antiword.info b/office/antiword/antiword.info
new file mode 100644
index 0000000000..cade87b62d
--- /dev/null
+++ b/office/antiword/antiword.info
@@ -0,0 +1,8 @@
+PRGNAM="antiword"
+VERSION="0.37"
+HOMEPAGE="http://www.winfield.demon.nl/"
+DOWNLOAD="http://www.winfield.demon.nl/linux/antiword-0.37.tar.gz"
+MD5SUM="f868e2a269edcbc06bf77e89a55898d1"
+MAINTAINER="titopoquito"
+EMAIL="titopoquito@cooltoad.com"
+APPROVED="alien"
diff --git a/office/antiword/patch.Makefile b/office/antiword/patch.Makefile
new file mode 100644
index 0000000000..ed3e5b4cce
--- /dev/null
+++ b/office/antiword/patch.Makefile
@@ -0,0 +1,11 @@
+--- /usr/packages/slackbuild/recoll-Dateisuche/01_antiword/antiword-0.37/Makefile 2005-10-29 19:13:15.000000000 +0200
++++ Makefile 2007-04-05 21:44:19.000000000 +0200
+@@ -36,7 +36,7 @@
+ LOCAL_INSTALL_DIR = $(HOME)/bin
+ LOCAL_RESOURCES_DIR = $(HOME)/.antiword
+
+-GLOBAL_INSTALL_DIR = /usr/local/bin
++GLOBAL_INSTALL_DIR = /usr/bin
+ GLOBAL_RESOURCES_DIR = /usr/share/antiword
+
+ all: $(PROGS)
diff --git a/office/antiword/slack-desc b/office/antiword/slack-desc
new file mode 100644
index 0000000000..607408f9f9
--- /dev/null
+++ b/office/antiword/slack-desc
@@ -0,0 +1,18 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+ |-----handy-ruler------------------------------------------------------|
+antiword: antiword (a free MS Word reader)
+antiword:
+antiword: Antiword is a free MS Word reader for Linux and RISC OS.
+antiword: Antiword converts the binary files from Word 2, 6, 7, 97, 2000,
+antiword: 2002 and 2003 to plain text and to PostScript TM .
+antiword:
+antiword:
+antiword:
+antiword:
+antiword: http://www.winfield.demon.nl/
+antiword: