summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author brobr <sborg63@disroot.org>2022-04-18 01:12:11 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-04-24 01:47:17 +0700
commitb6484732c39b72d23abcc42520d73190ba872cbf (patch)
tree4145ab62528b87baf1bc59b30f846af729b3ce20 /office
parenteee4b79675f9e83441fc2f5d6e602c13812e4483 (diff)
downloadslackbuilds-b6484732c39b72d23abcc42520d73190ba872cbf.tar.gz
slackbuilds-b6484732c39b72d23abcc42520d73190ba872cbf.tar.xz
office/pdfarranger: moved from python; adapted doinst.sh for icons
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'office')
-rw-r--r--office/pdfarranger/README7
-rw-r--r--office/pdfarranger/doinst.sh9
-rw-r--r--office/pdfarranger/pdfarranger.SlackBuild108
-rw-r--r--office/pdfarranger/pdfarranger.info10
-rw-r--r--office/pdfarranger/slack-desc19
5 files changed, 153 insertions, 0 deletions
diff --git a/office/pdfarranger/README b/office/pdfarranger/README
new file mode 100644
index 0000000000..8fc6332e3a
--- /dev/null
+++ b/office/pdfarranger/README
@@ -0,0 +1,7 @@
+PDF Arranger is a small python-gtk application, which helps the user
+to merge or split pdf documents and rotate, crop and rearrange their
+pages using an interactive and intuitive graphical interface. It is
+a frontend for pikepdf and a fork of Konstantinos Poulios's
+pdfshuffler.
+
+PDF Arranger supports image file import if img2pdf is installed
diff --git a/office/pdfarranger/doinst.sh b/office/pdfarranger/doinst.sh
new file mode 100644
index 0000000000..65c7e2eeb9
--- /dev/null
+++ b/office/pdfarranger/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/office/pdfarranger/pdfarranger.SlackBuild b/office/pdfarranger/pdfarranger.SlackBuild
new file mode 100644
index 0000000000..ff1138a58f
--- /dev/null
+++ b/office/pdfarranger/pdfarranger.SlackBuild
@@ -0,0 +1,108 @@
+#!/bin/bash
+
+# Slackware build script for pdfarranger
+
+# Copyright 2020, 2022 Rob van Nues
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=pdfarranger
+VERSION=${VERSION:-1.8.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/share/man -type f -exec gzip -9 {} \;
+mv $PKG/usr/share/man $PKG/usr/man
+
+mv $PKG/usr/share/applications/com.github.jeromerobert.pdfarranger.desktop \
+$PKG/usr/share/applications/pdfarranger.desktop
+
+mv $PKG/usr/share/metainfo/com.github.jeromerobert.pdfarranger.metainfo.xml \
+$PKG/usr/share/metainfo/pdfarranger.metainfo.xml
+
+find $PKG/usr/share/icons/hicolor/ -iname 'com.github.jeromerobert.pdfarranger*' -exec rename com.github.jeromerobert.pdfarranger pdfarranger '{}' ';'
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.* COPYING \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/office/pdfarranger/pdfarranger.info b/office/pdfarranger/pdfarranger.info
new file mode 100644
index 0000000000..11f03e37a7
--- /dev/null
+++ b/office/pdfarranger/pdfarranger.info
@@ -0,0 +1,10 @@
+PRGNAM="pdfarranger"
+VERSION="1.8.2"
+HOMEPAGE="https://github.com/pdfarranger/pdfarranger"
+DOWNLOAD="https://github.com/pdfarranger/pdfarranger/archive/refs/tags/1.8.2/pdfarranger-1.8.2.tar.gz"
+MD5SUM="d38a47d5b5c6cfe16c0bbeb03971bb76"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pikepdf python-distutils-extra python3-dateutil img2pdf"
+MAINTAINER="Rob van Nues"
+EMAIL="sborg63@disroot.org"
diff --git a/office/pdfarranger/slack-desc b/office/pdfarranger/slack-desc
new file mode 100644
index 0000000000..c984ea725d
--- /dev/null
+++ b/office/pdfarranger/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pdfarranger: pdfarranger (rearrange pdf pages)
+pdfarranger:
+pdfarranger: pdfarranger is a small python-gtk application, which helps the user to
+pdfarranger: merge or split pdf documents and rotate, crop and rearrange their
+pdfarranger: pages using an interactive and intuitive graphical interface. It is a
+pdfarranger: frontend for pikepdf and a fork of pdfshuffler. PDF Arranger supports
+pdfarranger: image file import if img2pdf is installed
+pdfarranger:
+pdfarranger: Home: https://github.com/pdfarranger/pdfarranger
+pdfarranger:
+pdfarranger: