summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-09-29 22:35:01 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-10-01 07:28:39 +0700
commita23d4b7a35db7517340cdbd26f7559fea079e9e5 (patch)
tree9d40e3566244ec3935b44b92cf8c5d1abe70b675 /office
parente4549ae28c22409a4d537e5833205ea6eb1622bd (diff)
downloadslackbuilds-a23d4b7a35db7517340cdbd26f7559fea079e9e5.tar.gz
slackbuilds-a23d4b7a35db7517340cdbd26f7559fea079e9e5.tar.xz
office/marave: Switch to i586.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'office')
-rw-r--r--office/marave/marave.SlackBuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/office/marave/marave.SlackBuild b/office/marave/marave.SlackBuild
index f191ae4a51..6777a1a04d 100644
--- a/office/marave/marave.SlackBuild
+++ b/office/marave/marave.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for marave
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -29,7 +29,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -67,7 +67,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
@@ -77,7 +77,6 @@ install -D -m644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.deskto
mkdir -p $PKG/usr/share/pixmaps/
install -D -m644 marave/icons/marave.svg $PKG/usr/share/pixmaps/marave.svg
-
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true