summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author John Tyree <johntyree@gmail.com>2010-12-13 22:01:00 -0200
committer Erik Hanson <erik@slackbuilds.org>2010-12-17 07:56:46 -0600
commitdb8c99c388c580613ec0e6c06ba498a5b8e5fe3e (patch)
treef767c2e1a1272dd517b6302832774a9ad0ac8c10 /office
parent4c2b9e6819ab17e8752feab0be466b51148d3a53 (diff)
downloadslackbuilds-db8c99c388c580613ec0e6c06ba498a5b8e5fe3e.tar.gz
slackbuilds-db8c99c388c580613ec0e6c06ba498a5b8e5fe3e.tar.xz
office/traduisons: Added (python front-end to Google Translate)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'office')
-rw-r--r--office/traduisons/README16
-rw-r--r--office/traduisons/slack-desc19
-rw-r--r--office/traduisons/traduisons.SlackBuild52
-rw-r--r--office/traduisons/traduisons.info10
4 files changed, 97 insertions, 0 deletions
diff --git a/office/traduisons/README b/office/traduisons/README
new file mode 100644
index 0000000000..51d234bbc5
--- /dev/null
+++ b/office/traduisons/README
@@ -0,0 +1,16 @@
+Traduisons! (French for "Let's Translate!") is a front-end for google
+translate, allowing translation of words and sentences without opening the
+browser. It is written in python and optionally uses a gtk-based gui.
+
+Traduisons! is focused on being as streamlined and fast as possible. It is
+designed to be a quick, reference tool, not a large-scale document translator.
+
+Traduisons! itself is not a translator. It works by sending a query string to
+Google's web-based translation service and copying the result to the clipboard
+and screen.
+
+All operations are performed with keyboard shortcuts or specific input
+characters such as '`/`' and '`.`'.
+
+Internet access is required to use Traduisons!
+
diff --git a/office/traduisons/slack-desc b/office/traduisons/slack-desc
new file mode 100644
index 0000000000..01fce47db9
--- /dev/null
+++ b/office/traduisons/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+traduisons: traduisons (python front-end to Google Translate)
+traduisons:
+traduisons: Traduisons! (French for "Let's Translate!") is a front-end for google
+traduisons: translate, allowing translation of words and sentences without opening
+traduisons: the browser. It is written in python and optionally uses a gtk-based
+traduisons: gui. Traduisons! is focused on being as streamlined and fast as
+traduisons: possible. It is designed to be a quick, reference tool, not a
+traduisons: large-scale document translator.
+traduisons:
+traduisons: Internet access is required to use Traduisons!.
+traduisons:
diff --git a/office/traduisons/traduisons.SlackBuild b/office/traduisons/traduisons.SlackBuild
new file mode 100644
index 0000000000..e7986e8ea9
--- /dev/null
+++ b/office/traduisons/traduisons.SlackBuild
@@ -0,0 +1,52 @@
+#!/bin/sh
+
+# Slackware build script for traduisons
+
+# Written by John Tyree johntyree@gmail.com
+
+PRGNAM=traduisons
+VERSION=${VERSION:-0.4.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGELOG LICENSE README PKG-INFO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/office/traduisons/traduisons.info b/office/traduisons/traduisons.info
new file mode 100644
index 0000000000..ae1f6b5c06
--- /dev/null
+++ b/office/traduisons/traduisons.info
@@ -0,0 +1,10 @@
+PRGNAM="traduisons"
+VERSION="0.4.3"
+HOMEPAGE="http://traduisons.googlecode.com"
+DOWNLOAD="http://traduisons.googlecode.com/files/traduisons-0.4.3.tar.gz"
+MD5SUM="fc23d17917ea503adc0b62293e8112e8"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="John Tyree"
+EMAIL="johntyree@gmail.com"
+APPROVED="Niels Horn"