summaryrefslogtreecommitdiffstats
path: root/perl
diff options
context:
space:
mode:
author Andrew Clemons <andrew.clemons@gmail.com>2021-08-28 12:39:08 +1200
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-08-30 06:55:58 +0700
commit0dce96b888fbd713e9c4b922b12aaa37982bbba7 (patch)
tree8aac1192dfe8c92ed411ed2650b54acd969663d6 /perl
parent5e7297490ea2124614af0060e2c6d2b80b0e1cdf (diff)
downloadslackbuilds-0dce96b888fbd713e9c4b922b12aaa37982bbba7.tar.gz
slackbuilds-0dce96b888fbd713e9c4b922b12aaa37982bbba7.tar.xz
perl/perl-WWW-Curl: Add missing dependency.
Update patch to build with newer libcurl. Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'perl')
-rw-r--r--perl/perl-WWW-Curl/WWW-Curl-4.150.0-curl-7.50.2.patch40
-rw-r--r--perl/perl-WWW-Curl/curl-7.71.0.patch.gzbin0 -> 497 bytes
-rw-r--r--perl/perl-WWW-Curl/perl-WWW-Curl.SlackBuild2
-rw-r--r--perl/perl-WWW-Curl/perl-WWW-Curl.info2
4 files changed, 2 insertions, 42 deletions
diff --git a/perl/perl-WWW-Curl/WWW-Curl-4.150.0-curl-7.50.2.patch b/perl/perl-WWW-Curl/WWW-Curl-4.150.0-curl-7.50.2.patch
deleted file mode 100644
index 2fecfce621..0000000000
--- a/perl/perl-WWW-Curl/WWW-Curl-4.150.0-curl-7.50.2.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-curl-7.50.2 introduced a #define without integer value:
-
- #ifdef CURL_NO_OLDIES
- #define CURL_STRICTER
- #endif
-
-Heuristics in 'Makefile.PL' assumes all defines in form of
- #define CURL_<something> <an-expression>
-and generates a symbol lookup table in 'curlopt-constants.c'
-as:
-
- static int
- constant(const char *name)
- {
- errno = 0;
-
- if (strncmp(name, "CURL_", 5) == 0) {
- name += 5;
- switch (*name) {
- ...
- case 'S':
- if (strEQ(name, "STRICTER")) return CURL_STRICTER;
-Which is not valid C:
- curlopt-constants.c:128:49: error: ‘CURL_STRICTER’ undeclared (first use in this function)
- if (strEQ(name, "STRICTER")) return CURL_STRICTER;
- ^~~~~~~~~~~~~
-diff --git a/Makefile.PL b/Makefile.PL
-index f9170bb..fc1a55a 100644
---- a/Makefile.PL
-+++ b/Makefile.PL
-@@ -122,2 +122,9 @@ if (!defined($curl_h)) {
- while(<H>) {
-+ # Skip defines without values like:
-+ # #define CURL_STRICTER
-+ if (/^#define (CURL[A-Za-z0-9_]*)$/) {
-+ chomp;
-+ warn "Skipping '$_': does not define a symbol";
-+ next;
-+ }
- if (/^#define (CURL[A-Za-z0-9_]*)/) {
diff --git a/perl/perl-WWW-Curl/curl-7.71.0.patch.gz b/perl/perl-WWW-Curl/curl-7.71.0.patch.gz
new file mode 100644
index 0000000000..f85592a36f
--- /dev/null
+++ b/perl/perl-WWW-Curl/curl-7.71.0.patch.gz
Binary files differ
diff --git a/perl/perl-WWW-Curl/perl-WWW-Curl.SlackBuild b/perl/perl-WWW-Curl/perl-WWW-Curl.SlackBuild
index caef031833..2a51a3cb5f 100644
--- a/perl/perl-WWW-Curl/perl-WWW-Curl.SlackBuild
+++ b/perl/perl-WWW-Curl/perl-WWW-Curl.SlackBuild
@@ -62,7 +62,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-patch -p1 < $CWD/WWW-Curl-4.150.0-curl-7.50.2.patch
+zcat $CWD/curl-7.71.0.patch.gz | patch -p1
perl Makefile.PL \
PREFIX=/usr \
diff --git a/perl/perl-WWW-Curl/perl-WWW-Curl.info b/perl/perl-WWW-Curl/perl-WWW-Curl.info
index f0c9a3599c..c2c9680284 100644
--- a/perl/perl-WWW-Curl/perl-WWW-Curl.info
+++ b/perl/perl-WWW-Curl/perl-WWW-Curl.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://cpan.metacpan.org/authors/id/S/SZ/SZBALINT/WWW-Curl-4.17.tar.g
MD5SUM="997ac81cd6b03b30b36f7cd930474845"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="perl-Module-Install"
MAINTAINER="Pragmatic Cypher"
EMAIL="slackbuilds@server.ky"