summaryrefslogtreecommitdiffstats
path: root/python/Flask
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-05-29 17:21:42 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-06-01 23:54:42 +0700
commit672087c291edc9ab23a5e36e5a3d5a1fd7ada83f (patch)
treecf50627e68a80f2037a920fd07b866147490e720 /python/Flask
parent82bef69f6a3318a32f356e9b80d1dde9ac8068fa (diff)
downloadslackbuilds-672087c291edc9ab23a5e36e5a3d5a1fd7ada83f.tar.gz
slackbuilds-672087c291edc9ab23a5e36e5a3d5a1fd7ada83f.tar.xz
python/Flask: Updated for version 0.11.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'python/Flask')
-rw-r--r--python/Flask/Flask.SlackBuild6
-rw-r--r--python/Flask/Flask.info9
-rw-r--r--python/Flask/README2
-rw-r--r--python/Flask/slack-desc4
4 files changed, 10 insertions, 11 deletions
diff --git a/python/Flask/Flask.SlackBuild b/python/Flask/Flask.SlackBuild
index dc8daf6d4e..2054696873 100644
--- a/python/Flask/Flask.SlackBuild
+++ b/python/Flask/Flask.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for Flask
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=Flask
-VERSION=${VERSION:-0.10.1}
+VERSION=${VERSION:-0.11}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -67,7 +67,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
diff --git a/python/Flask/Flask.info b/python/Flask/Flask.info
index d437836f1b..8a7b4e9dc3 100644
--- a/python/Flask/Flask.info
+++ b/python/Flask/Flask.info
@@ -1,11 +1,10 @@
PRGNAM="Flask"
-VERSION="0.10.1"
+VERSION="0.11"
HOMEPAGE="http://flask.pocoo.org/"
-DOWNLOAD="https://pypi.python.org/packages/source/F/Flask/Flask-0.10.1.tar.gz"
-MD5SUM="378670fe456957eb3c27ddaef60b2b24"
+DOWNLOAD="https://pypi.python.org/packages/dc/ca/c0ed9cc90c079085c698e284b672edbc1ffd6866b1830574095cbc5b7752/Flask-0.11.tar.gz"
+MD5SUM="89fbdcb04b7b96c5b24625ae299cf48b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="werkzeug Jinja2 itsdangerous"
+REQUIRES="werkzeug Jinja2 itsdangerous click"
MAINTAINER="Dimitris Zlatanidis"
EMAIL="d.zlatanidis@gmail.com"
-
diff --git a/python/Flask/README b/python/Flask/README
index fdc117a9e8..13caec97e5 100644
--- a/python/Flask/README
+++ b/python/Flask/README
@@ -1,3 +1,3 @@
Flask is a microframework for Python based on Werkzeug
-and Jinja2. It's intended for getting started very quickly
+and Jinja2. It's intended for getting started very quickly
and was developed with best intentions in mind.
diff --git a/python/Flask/slack-desc b/python/Flask/slack-desc
index 6e0a4c8879..d5f2924318 100644
--- a/python/Flask/slack-desc
+++ b/python/Flask/slack-desc
@@ -6,14 +6,14 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-Flask: Flask (Microframework based on Werkzeug, Jinja2 and good intentions)
+Flask: Flask (Microframework for Python)
Flask:
Flask: Flask is a microframework for Python based on Werkzeug, Jinja 2
Flask: and good intentions.
Flask:
+Flask: Homepage: http://flask.pocoo.org/
Flask:
Flask:
Flask:
Flask:
-Flask: Homepage: http://flask.pocoo.org/
Flask: