summaryrefslogtreecommitdiffstats
path: root/python/Pyro4
diff options
context:
space:
mode:
author Thibaut Notteboom <tib@tibux.org>2011-12-14 10:48:21 -0600
committer Niels Horn <niels.horn@slackbuilds.org>2011-12-18 00:07:48 -0200
commit6e65c9c406c54741b2f8b83ae25865d8742aca7d (patch)
tree4092845917cea11e0cde5507238b2a7833e0d185 /python/Pyro4
parentf9b670f4e512254b89bb9d94491a7778d73522aa (diff)
downloadslackbuilds-6e65c9c406c54741b2f8b83ae25865d8742aca7d.tar.gz
slackbuilds-6e65c9c406c54741b2f8b83ae25865d8742aca7d.tar.xz
python/Pyro4: Added (PYthon Remote Objects 4.x)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/Pyro4')
-rw-r--r--python/Pyro4/Pyro4.SlackBuild63
-rw-r--r--python/Pyro4/Pyro4.info10
-rw-r--r--python/Pyro4/README3
-rw-r--r--python/Pyro4/slack-desc19
4 files changed, 95 insertions, 0 deletions
diff --git a/python/Pyro4/Pyro4.SlackBuild b/python/Pyro4/Pyro4.SlackBuild
new file mode 100644
index 0000000000..f8adb9c22c
--- /dev/null
+++ b/python/Pyro4/Pyro4.SlackBuild
@@ -0,0 +1,63 @@
+#!/bin/sh
+
+# Slackware build script for Pyro
+# Written by Thibaut Notteboom (tib@tibux.org)
+
+PRGNAM=Pyro4
+VERSION=${VERSION:-4.11}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.txt docs/ examples/ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/Pyro4/Pyro4.info b/python/Pyro4/Pyro4.info
new file mode 100644
index 0000000000..9d236f7d54
--- /dev/null
+++ b/python/Pyro4/Pyro4.info
@@ -0,0 +1,10 @@
+PRGNAM="Pyro4"
+VERSION="4.11"
+HOMEPAGE="http://irmen.home.xs4all.nl/pyro/"
+DOWNLOAD="http://pypi.python.org/packages/source/P/Pyro4/Pyro4-4.11.tar.gz"
+MD5SUM="8126e7049206b7b09f324750f50cee2d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Thibaut Notteboom"
+EMAIL="tib@tibux.org"
+APPROVED="rworkman"
diff --git a/python/Pyro4/README b/python/Pyro4/README
new file mode 100644
index 0000000000..80c214e00a
--- /dev/null
+++ b/python/Pyro4/README
@@ -0,0 +1,3 @@
+Pyro4 means PYthon Remote Objects. It is an advanced and powerful
+Distributed Object Technology system written entirely in Python
+that is designed to be very easy to use.
diff --git a/python/Pyro4/slack-desc b/python/Pyro4/slack-desc
new file mode 100644
index 0000000000..d105f06a9c
--- /dev/null
+++ b/python/Pyro4/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+Pyro4: Pyro4 (PYthon Remote Objects 4.x).
+Pyro4:
+Pyro4: Pyro means PYthon Remote Objects. It is an advanced and powerful
+Pyro4: Distributed Object Technology system written entirely in Python
+Pyro4: that is designed to be very easy to use.
+Pyro4:
+Pyro4: Homepage: http://irmen.home.xs4all.nl/pyro/
+Pyro4:
+Pyro4:
+Pyro4:
+Pyro4: