summaryrefslogtreecommitdiffstats
path: root/python/apsw
diff options
context:
space:
mode:
author Andrew Clemons <andrew.clemons@gmail.com>2022-03-07 20:44:26 +1300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-08 09:46:13 +0700
commit6908e35b80d4347bd1b4a6c41be36b2e66c95fe2 (patch)
treec95f6ac5f65e5caae1b81caf00ec5727e707bc7a /python/apsw
parent51202f2516edd4576dedfd88e31366aa61b6b7a3 (diff)
downloadslackbuilds-6908e35b80d4347bd1b4a6c41be36b2e66c95fe2.tar.gz
slackbuilds-6908e35b80d4347bd1b4a6c41be36b2e66c95fe2.tar.xz
python/apsw: Always build python3.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/apsw')
-rw-r--r--python/apsw/README3
-rw-r--r--python/apsw/apsw.SlackBuild6
2 files changed, 2 insertions, 7 deletions
diff --git a/python/apsw/README b/python/apsw/README
index c078b5fc93..ee0623e83c 100644
--- a/python/apsw/README
+++ b/python/apsw/README
@@ -3,6 +3,3 @@ contrast to other wrappers such as pysqlite it focuses on being a minimal layer
over SQLite attempting just to translate the complete SQLite API into Python.
The documentation has a section on the differences between APSW and pysqlite.
APSW supports CPython 2.3 onwards and CPython 3.1 onwards.
-
-Note: To install python 3 set PYTHON3=yes.
- # PYTHON3=yes ./apsw.SlackBuild
diff --git a/python/apsw/apsw.SlackBuild b/python/apsw/apsw.SlackBuild
index 195d7cb864..18370cda60 100644
--- a/python/apsw/apsw.SlackBuild
+++ b/python/apsw/apsw.SlackBuild
@@ -68,10 +68,8 @@ find -L . \
python setup.py build --enable-all-extensions
python setup.py install --root=$PKG --skip-build
-if [ "${PYTHON3:-no}" == "yes" ]; then
- python3 setup.py build --enable-all-extensions
- python3 setup.py install --root=$PKG --skip-build
-fi
+python3 setup.py build --enable-all-extensions
+python3 setup.py install --root=$PKG --skip-build
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true