summaryrefslogtreecommitdiffstats
path: root/python/buildbot-worker
diff options
context:
space:
mode:
author Arn0 <yth@ythogtha.org>2022-03-02 10:44:05 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-03 15:56:39 +0700
commitc5d809b1d5ef94f3b43fd5cdf0d25cb62fdc990c (patch)
treed1fdd3fdf1cff466bbdf00911a8a2645eb6b3d63 /python/buildbot-worker
parent07d9277718e454550ec2da7c5c8c4385b5820549 (diff)
downloadslackbuilds-c5d809b1d5ef94f3b43fd5cdf0d25cb62fdc990c.tar.gz
slackbuilds-c5d809b1d5ef94f3b43fd5cdf0d25cb62fdc990c.tar.xz
python/buildbot-worker: Updated for version 3.4.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/buildbot-worker')
-rw-r--r--python/buildbot-worker/README5
-rw-r--r--python/buildbot-worker/buildbot-worker.SlackBuild96
-rw-r--r--python/buildbot-worker/buildbot-worker.info10
-rw-r--r--python/buildbot-worker/slack-desc19
4 files changed, 130 insertions, 0 deletions
diff --git a/python/buildbot-worker/README b/python/buildbot-worker/README
new file mode 100644
index 0000000000..4e209f21db
--- /dev/null
+++ b/python/buildbot-worker/README
@@ -0,0 +1,5 @@
+Buildbot-worker is a worker to the continuous integration system
+designed to automate the build/test cycle (buildbot).
+By automatically rebuilding and testing the tree each time
+something has changed, build problems are pinpointed quickly,
+before other developers are inconvenienced by the failure.
diff --git a/python/buildbot-worker/buildbot-worker.SlackBuild b/python/buildbot-worker/buildbot-worker.SlackBuild
new file mode 100644
index 0000000000..ca796423f6
--- /dev/null
+++ b/python/buildbot-worker/buildbot-worker.SlackBuild
@@ -0,0 +1,96 @@
+#!/bin/bash
+
+# Slackware build script for python3 buildbot-worker
+
+# Copyright 2021 Yth | Pont-en-Royans, France | yth@ythogtha.org
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=buildbot-worker
+SRCNAM=${PRGNAM#python-*}
+VERSION=${VERSION:-3.4.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a docs/ COPYING NEWS PKG-INFO README UPGRADING $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/buildbot-worker/buildbot-worker.info b/python/buildbot-worker/buildbot-worker.info
new file mode 100644
index 0000000000..70fd49bdb3
--- /dev/null
+++ b/python/buildbot-worker/buildbot-worker.info
@@ -0,0 +1,10 @@
+PRGNAM="buildbot-worker"
+VERSION="3.4.1"
+HOMEPAGE="https://pypi.python.org/pypi/buildbot-worker"
+DOWNLOAD="https://pypi.python.org/packages/source/b/buildbot-worker/buildbot-worker-3.4.1.tar.gz"
+MD5SUM="d90ed3b580eed91fa2179a63cccda356"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python-twisted"
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/buildbot-worker/slack-desc b/python/buildbot-worker/slack-desc
new file mode 100644
index 0000000000..0545d27a69
--- /dev/null
+++ b/python/buildbot-worker/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+buildbot-worker: buildbot-worker (worker to buildbot)
+buildbot-worker:
+buildbot-worker: buildbot-woker is a slave to the continuous integration system
+buildbot-worker: designed to automate the build/test cycle.
+buildbot-worker: By automatically rebuilding and testing the tree each time
+buildbot-worker: something has changed, build problems are pinpointed quickly,
+buildbot-worker: before other developers are inconvenienced by the failure.
+buildbot-worker:
+buildbot-worker: Homepage: http://buildbot.net
+buildbot-worker:
+buildbot-worker: