summaryrefslogtreecommitdiffstats
path: root/python/coverage
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2014-01-15 12:19:09 +0700
committer Erik Hanson <erik@slackbuilds.org>2014-01-29 23:21:02 -0600
commitc98080fb5d3738ec7d4a322c5405f3224ac595f1 (patch)
treeddb9b0b5282b7bf9ac426e8fcd5c7adc37b22585 /python/coverage
parentf5b4dd36728a0fd199ec0d4e97a53cf2f34f0f45 (diff)
downloadslackbuilds-c98080fb5d3738ec7d4a322c5405f3224ac595f1.tar.gz
slackbuilds-c98080fb5d3738ec7d4a322c5405f3224ac595f1.tar.xz
python/coverage: Added (Code coverage measurement for Python).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/coverage')
-rw-r--r--python/coverage/README5
-rw-r--r--python/coverage/coverage.SlackBuild86
-rw-r--r--python/coverage/coverage.info10
-rw-r--r--python/coverage/slack-desc19
4 files changed, 120 insertions, 0 deletions
diff --git a/python/coverage/README b/python/coverage/README
new file mode 100644
index 0000000000..e2bf006726
--- /dev/null
+++ b/python/coverage/README
@@ -0,0 +1,5 @@
+Coverage.py: code coverage testing for Python
+
+Coverage.py measures code coverage, typically during test execution. It uses
+the code analysis tools and tracing hooks provided in the Python standard
+library to determine which lines are executable, and which have been executed.
diff --git a/python/coverage/coverage.SlackBuild b/python/coverage/coverage.SlackBuild
new file mode 100644
index 0000000000..4ffe1895d6
--- /dev/null
+++ b/python/coverage/coverage.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for coverage
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=coverage
+VERSION=${VERSION:-3.7.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.txt AUTHORS.txt CHANGES.txt PKG-INFO doc/*.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/coverage/coverage.info b/python/coverage/coverage.info
new file mode 100644
index 0000000000..429289efb7
--- /dev/null
+++ b/python/coverage/coverage.info
@@ -0,0 +1,10 @@
+PRGNAM="coverage"
+VERSION="3.7.1"
+HOMEPAGE="http://nedbatchelder.com/code/coverage/"
+DOWNLOAD="https://pypi.python.org/packages/source/c/coverage/coverage-3.7.1.tar.gz"
+MD5SUM="c47b36ceb17eaff3ecfab3bcd347d0df"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools nose mock tox pylint Sphinx"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/coverage/slack-desc b/python/coverage/slack-desc
new file mode 100644
index 0000000000..a9ec1cdf94
--- /dev/null
+++ b/python/coverage/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+coverage: coverage (Code coverage measurement for Python)
+coverage:
+coverage: Coverage.py measures code coverage, typically during test
+coverage: execution. It uses the code analysis tools and tracing hooks
+coverage: provided in the Python standard library to determine which
+coverage: lines are executable, and which have been executed.
+coverage:
+coverage:
+coverage: Homepage: http://nedbatchelder.com/code/coverage/
+coverage:
+coverage: