summaryrefslogtreecommitdiffstats
path: root/python/cssselect
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2012-12-11 09:47:54 +0100
committer dsomero <xgizzmo@slackbuilds.org>2012-12-11 16:23:07 -0500
commit8605168a123ea7da106b2733af127174fa326a99 (patch)
tree9547f4aaf25dea7a263e3fc31e1aa4725c44fa39 /python/cssselect
parenta44650c691eb054deb0d59ee0d17e49d91565500 (diff)
downloadslackbuilds-8605168a123ea7da106b2733af127174fa326a99.tar.gz
slackbuilds-8605168a123ea7da106b2733af127174fa326a99.tar.xz
python/cssselect: Added (CSS3 selectors parser).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'python/cssselect')
-rw-r--r--python/cssselect/README3
-rw-r--r--python/cssselect/cssselect.SlackBuild87
-rw-r--r--python/cssselect/cssselect.info10
-rw-r--r--python/cssselect/slack-desc19
4 files changed, 119 insertions, 0 deletions
diff --git a/python/cssselect/README b/python/cssselect/README
new file mode 100644
index 0000000000..962b0278f1
--- /dev/null
+++ b/python/cssselect/README
@@ -0,0 +1,3 @@
+cssselect parses CSS3 Selectors and translate them to XPath 1.0 expressions.
+Such expressions can be used in lxml or another XPath engine to find the
+matching elements in an XML or HTML document.
diff --git a/python/cssselect/cssselect.SlackBuild b/python/cssselect/cssselect.SlackBuild
new file mode 100644
index 0000000000..22725a4746
--- /dev/null
+++ b/python/cssselect/cssselect.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for cssselect
+
+# Copyright 2012 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=cssselect
+VERSION=${VERSION:-0.7.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS CHANGES LICENSE PKG-INFO README.rst docs/* \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/cssselect/cssselect.info b/python/cssselect/cssselect.info
new file mode 100644
index 0000000000..81aad3d5cc
--- /dev/null
+++ b/python/cssselect/cssselect.info
@@ -0,0 +1,10 @@
+PRGNAM="cssselect"
+VERSION="0.7.1"
+HOMEPAGE="http://packages.python.org/cssselect/"
+DOWNLOAD="http://pypi.python.org/packages/source/c/cssselect/cssselect-0.7.1.tar.gz"
+MD5SUM="c6c5e9a2e7ca226ce03f6f67a771379c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="distribute"
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/python/cssselect/slack-desc b/python/cssselect/slack-desc
new file mode 100644
index 0000000000..a25ab46377
--- /dev/null
+++ b/python/cssselect/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+cssselect: cssselect
+cssselect:
+cssselect: cssselect parses CSS3 Selectors and translate them to XPath 1.0
+cssselect: expressions. Such expressions can be used in lxml or another XPath
+cssselect: engine to find the matching elements in an XML or HTML document.
+cssselect:
+cssselect: Homepage: http://packages.python.org/cssselect/
+cssselect:
+cssselect:
+cssselect:
+cssselect: