summaryrefslogtreecommitdiffstats
path: root/python/decorator
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <bosth@alumni.sfu.ca>2017-04-15 17:14:11 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-04-22 08:10:26 +0700
commit3b7215cf863de914bd5d3ed69946377de82c6c8a (patch)
treee0ca379f7d96965f98f1d3b551be2b7f36b070ec /python/decorator
parent70ecd2bf055b7f13871cd3aa0561bf3e933199de (diff)
downloadslackbuilds-3b7215cf863de914bd5d3ed69946377de82c6c8a.tar.gz
slackbuilds-3b7215cf863de914bd5d3ed69946377de82c6c8a.tar.xz
python/decorator: Remove Python 3 support.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'python/decorator')
-rw-r--r--python/decorator/README2
-rw-r--r--python/decorator/decorator.SlackBuild5
-rw-r--r--python/decorator/slack-desc2
3 files changed, 1 insertions, 8 deletions
diff --git a/python/decorator/README b/python/decorator/README
index ff2bfc793c..d1d2a840af 100644
--- a/python/decorator/README
+++ b/python/decorator/README
@@ -2,5 +2,3 @@ The aim of the decorator module it to simplify the usage of decorators
for the average programmer, and to popularize decorators usage giving
examples of useful decorators, such as memoize, tracing,
redirecting_stdout, locked, etc.
-
-Python 3 support will be included if python3 is installed.
diff --git a/python/decorator/decorator.SlackBuild b/python/decorator/decorator.SlackBuild
index ccb77a0a76..5864a4fff1 100644
--- a/python/decorator/decorator.SlackBuild
+++ b/python/decorator/decorator.SlackBuild
@@ -58,11 +58,6 @@ find -L . \
python setup.py install --root=$PKG
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a CHANGES.md LICENSE.txt docs/README.rst $PKG/usr/doc/$PRGNAM-$VERSION/
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/python/decorator/slack-desc b/python/decorator/slack-desc
index 24dc979f50..ed6b666076 100644
--- a/python/decorator/slack-desc
+++ b/python/decorator/slack-desc
@@ -6,7 +6,7 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-decorator: decorator (The decorator Python module)
+decorator: decorator (decorator module for Python)
decorator:
decorator: The aim of the decorator module it to simplify the usage of
decorator: decorators for the average programmer, and to popularize decorators