summaryrefslogtreecommitdiffstats
path: root/python/entrypoints/setup.py
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <slackbuilds@jaxartes.net>2017-01-24 21:44:47 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-01-28 07:38:02 +0700
commit88e26a9d850073317b213beda47e5da8b881ccb0 (patch)
tree77691ac87eae3371c909afcba1ed08265cd20e84 /python/entrypoints/setup.py
parent866186bcf6266eef7dd5209abc4818a0399d8c7d (diff)
downloadslackbuilds-88e26a9d850073317b213beda47e5da8b881ccb0.tar.gz
slackbuilds-88e26a9d850073317b213beda47e5da8b881ccb0.tar.xz
python/entrypoints: Added (Discover & load entry points).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/entrypoints/setup.py')
-rw-r--r--python/entrypoints/setup.py13
1 files changed, 13 insertions, 0 deletions
diff --git a/python/entrypoints/setup.py b/python/entrypoints/setup.py
new file mode 100644
index 0000000000..e278244224
--- /dev/null
+++ b/python/entrypoints/setup.py
@@ -0,0 +1,13 @@
+
+from setuptools import setup, find_packages
+
+setup(
+ name='entrypoints',
+ version='0.3',
+ description='Discover and load entry points from installed packages',
+ url='https://github.com/takluyver/entrypoints',
+ author='https://github.com/takluyver',
+ license='MIT',
+ long_description='The entrypoints module contains functions to find and load entry points, a way for Python packages to advertise objects.',
+ py_modules=['entrypoints']
+)