summaryrefslogtreecommitdiffstats
path: root/python/foolscap
diff options
context:
space:
mode:
author Markus Reichelt <slackbuilds@mareichelt.de>2012-06-28 16:57:52 -0400
committer dsomero <xgizzmo@slackbuilds.org>2012-06-28 16:57:52 -0400
commit344022d9c3550b4a266713fe1b5987f9dac85e9b (patch)
tree9fae55dde3ff92d8531b5882f589dfe39f27f6d7 /python/foolscap
parent2c661fa148d1f7274ff1d5590cef02eb3194df01 (diff)
downloadslackbuilds-344022d9c3550b4a266713fe1b5987f9dac85e9b.tar.gz
slackbuilds-344022d9c3550b4a266713fe1b5987f9dac85e9b.tar.xz
python/foolscap: Updated for version 0.6.4, moved from libraries.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'python/foolscap')
-rw-r--r--python/foolscap/README8
-rw-r--r--python/foolscap/foolscap.SlackBuild91
-rw-r--r--python/foolscap/foolscap.info10
-rw-r--r--python/foolscap/slack-desc19
4 files changed, 128 insertions, 0 deletions
diff --git a/python/foolscap/README b/python/foolscap/README
new file mode 100644
index 0000000000..1a59cf9780
--- /dev/null
+++ b/python/foolscap/README
@@ -0,0 +1,8 @@
+"Foolscap" is an RPC protocol for Python+Twisted, providing a
+capability-based security model and flexible serialization. It
+is intended to replace Twisted's native "Perspective Broker"
+RPC system. Foolscap has been under development (on and off)
+by Brian Warner for several years.
+
+This package requires pysetuptools, python-twisted and
+zope.interface.
diff --git a/python/foolscap/foolscap.SlackBuild b/python/foolscap/foolscap.SlackBuild
new file mode 100644
index 0000000000..302f336563
--- /dev/null
+++ b/python/foolscap/foolscap.SlackBuild
@@ -0,0 +1,91 @@
+#!/bin/sh
+
+# Slackware build script for foolscap.
+
+# Copyright 2010-2011 Marco Bonetti <sid77@slackware.it>
+# Copyright 2012 Markus Reichelt, Aachen, DE
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# Originally written by Marco Bonetti - Thanks!
+# Now maintained by Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
+
+PRGNAM=foolscap
+VERSION=${VERSION:-0.6.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ ChangeLog NEWS LICENSE README doc/* \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/foolscap/foolscap.info b/python/foolscap/foolscap.info
new file mode 100644
index 0000000000..058211b1bd
--- /dev/null
+++ b/python/foolscap/foolscap.info
@@ -0,0 +1,10 @@
+PRGNAM="foolscap"
+VERSION="0.6.4"
+HOMEPAGE="http://foolscap.lothar.com/trac"
+DOWNLOAD="http://foolscap.lothar.com/releases/foolscap-0.6.4.tar.gz"
+MD5SUM="0aedae62a0be50da4f89d80b5b30c8a2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Markus Reichelt"
+EMAIL="slackbuilds@mareichelt.de"
+APPROVED="dsomero"
diff --git a/python/foolscap/slack-desc b/python/foolscap/slack-desc
new file mode 100644
index 0000000000..7311ee50ca
--- /dev/null
+++ b/python/foolscap/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+foolscap: foolscap (RPC protocol for Python+Twisted)
+foolscap:
+foolscap: Foolscap is an RPC protocol for Python+Twisted, providing a
+foolscap: capability-based security model and flexible serialization. It is
+foolscap: intended to replace Twisted's native "Perspective Broker" RPC
+foolscap: system.
+foolscap:
+foolscap: Homepage: http://foolscap.lothar.com/trac
+foolscap:
+foolscap:
+foolscap: