summaryrefslogtreecommitdiffstats
path: root/python/fudge
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2014-01-11 08:40:53 +0700
committer Erik Hanson <erik@slackbuilds.org>2014-01-29 23:20:58 -0600
commit97cf4a77b51945b78710e211f442b299140b0b34 (patch)
tree1e0dfd556ac58af23cb4c09e70cd6e252decb430 /python/fudge
parentcd08444e2e106f5e9694b865b113cbe5e1b090f5 (diff)
downloadslackbuilds-97cf4a77b51945b78710e211f442b299140b0b34.tar.gz
slackbuilds-97cf4a77b51945b78710e211f442b299140b0b34.tar.xz
python/fudge: Added (Python module for using fake objects).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/fudge')
-rw-r--r--python/fudge/README2
-rw-r--r--python/fudge/fudge.SlackBuild86
-rw-r--r--python/fudge/fudge.info11
-rw-r--r--python/fudge/slack-desc19
4 files changed, 118 insertions, 0 deletions
diff --git a/python/fudge/README b/python/fudge/README
new file mode 100644
index 0000000000..15adf2f329
--- /dev/null
+++ b/python/fudge/README
@@ -0,0 +1,2 @@
+Fudge is a Python module for using fake objects (mocks and stubs)
+to test real ones.
diff --git a/python/fudge/fudge.SlackBuild b/python/fudge/fudge.SlackBuild
new file mode 100644
index 0000000000..adf95ef29e
--- /dev/null
+++ b/python/fudge/fudge.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for fudge
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=fudge
+VERSION=${VERSION:-1.0.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.txt LICENSE.txt PKG-INFO docs/*.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/fudge/fudge.info b/python/fudge/fudge.info
new file mode 100644
index 0000000000..2287777fe8
--- /dev/null
+++ b/python/fudge/fudge.info
@@ -0,0 +1,11 @@
+PRGNAM="fudge"
+VERSION="1.0.3"
+HOMEPAGE="http://farmdev.com/projects/fudge/"
+DOWNLOAD="https://pypi.python.org/packages/source/f/fudge/fudge-1.0.3.tar.gz"
+MD5SUM="ee0797e0a28732e630938da16137240a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
+
diff --git a/python/fudge/slack-desc b/python/fudge/slack-desc
new file mode 100644
index 0000000000..14a914994c
--- /dev/null
+++ b/python/fudge/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+fudge: fudge (Python module for using fake objects)
+fudge:
+fudge: Replace real objects with fakes (mocks, stubs, etc) while testing.
+fudge:
+fudge: Fudge is a Python module for using fake objects (mocks and stubs)
+fudge: to test real ones.
+fudge:
+fudge:
+fudge:
+fudge: Homepage: http://farmdev.com/projects/fudge/
+fudge: