summaryrefslogtreecommitdiffstats
path: root/python/huepy
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-02-12 12:56:14 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-02-13 09:17:50 +0700
commit9e028fa05776ba78ca3d540a41847c6403b23e79 (patch)
tree5d28b9291df85093e3a8240f8b92890af166abad /python/huepy
parent0315938fc3ba71b08385a638261d8ecdd8bc68b2 (diff)
downloadslackbuilds-9e028fa05776ba78ca3d540a41847c6403b23e79.tar.gz
slackbuilds-9e028fa05776ba78ca3d540a41847c6403b23e79.tar.xz
python/huepy: Added (python text color library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/huepy')
-rw-r--r--python/huepy/README4
-rw-r--r--python/huepy/huepy.SlackBuild73
-rw-r--r--python/huepy/huepy.info10
-rw-r--r--python/huepy/slack-desc19
4 files changed, 106 insertions, 0 deletions
diff --git a/python/huepy/README b/python/huepy/README
new file mode 100644
index 0000000000..3467c1a0d5
--- /dev/null
+++ b/python/huepy/README
@@ -0,0 +1,4 @@
+huepy (python text color library)
+
+huepy provides a minimal and powerful interface to print colored text
+and labels in the terminal. It works with Python 2 and 3.
diff --git a/python/huepy/huepy.SlackBuild b/python/huepy/huepy.SlackBuild
new file mode 100644
index 0000000000..a97c29ee15
--- /dev/null
+++ b/python/huepy/huepy.SlackBuild
@@ -0,0 +1,73 @@
+#!/bin/bash
+
+# Slackware build script for huepy
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=huepy
+VERSION=${VERSION:-1.2.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
+rm -f $PKG/usr/LICENSE
+
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC
+cp -a LICENSE* README* $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/huepy/huepy.info b/python/huepy/huepy.info
new file mode 100644
index 0000000000..16fd31aa2b
--- /dev/null
+++ b/python/huepy/huepy.info
@@ -0,0 +1,10 @@
+PRGNAM="huepy"
+VERSION="1.2.1"
+HOMEPAGE="https://pypi.org/project/huepy/"
+DOWNLOAD="https://files.pythonhosted.org/packages/d6/4e/2dae447d8858a31158ca6c313f5d1902bc83b8542bb5f10c0307de2973bc/huepy-1.2.1.tar.gz"
+MD5SUM="394a1072bec18c27097b053c40ddf0ea"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
diff --git a/python/huepy/slack-desc b/python/huepy/slack-desc
new file mode 100644
index 0000000000..cc74ce9fae
--- /dev/null
+++ b/python/huepy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+huepy: huepy (python text color library)
+huepy:
+huepy: huepy provides a minimal and powerful interface to print colored text
+huepy: and labels in the terminal. It works with Python 2 and 3.
+huepy:
+huepy:
+huepy:
+huepy:
+huepy:
+huepy:
+huepy: