summaryrefslogtreecommitdiffstats
path: root/python/i3-py
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-09-27 16:22:20 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-10-01 07:28:39 +0700
commit11b56649b8de0a3ced2b8e90fc87cfc7d894bd71 (patch)
treeeed1f226ea48ecf41d17831ed3e06fa995e29196 /python/i3-py
parentdcaea59b82fd6d0c144d62d72495243239536d37 (diff)
downloadslackbuilds-11b56649b8de0a3ced2b8e90fc87cfc7d894bd71.tar.gz
slackbuilds-11b56649b8de0a3ced2b8e90fc87cfc7d894bd71.tar.xz
python/i3-py: Switch to i586.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'python/i3-py')
-rw-r--r--python/i3-py/i3-py.SlackBuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/python/i3-py/i3-py.SlackBuild b/python/i3-py/i3-py.SlackBuild
index b114540b91..273ef8cc1a 100644
--- a/python/i3-py/i3-py.SlackBuild
+++ b/python/i3-py/i3-py.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for i3-py
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,7 +22,6 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
PRGNAM=i3-py
VERSION=${VERSION:-0.6.4}
BUILD=${BUILD:-1}
@@ -30,7 +29,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -41,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -68,7 +67,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG