summaryrefslogtreecommitdiffstats
path: root/python/lxml
diff options
context:
space:
mode:
author Larry Hajali <larryhaja@gmail.com>2014-09-14 07:59:15 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-09-14 07:59:15 +0700
commit1edbc8b082cb52f768d7710378c0f92831f8e784 (patch)
tree67cc2fb19cfc7d7cadf200115d7700933336996c /python/lxml
parente1b353b7f92ee042a8ea407106635bb00f187f68 (diff)
downloadslackbuilds-1edbc8b082cb52f768d7710378c0f92831f8e784.tar.gz
slackbuilds-1edbc8b082cb52f768d7710378c0f92831f8e784.tar.xz
python/lxml: Updated for version 3.4.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/lxml')
-rw-r--r--python/lxml/README4
-rw-r--r--python/lxml/lxml.SlackBuild7
-rw-r--r--python/lxml/lxml.info6
3 files changed, 11 insertions, 6 deletions
diff --git a/python/lxml/README b/python/lxml/README
index 03c9bcbdbc..61afd1f60f 100644
--- a/python/lxml/README
+++ b/python/lxml/README
@@ -2,5 +2,5 @@ lxml is a Pythonic binding for the libxml2 and libxslt libraries.
It is unique in that it combines the speed and feature completeness
of these libraries with the simplicity of a native Python API.
-Cython and pysetuptools are optional build dependencies. cssselect
-and html5lib are optional runtime dependencies.
+Cython, python3 and pysetuptools are optional build dependencies.
+cssselect and html5lib are optional runtime dependencies.
diff --git a/python/lxml/lxml.SlackBuild b/python/lxml/lxml.SlackBuild
index e06a191930..a59729373e 100644
--- a/python/lxml/lxml.SlackBuild
+++ b/python/lxml/lxml.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=lxml
-VERSION=${VERSION:-3.3.6}
+VERSION=${VERSION:-3.4.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -68,6 +68,11 @@ find -L . \
python setup.py build --with-unicode-strings
python setup.py install --skip-build --root=$PKG
+if $(python3 -c 'import os' 2>/dev/null); then
+ python3 setup.py build --with-unicode-strings
+ python3 setup.py install --skip-build --root=$PKG
+fi
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/lxml/lxml.info b/python/lxml/lxml.info
index b5e8b6c81c..8bb868f635 100644
--- a/python/lxml/lxml.info
+++ b/python/lxml/lxml.info
@@ -1,8 +1,8 @@
PRGNAM="lxml"
-VERSION="3.3.6"
+VERSION="3.4.0"
HOMEPAGE="http://lxml.de/"
-DOWNLOAD="http://pypi.python.org/packages/source/l/lxml/lxml-3.3.6.tar.gz"
-MD5SUM="a804b36864c483fe7abdd7f493a0c379"
+DOWNLOAD="http://pypi.python.org/packages/source/l/lxml/lxml-3.4.0.tar.gz"
+MD5SUM="bc90cc4e4ee04e1f8290ae0f70e34eea"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="BeautifulSoup"