summaryrefslogtreecommitdiffstats
path: root/python/munch
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <bosth@alumni.sfu.ca>2018-04-09 11:11:45 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-04-14 07:06:34 +0700
commita10527fb9239db76cf84249fb11a0dab8a93051d (patch)
tree45ac29e8be67c988de3e2f026baef63c34c60999 /python/munch
parent8c210e4b07a044c8ec986e1ef9a573df4b050fcf (diff)
downloadslackbuilds-a10527fb9239db76cf84249fb11a0dab8a93051d.tar.gz
slackbuilds-a10527fb9239db76cf84249fb11a0dab8a93051d.tar.xz
python/munch: Updated for version 2.3.1.
Diffstat (limited to 'python/munch')
-rw-r--r--python/munch/README2
-rw-r--r--python/munch/munch.SlackBuild19
-rw-r--r--python/munch/munch.info6
3 files changed, 17 insertions, 10 deletions
diff --git a/python/munch/README b/python/munch/README
index 1d6a19c454..c4e8b0c29c 100644
--- a/python/munch/README
+++ b/python/munch/README
@@ -1,2 +1,4 @@
Munch implements a Python dictionary that provides attribute-style access (a la
JavaScript objects). Munch is a fork of David Schoonover's Bunch package.
+
+Munch will make use PyYAML and python3-PyYAML if they are installed.
diff --git a/python/munch/munch.SlackBuild b/python/munch/munch.SlackBuild
index 26401010d1..ff5b848e05 100644
--- a/python/munch/munch.SlackBuild
+++ b/python/munch/munch.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for munch
-# Copyright 2016 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2016-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=munch
-VERSION=${VERSION:-2.2.0}
+VERSION=${VERSION:-2.3.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -64,15 +64,20 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE.txt README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE.txt README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/munch/munch.info b/python/munch/munch.info
index 09eb52bf45..079603995d 100644
--- a/python/munch/munch.info
+++ b/python/munch/munch.info
@@ -1,8 +1,8 @@
PRGNAM="munch"
-VERSION="2.2.0"
+VERSION="2.3.1"
HOMEPAGE="https://github.com/Infinidat/munch"
-DOWNLOAD="https://github.com/Infinidat/munch/archive/2.2.0/munch-2.2.0.tar.gz"
-MD5SUM="a50f0e4d770b5106f0c440a6cff3617f"
+DOWNLOAD="https://github.com/Infinidat/munch/archive/2.3.1/munch-2.3.1.tar.gz"
+MD5SUM="9768b766fb7aa653fda73da08f58c371"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""