summaryrefslogtreecommitdiffstats
path: root/python/odict
diff options
context:
space:
mode:
author Cristiano Urban <cristiano.urban.slack@gmail.com>2019-08-24 07:48:12 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-08-24 07:48:12 +0700
commit2e49de07f7a6ee7c15b1c412280a572f7b979349 (patch)
tree4f3b7258e1f08a83d75b9ca4064fb31ddfec5782 /python/odict
parentb08cefd65bd6cb95a8df5ebfcc6825344b5fb20f (diff)
downloadslackbuilds-2e49de07f7a6ee7c15b1c412280a572f7b979349.tar.gz
slackbuilds-2e49de07f7a6ee7c15b1c412280a572f7b979349.tar.xz
python/odict: Added (ordered dictionary).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/odict')
-rw-r--r--python/odict/README11
-rw-r--r--python/odict/odict.SlackBuild90
-rw-r--r--python/odict/odict.info10
-rw-r--r--python/odict/slack-desc19
4 files changed, 130 insertions, 0 deletions
diff --git a/python/odict/README b/python/odict/README
new file mode 100644
index 0000000000..f760f155a8
--- /dev/null
+++ b/python/odict/README
@@ -0,0 +1,11 @@
+Dictionary in which the insertion order of items is preserved
+(using an internal double linked list). In this implementation
+replacing an existing item keeps it at its original position.
+
+python3 is an optional dependency.
+
+If you want to build the package with python3 support
+you have to pass the PYTHON3 parameter to the script
+as follows:
+
+ PYTHON3=yes ./odict.SlackBuild
diff --git a/python/odict/odict.SlackBuild b/python/odict/odict.SlackBuild
new file mode 100644
index 0000000000..add7ccfe82
--- /dev/null
+++ b/python/odict/odict.SlackBuild
@@ -0,0 +1,90 @@
+#!/bin/sh
+
+# Slackware build script for odict
+
+# Copyright (c) 2017 Cristiano Urban, Gonars, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=odict
+VERSION=${VERSION:-1.7.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+# Install python3 bindings. Default is no.
+if [ "${PYTHON3:-no}" = "yes" ]; then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.rst LICENSE.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/odict/odict.info b/python/odict/odict.info
new file mode 100644
index 0000000000..d0093addcc
--- /dev/null
+++ b/python/odict/odict.info
@@ -0,0 +1,10 @@
+PRGNAM="odict"
+VERSION="1.7.0"
+HOMEPAGE="https://github.com/bluedynamics/odict"
+DOWNLOAD="https://github.com/bluedynamics/odict/archive/1.7.0/odict-1.7.0.tar.gz"
+MD5SUM="a5123a0c2e18df01a2d850dce9bb134b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Cristiano Urban"
+EMAIL="cristiano.urban.slack@gmail.com"
diff --git a/python/odict/slack-desc b/python/odict/slack-desc
new file mode 100644
index 0000000000..6e32db147c
--- /dev/null
+++ b/python/odict/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+odict: odict (ordered dictionary)
+odict:
+odict: Dictionary in which the insertion order of items is preserved
+odict: (using an internal double linked list). In this implementation
+odict: replacing an existing item keeps it at its original position.
+odict:
+odict: Homepage: https://github.com/bluedynamics/odict
+odict:
+odict:
+odict:
+odict: