summaryrefslogtreecommitdiffstats
path: root/python/pattern
diff options
context:
space:
mode:
author Nikolay Korotkiy <sikmir@gmail.com>2013-02-10 01:03:02 -0600
committer Erik Hanson <erik@slackbuilds.org>2013-02-14 00:26:52 -0600
commit25b787c4425bf4971443f7dc2836034fcbb18652 (patch)
tree75cfb04f1e48ec8c44f485c161f9188e889f6760 /python/pattern
parentbb8c10245e5e2f6b7e6c9e14040e9bd7bb0a40ad (diff)
downloadslackbuilds-25b787c4425bf4971443f7dc2836034fcbb18652.tar.gz
slackbuilds-25b787c4425bf4971443f7dc2836034fcbb18652.tar.xz
python/pattern: Added (a web mining module for Python)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'python/pattern')
-rw-r--r--python/pattern/README14
-rw-r--r--python/pattern/pattern.SlackBuild70
-rw-r--r--python/pattern/pattern.info10
-rw-r--r--python/pattern/slack-desc19
4 files changed, 113 insertions, 0 deletions
diff --git a/python/pattern/README b/python/pattern/README
new file mode 100644
index 0000000000..a1c152e8a8
--- /dev/null
+++ b/python/pattern/README
@@ -0,0 +1,14 @@
+Pattern is a web mining module for the Python programming language.
+
+It bundles tools for data retrieval (Google + Twitter + Wikipedia API, web spider,
+HTML DOM parser), text analysis (rule-based shallow parser, WordNet interface,
+syntactical + semantical n-gram search algorithm, tf-idf + cosine similarity +
+LSA metrics), clustering and classification (k-means, k-NN, SVM), and data
+visualization (graph networks).
+
+The module is bundled with 30+ examples and 350+ unit tests.
+
+Pattern is written for Python 2.5+ (no support for Python 3 yet).
+
+The source code is licensed under BSD and available from
+http://www.clips.ua.ac.be/pages/pattern.
diff --git a/python/pattern/pattern.SlackBuild b/python/pattern/pattern.SlackBuild
new file mode 100644
index 0000000000..1454208254
--- /dev/null
+++ b/python/pattern/pattern.SlackBuild
@@ -0,0 +1,70 @@
+#!/bin/sh
+
+# Slackware build script for pattern
+
+# Copyright 2013, Nikolay Korotkiy <sikmir@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pattern
+VERSION=${VERSION:-2.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -eu
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+unzip -o $CWD/$PRGNAM-$VERSION.zip
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE.txt README.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pattern/pattern.info b/python/pattern/pattern.info
new file mode 100644
index 0000000000..820702e11b
--- /dev/null
+++ b/python/pattern/pattern.info
@@ -0,0 +1,10 @@
+PRGNAM="pattern"
+VERSION="2.5"
+HOMEPAGE="https://github.com/clips/pattern"
+DOWNLOAD="http://www.clips.ua.ac.be/media/pattern-2.5.zip"
+MD5SUM="3f7e4e56b3b129e3816ed9ded648e105"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Nikolay Korotkiy"
+EMAIL="sikmir@gmail.com"
diff --git a/python/pattern/slack-desc b/python/pattern/slack-desc
new file mode 100644
index 0000000000..094f7a2c86
--- /dev/null
+++ b/python/pattern/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pattern: pattern (a web mining module for Python)
+pattern:
+pattern: It bundles tools for:
+pattern: - Data Mining
+pattern: - Natural Language Processing
+pattern: - Machine Learning
+pattern: - Network Analysis
+pattern:
+pattern: Homepage: https://github.com/clips/pattern
+pattern:
+pattern: